summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-11-02 15:23:48 -0600
committerMark Wagie2021-11-02 15:23:48 -0600
commite0dd26023f3bb4dc80c6035b4b79b8badbf5b590 (patch)
treec4822284a319744e0d4d5464ecac8537df7865eb
parentdd303b57050125316354c8e73d99c87e27d148b3 (diff)
downloadaur-e0dd26023f3bb4dc80c6035b4b79b8badbf5b590.tar.gz
use signed commit, fix typo
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD21
2 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee9cebe39fc5..a799cdfd1f74 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = system76-driver
pkgdesc = Universal driver for System76 computers
pkgver = 20.04.44
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pop-os/system76-driver
install = system76-driver.install
arch = any
license = GPL
+ makedepends = git
+ makedepends = python-pyflakes
depends = at
depends = dmidecode
depends = ethtool
@@ -37,11 +39,12 @@ pkgbase = system76-driver
optdepends = system76-power: System76 Power Management
optdepends = xorg-xhost: To enable GUI applications on Wayland
optdepends = xorg-xbacklight: To use the backlight service
- source = system76-driver-20.04.44.tar.gz::https://github.com/pop-os/system76-driver/archive/20.04.44.tar.gz
+ source = git+https://github.com/pop-os/system76-driver.git#commit=e10c83da63cee72fdd80991289401e14f3a2efdd?signed
source = cli.patch
source = wayland.patch
source = actions.patch
- sha256sums = f4a9c6703e6c15602f401b7f2f09a10a2406e4b0c92c5b285346fe0dc76b1f67
+ validpgpkeys = DA0878FCF806089ED4FDDF58E988B49EE78A7FB1
+ sha256sums = SKIP
sha256sums = ef027346c439561dc01f906ae7bd961100aedf9125fd86bb0eb89a87b683fdc3
sha256sums = 2ffbd813744c0b99416947a2755767767af434758aa20dcfafefb49fb367d5d3
sha256sums = 3ade740c1681f8f33ef78e1e6c087e4002d14c888d7a5bf6bfbeb2aa70111119
diff --git a/PKGBUILD b/PKGBUILD
index 41b6ea95501f..f65d781addfd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Corey Hinshaw <corey(at)electrickite(dot)org>
pkgname=system76-driver
pkgver=20.04.44
-pkgrel=1
+pkgrel=2
pkgdesc="Universal driver for System76 computers"
arch=('any')
url="https://github.com/pop-os/system76-driver"
@@ -28,7 +28,8 @@ depends=(
'system76-firmware-daemon'
'usbutils'
'wireless_tools')
-makepdepends=(
+makedepends=(
+ 'git'
'python-pyflakes')
optdepends=(
'firmware-manager: Manage System76 firmware updates via standalone application'
@@ -44,19 +45,25 @@ optdepends=(
'xorg-xhost: To enable GUI applications on Wayland'
'xorg-xbacklight: To use the backlight service')
install="$pkgname.install"
+_commit=e10c83da63cee72fdd80991289401e14f3a2efdd
source=(
- "$pkgname-$pkgver.tar.gz::https://github.com/pop-os/system76-driver/archive/$pkgver.tar.gz"
+ "git+https://github.com/pop-os/system76-driver.git#commit=$_commit?signed"
'cli.patch'
'wayland.patch'
'actions.patch')
-sha256sums=('f4a9c6703e6c15602f401b7f2f09a10a2406e4b0c92c5b285346fe0dc76b1f67'
+sha256sums=('SKIP'
'ef027346c439561dc01f906ae7bd961100aedf9125fd86bb0eb89a87b683fdc3'
'2ffbd813744c0b99416947a2755767767af434758aa20dcfafefb49fb367d5d3'
'3ade740c1681f8f33ef78e1e6c087e4002d14c888d7a5bf6bfbeb2aa70111119')
+validpgpkeys=('DA0878FCF806089ED4FDDF58E988B49EE78A7FB1') # Jeremy Soller <jeremy@system76.com>
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed 's/-/+/g'
+}
prepare() {
- cd "$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
# patch for cli version - enable override vendor/model via /etc/system76-daemon.json
patch --no-backup-if-mismatch -Np1 -i $srcdir/cli.patch
@@ -73,12 +80,12 @@ prepare() {
}
build() {
- cd "$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
python setup.py build
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
# Install base package
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build