summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2019-07-23 16:29:52 -0400
committerTony Lambiris2019-07-23 16:29:52 -0400
commit6cc8b793317811d499b631aef0eb3d45fdfa1ee2 (patch)
tree180ab538587a4de1ba8c7e7a0ca1376483b5b29c
parent7673ed7aab756987d2bf1b7b2d52b64c9fe32bd6 (diff)
downloadaur-6cc8b793317811d499b631aef0eb3d45fdfa1ee2.tar.gz
Version bump, run system76-driver-cli post install
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
-rw-r--r--system76-driver-git.install107
3 files changed, 55 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0cf20c3d8a8..c435b164eaca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = system76-driver-git
pkgdesc = System76 Driver for System76 computers
- pkgver = 19.04.9.r1.gfc2fd58
+ pkgver = 19.04.9.r5.g9f315b1
pkgrel = 1
url = https://github.com/pop-os/system76-driver
install = system76-driver-git.install
@@ -16,6 +16,7 @@ pkgbase = system76-driver-git
depends = python-xlib
depends = dmidecode
depends = at
+ depends = tlp
depends = system76-dkms
depends = system76-io-dkms
depends = system76-firmware-daemon
diff --git a/PKGBUILD b/PKGBUILD
index ce34f2f16d7b..feda19346f1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=system76-driver-git
-pkgver=19.04.9.r1.gfc2fd58
+pkgver=19.04.9.r5.g9f315b1
pkgrel=1
pkgdesc="System76 Driver for System76 computers"
arch=('any')
@@ -21,6 +21,7 @@ depends=(
'python-xlib'
'dmidecode'
'at'
+ 'tlp'
'system76-dkms'
'system76-io-dkms'
'system76-firmware-daemon')
diff --git a/system76-driver-git.install b/system76-driver-git.install
index 79820fab8e0f..a837edbc1cae 100644
--- a/system76-driver-git.install
+++ b/system76-driver-git.install
@@ -1,87 +1,82 @@
_services="system76.service"
_stop_services() {
- /usr/bin/systemctl stop $_services >/dev/null 2>&1
+ /usr/bin/systemctl stop $_services
}
_disable_services() {
- /usr/bin/systemctl disable $_services >/dev/null 2>&1
- /usr/bin/systemctl reset-failed $_services >/dev/null 2>&1
+ /usr/bin/systemctl disable $_services
+ /usr/bin/systemctl reset-failed $_services
}
_restore_services() {
- for service in $_services; do
- if /usr/bin/systemctl -q is-enabled $service >/dev/null 2>&1; then
- /usr/bin/systemctl start $service > /dev/null 2>&1
- fi
- done
+ for service in $_services; do
+ if /usr/bin/systemctl -q is-enabled $service; then
+ /usr/bin/systemctl restart $service
+ fi
+ done
}
_remove_symlink() {
- if [ -L $1 ] && [ "$(readlink -f $1)" = "$2" ]; then
- rm $1
- fi
+ if [ -L $1 ] && [ "$(readlink -f $1)" = "$2" ]; then
+ rm $1
+ fi
}
post_install() {
-cat << EOF
+ /usr/bin/system76-driver-cli
- The System76 Driver package provides the following system services:
-
- system76.service System76 airplane-mode hotkey and LED support
-
- And the following user services:
-
- system76-backlight.service Backlight Daemon for NVIDIA 9 Series on GNOME
-
- The backlight service can (optionally) be started automatically:
-
- ln -s /usr/share/applications/system76-driver-backlight.desktop /etc/xdg/autostart/system76-driver-backlight.desktop
-
- GUI applications are provided to install drivers, patches, and firmware updates.
-
- (!) To use system76.service, you must add "ec_sys.write_support=1" to your kernel command line
-
- (!) If you do not use the Grub bootloader, please check output for possible manual actions required for
- your model related to bootloader modifications.
-
- (!) For Clevo W740SU BIOS/Firmware users on Galago UltraPro: your will need to create /etc/system76-daemon.json
- file with following content:
-
- { "vendor": "System76, Inc", "model": "galu1" }
-
- (!) If you experience Wifi issues after resuming from suspend, consider using the included network
- restart script:
-
- ln -s /usr/lib/system76-driver/system76-nm-restart /lib/systemd/system-sleep/system76-nm-restart
-
-EOF
+ printf "%b\n" "$postmessage"
}
pre_upgrade() {
- _stop_services
+ _stop_services
}
post_upgrade() {
- /usr/bin/systemctl daemon-reload >/dev/null 2>&1
- _restore_services
- post_install
+ /usr/bin/systemctl daemon-reload
+
+ _restore_services
+ post_install
}
pre_remove() {
- _stop_services
- _disable_services
+ _stop_services
+ _disable_services
- # Remove symlinks if target points to package files
- _remove_symlink /etc/xdg/autostart/system76-driver-backlight.desktop /usr/share/applications/system76-driver-backlight.desktop
- _remove_symlink /lib/systemd/system-sleep/system76-nm-restart /usr/lib/system76-driver/system76-nm-restart
+ # Remove symlinks if target points to package files
+ _remove_symlink /etc/xdg/autostart/system76-driver-backlight.desktop /usr/share/applications/system76-driver-backlight.desktop
+ _remove_symlink /lib/systemd/system-sleep/system76-nm-restart /usr/lib/system76-driver/system76-nm-restart
}
post_remove() {
- /usr/bin/systemctl daemon-reload >/dev/null 2>&1
- cat << EOF
-
- Be sure to stop and disable all running System76 user services.
+ /usr/bin/systemctl daemon-reload
-EOF
+ echo "Be sure to stop and disable all running System76 user services."
}
+
+read -d '' postmessage <<-EOT
+--------------------------------------------------------------------------------
+The System76 Driver package provides the following system services:
+ system76.service System76 airplane-mode hotkey and LED support
+
+And the following user services:
+ system76-backlight.service Backlight Daemon for NVIDIA 9 Series on GNOME
+
+The backlight service can (optionally) be started automatically:
+ ln -s /usr/share/applications/system76-driver-backlight.desktop /etc/xdg/autostart/system76-driver-backlight.desktop
+
+GUI applications are provided to install drivers, patches, and firmware updates.
+
+(!) To use system76.service, you must add "ec_sys.write_support=1" to your kernel command line
+
+(!) If you do not use the Grub bootloader, please check output for possible manual actions required for
+ your model related to bootloader modifications.
+
+(!) For Clevo W740SU BIOS/Firmware users on Galago UltraPro: your will need to create /etc/system76-daemon.json file with following content:
+ { "vendor": "System76, Inc", "model": "galu1" }
+
+(!) If you experience Wifi issues after resuming from suspend, consider using the included network restart script:
+ ln -s /usr/lib/system76-driver/system76-nm-restart /lib/systemd/system-sleep/system76-nm-restart
+--------------------------------------------------------------------------------
+EOT