summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-09-20 13:55:30 -0600
committerMark Wagie2023-09-20 13:55:30 -0600
commit1c37265baf141eefe6ffb731ec111de11f7c4118 (patch)
tree850476cb6f88f700c7f16feb18e123212e17e31f
parentf7e81321c9240ca519c98264ddbe4e8564bca457 (diff)
downloadaur-1c37265baf141eefe6ffb731ec111de11f7c4118.tar.gz
1.0.3
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da10ac7a18b0..209072d4ca35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = system76-io-dkms
pkgdesc = DKMS module for controlling System76 Io board
- pkgver = 1.0.2
+ pkgver = 1.0.3
pkgrel = 1
url = https://github.com/pop-os/system76-io-dkms
arch = x86_64
license = GPL3
makedepends = git
depends = dkms
- source = git+https://github.com/pop-os/system76-io-dkms.git#commit=0217576dd5a14d68c8c9e7253f198ffbf735e283?signed
- validpgpkeys = DA0878FCF806089ED4FDDF58E988B49EE78A7FB1
+ source = git+https://github.com/pop-os/system76-io-dkms.git#commit=0f86350b4f608f0dca7d87ab95d035137995b88d
sha256sums = SKIP
pkgname = system76-io-dkms
diff --git a/PKGBUILD b/PKGBUILD
index fb16cc9499b3..6167e0e1f033 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Corey Hinshaw <coreyhinshaw(at)gmail(dot)com>
pkgname=system76-io-dkms
_modname=system76-io
-pkgver=1.0.2
+pkgver=1.0.3
pkgrel=1
pkgdesc="DKMS module for controlling System76 Io board"
arch=('x86_64')
@@ -10,10 +10,10 @@ url="https://github.com/pop-os/system76-io-dkms"
license=('GPL3')
depends=('dkms')
makedepends=('git')
-_commit=0217576dd5a14d68c8c9e7253f198ffbf735e283
-source=("git+https://github.com/pop-os/system76-io-dkms.git#commit=$_commit?signed")
+_commit=0f86350b4f608f0dca7d87ab95d035137995b88d # tags/1.0.3^0
+source=("git+https://github.com/pop-os/system76-io-dkms.git#commit=${_commit}")
sha256sums=('SKIP')
-validpgpkeys=('DA0878FCF806089ED4FDDF58E988B49EE78A7FB1') # Jeremy Soller <jeremy@system76.com>
+#validpgpkeys=('DA0878FCF806089ED4FDDF58E988B49EE78A7FB1') # Jeremy Soller <jeremy@system76.com>
pkgver() {
cd "$srcdir/$pkgname"
@@ -23,17 +23,15 @@ pkgver() {
package() {
cd "$srcdir/$pkgname"
- # Installation directory
- local install_dir="$pkgdir/usr/src/system76-io-$pkgver"
-
# Install source files
for file in {Makefile,*.c,*.h}; do
- [ -f "$file" ] || continue
- install -D -m644 -t "$install_dir/" "$file"
+ [ -f "${file}" ] || continue
+ install -D -m644 -t "$pkgdir/usr/src/system76-io-$pkgver/" "${file}"
done
# Edit and install dkms configuration
- sed "s/#MODULE_VERSION#/$pkgver/" "debian/system76-io-dkms.dkms" > "$install_dir/dkms.conf"
+ sed "s/#MODULE_VERSION#/$pkgver/" "debian/system76-io-dkms.dkms" > \
+ "$pkgdir/usr/src/system76-io-$pkgver/dkms.conf"
# Load the module at boot
install -Dm644 "usr/share/initramfs-tools/modules.d/$pkgname.conf" \