summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Hinshaw2018-12-03 14:38:23 -0500
committerCorey Hinshaw2018-12-03 14:38:23 -0500
commit35ad755648039bb9f1d6b9dbf0ddaefe45b91ad0 (patch)
treef930aea328313807723bc2a194da76a339728ecc
downloadaur-35ad755648039bb9f1d6b9dbf0ddaefe45b91ad0.tar.gz
Initial commit, version 0.0.1 from commit hash
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
-rw-r--r--system76-io.conf2
4 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c357d8f724ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = system76-io-dkms
+ pkgdesc = This DKMS driver controls System76 Io devices
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/pop-os/system76-io-dkms
+ arch = x86_64
+ license = GPL3
+ depends = dkms
+ source = https://github.com/pop-os/system76-io-dkms/archive/d7ec9914ea0aee4af22ff7ace5cba697a95309aa.tar.gz
+ source = system76-io.conf
+ sha256sums = 5791cd88485da3ac714ebf069eafe68266c46f87be911500cab2308e34436941
+ sha256sums = aac9100aba28a0a6716b6b2012858ce996a5f710e1f1e02628da1cff2ef2bdd2
+
+pkgname = system76-io-dkms
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0cced017d91a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+*.tar.gz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f15436b3bb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Corey Hinshaw <coreyhinshaw(at)gmail(dot)com>
+
+pkgname=system76-io-dkms
+pkgver=0.0.1
+_commit="d7ec9914ea0aee4af22ff7ace5cba697a95309aa"
+pkgrel=1
+pkgdesc="This DKMS driver controls System76 Io devices"
+arch=('x86_64')
+url="https://github.com/pop-os/system76-io-dkms"
+license=('GPL3')
+depends=('dkms')
+source=("https://github.com/pop-os/${pkgname}/archive/${_commit}.tar.gz"
+ "system76-io.conf")
+sha256sums=("5791cd88485da3ac714ebf069eafe68266c46f87be911500cab2308e34436941"
+ "aac9100aba28a0a6716b6b2012858ce996a5f710e1f1e02628da1cff2ef2bdd2")
+
+package() {
+ # Installation directory
+ local install_dir="${pkgdir}/usr/src/${pkgname}-${pkgver}"
+
+ cd ${srcdir}/${pkgname}-${_commit}
+
+ # Install source files
+ for file in {Makefile,*.c,*.h}; do
+ [ -f "$file" ] || continue
+ install -D -m644 -t "${install_dir}/" "${file}"
+ done
+
+ # Edit and install dkms configuration
+ sed "s/#MODULE_VERSION#/${pkgver}/" "debian/system76-io-dkms.dkms" > "${install_dir}/dkms.conf"
+
+ # Load the module at boot
+ install -Dm644 ${srcdir}/system76-io.conf ${pkgdir}/etc/modules-load.d/system76-io.conf
+}
diff --git a/system76-io.conf b/system76-io.conf
new file mode 100644
index 000000000000..a1cdbcec074a
--- /dev/null
+++ b/system76-io.conf
@@ -0,0 +1,2 @@
+# Load the system76-io driver module
+system76-io