summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-02-03 17:48:29 -0700
committerMark Wagie2021-02-03 17:48:29 -0700
commit6995f5d1ce4adce863456ec07ce2ac2592e947f5 (patch)
tree35ba94826e3a405e3e49599caea544b401e9afd6
parentc41971595c8e75789ef84b0a007ff686b57c2a2f (diff)
downloadaur-6995f5d1ce4adce863456ec07ce2ac2592e947f5.tar.gz
PKGBUILD improvements
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD32
3 files changed, 26 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dd4a47d2617..3af5b43716f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = system76-io-dkms
- pkgdesc = This DKMS driver controls System76 IO devices
+ pkgdesc = DKMS module for controlling System76 Io board
pkgver = 1.0.1
pkgrel = 1
url = https://github.com/pop-os/system76-io-dkms
arch = x86_64
license = GPL3
depends = dkms
- source = https://github.com/pop-os/system76-io-dkms/archive/1.0.1.tar.gz
+ source = system76-io-dkms-1.0.1.tar.gz::https://github.com/pop-os/system76-io-dkms/archive/1.0.1.tar.gz
source = system76-io.conf
sha256sums = 492b334c0861af0e3627eb8f9f25690ba1dc617ba743a4f25ca02740de26db26
sha256sums = aac9100aba28a0a6716b6b2012858ce996a5f710e1f1e02628da1cff2ef2bdd2
diff --git a/.gitignore b/.gitignore
index 0cced017d91a..0f0e282cf6bd 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,8 @@
-*.tar.xz
-*.tar.gz
-/pkg
-/src
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!system76-io.conf
diff --git a/PKGBUILD b/PKGBUILD
index e403ecc445e8..81ab9a97d631 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,34 @@
-# Maintainer: Corey Hinshaw <coreyhinshaw(at)gmail(dot)com>
-
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Corey Hinshaw <coreyhinshaw(at)gmail(dot)com>
pkgname=system76-io-dkms
_modname=system76-io
pkgver=1.0.1
pkgrel=1
-pkgdesc="This DKMS driver controls System76 IO devices"
+pkgdesc="DKMS module for controlling System76 Io board"
arch=('x86_64')
url="https://github.com/pop-os/system76-io-dkms"
license=('GPL3')
depends=('dkms')
-source=("https://github.com/pop-os/${pkgname}/archive/${pkgver}.tar.gz"
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
"system76-io.conf")
sha256sums=("492b334c0861af0e3627eb8f9f25690ba1dc617ba743a4f25ca02740de26db26"
"aac9100aba28a0a6716b6b2012858ce996a5f710e1f1e02628da1cff2ef2bdd2")
package() {
- # Installation directory
- local install_dir="${pkgdir}/usr/src/${_modname}-${pkgver}"
+ # Installation directory
+ local install_dir="$pkgdir/usr/src/system76-io-$pkgver"
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "$pkgname-$pkgver"
- # Install source files
- for file in {Makefile,*.c,*.h}; do
- [ -f "$file" ] || continue
- install -D -m644 -t "${install_dir}/" "${file}"
- done
+ # Install source files
+ for file in {Makefile,*.c,*.h}; do
+ [ -f "$file" ] || continue
+ install -D -m644 -t "$install_dir/" "$file"
+ done
- # Edit and install dkms configuration
- sed "s/#MODULE_VERSION#/${pkgver}/" "debian/system76-io-dkms.dkms" > "${install_dir}/dkms.conf"
+ # Edit and install dkms configuration
+ sed "s/#MODULE_VERSION#/$pkgver/" "debian/system76-io-dkms.dkms" > "$install_dir/dkms.conf"
- # Load the module at boot
- install -Dm644 ${srcdir}/system76-io.conf ${pkgdir}/etc/modules-load.d/system76-io.conf
+ # Load the module at boot
+ install -Dm644 $srcdir/system76-io.conf -t "$pkgdir/etc/modules-load.d"
}