summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-09-22 03:44:12 -0400
committerTony Lambiris2018-09-22 03:44:12 -0400
commit65fb59faecc637dea4154c9cd685261c9a667fa3 (patch)
tree2285af1036b9a2c0e458e873f1286f170906567a
downloadaur-65fb59faecc637dea4154c9cd685261c9a667fa3.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
-rw-r--r--system76-io.conf2
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f85f3ca7f54a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = system76-io-dkms-git
+ pkgdesc = This DKMS driver provides airplane mode, keyboard backlight, and fan support for System76 laptops
+ pkgver = 13
+ pkgrel = 1
+ url = https://github.com/pop-os/system76-io-dkms
+ arch = x86_64
+ license = GPL3
+ depends = dkms
+ source = system76-io-dkms::git+https://github.com/pop-os/system76-io-dkms.git
+ source = system76-io.conf
+ sha256sums = SKIP
+ sha256sums = aac9100aba28a0a6716b6b2012858ce996a5f710e1f1e02628da1cff2ef2bdd2
+
+pkgname = system76-io-dkms-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59ddeb9c826b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
+
+pkgname=system76-io-dkms-git
+_pkgname=system76-io-dkms
+pkgver=13
+pkgrel=1
+pkgdesc="This DKMS driver provides airplane mode, keyboard backlight, and fan support for System76 laptops"
+arch=('x86_64')
+url="https://github.com/pop-os/system76-io-dkms"
+license=('GPL3')
+depends=('dkms')
+source=("${_pkgname}::git+https://github.com/pop-os/${_pkgname}.git"
+ 'system76-io.conf')
+sha256sums=('SKIP'
+ 'aac9100aba28a0a6716b6b2012858ce996a5f710e1f1e02628da1cff2ef2bdd2')
+
+pkgver() {
+ cd ${srcdir}/${_pkgname}
+ git rev-list --count HEAD
+}
+
+
+package() {
+ # Installation directory
+ local install_dir="${pkgdir}/usr/src/${_pkgname}-${pkgver}"
+
+ cd "${srcdir}/${_pkgname}"
+
+ # Install source files
+ for file in {Makefile,*.c,*.h}; do
+ [ -f "$file" ] || continue
+ install -D -m644 -t "${install_dir}/" "${file}"
+ done
+
+ # Edit and install dkms configuration
+ sed "s/#MODULE_VERSION#/${pkgver}/" "debian/system76-io-dkms.dkms" > "${install_dir}/dkms.conf"
+
+ # Load the module at boot
+ install -Dm644 ${srcdir}/system76-io.conf ${pkgdir}/etc/modules-load.d/system76-io.conf
+}
diff --git a/system76-io.conf b/system76-io.conf
new file mode 100644
index 000000000000..a1cdbcec074a
--- /dev/null
+++ b/system76-io.conf
@@ -0,0 +1,2 @@
+# Load the system76-io driver module
+system76-io