summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2019-06-10 06:26:50 -0400
committerTony Lambiris2019-06-10 06:26:50 -0400
commit7c98d82059a502649c31211edcb47d5e77c15beb (patch)
tree7a1687a3be7900cf620c5a65aaafe6dc42d63dd5
parent1138dc8f7e48a564c4b59036bc9decf8da771798 (diff)
downloadaur-7c98d82059a502649c31211edcb47d5e77c15beb.tar.gz
Version bump
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD13
3 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af9a46bc7ca1..12b3f16f0cb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = system76-io-dkms-git
pkgdesc = This DKMS driver provides airplane mode, keyboard backlight, and fan support for System76 laptops
- pkgver = r20.e58ff7f
- pkgrel = 2
+ pkgver = r26.ea5f61a
+ pkgrel = 1
url = https://github.com/pop-os/system76-io-dkms
arch = x86_64
license = GPL3
depends = dkms
provides = system76-io-dkms
conflicts = system76-io-dkms
- source = system76-io-dkms::git+https://github.com/pop-os/system76-io-dkms.git
+ source = system76-io-dkms-git::git+https://github.com/pop-os/system76-io-dkms
source = system76-io.conf
sha256sums = SKIP
sha256sums = aac9100aba28a0a6716b6b2012858ce996a5f710e1f1e02628da1cff2ef2bdd2
diff --git a/.gitignore b/.gitignore
index df4784ff93ff..0b12ace54a15 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
src
pkg
-system76-io-dkms
+system76-io-dkms-git
*pkg.tar.xz
tags
diff --git a/PKGBUILD b/PKGBUILD
index 6a34b47a4321..b6f3608dd0a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=system76-io-dkms-git
-_pkgname=system76-io-dkms
-pkgver=r20.e58ff7f
-pkgrel=2
+pkgver=r26.ea5f61a
+pkgrel=1
pkgdesc="This DKMS driver provides airplane mode, keyboard backlight, and fan support for System76 laptops"
arch=('x86_64')
url="https://github.com/pop-os/system76-io-dkms"
@@ -11,13 +10,13 @@ license=('GPL3')
depends=('dkms')
conflicts=(system76-io-dkms)
provides=(system76-io-dkms)
-source=("${_pkgname}::git+https://github.com/pop-os/${_pkgname}.git"
+source=("${pkgname}::git+https://github.com/pop-os/system76-io-dkms"
'system76-io.conf')
sha256sums=('SKIP'
'aac9100aba28a0a6716b6b2012858ce996a5f710e1f1e02628da1cff2ef2bdd2')
pkgver() {
- cd ${srcdir}/${_pkgname}
+ cd ${srcdir}/${pkgname}
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
@@ -25,9 +24,9 @@ pkgver() {
package() {
# Installation directory
- local install_dir="${pkgdir}/usr/src/${_pkgname}-${pkgver}"
+ local install_dir="${pkgdir}/usr/src/${pkgname%%-git}-${pkgver}"
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${pkgname}"
# Install source files
for file in {Makefile,*.c,*.h}; do