summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Hinshaw2019-10-11 09:43:25 -0400
committerCorey Hinshaw2019-10-11 09:43:25 -0400
commitd567fb2c1dd89a9ef34ff5c8ef3025d6e018a89a (patch)
tree5a349fc41eb44a36ed52634a9d78b736d1fdfb8a
downloadaur-d567fb2c1dd89a9ef34ff5c8ef3025d6e018a89a.tar.gz
Initial commit - version 0.1.3
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..190cbf729b6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = system76-oled
+ pkgdesc = Control brightness on System76 OLED displays
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/pop-os/system76-oled
+ arch = x86_64
+ license = GPL3
+ depends = rust
+ depends = dbus
+ depends = libx11
+ depends = libxrandr
+ source = https://github.com/pop-os/system76-oled/archive/0.1.3.tar.gz
+ sha256sums = af99b853c309bae06114aa3a49ab86a31db44d55b5e074d8a560854150d60f9d
+
+pkgname = system76-oled
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0cced017d91a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+*.tar.gz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2039c08c8ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Corey Hinshaw <corey(at)electrickite(dot)org>
+
+pkgname=system76-oled
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Control brightness on System76 OLED displays"
+arch=('x86_64')
+url="https://github.com/pop-os/system76-oled"
+license=('GPL3')
+depends=('rust' 'dbus' 'libx11' 'libxrandr')
+source=("https://github.com/pop-os/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('af99b853c309bae06114aa3a49ab86a31db44d55b5e074d8a560854150d60f9d')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make clean prefix=/usr
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="$pkgdir/" install prefix=/usr
+}
+