summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Soto2018-09-24 11:49:32 -0700
committerFrancisco Soto2018-09-24 11:49:32 -0700
commit1ba8625f3672491d3f08fef838f9d49aef7e45df (patch)
tree08cad3096bb30241c8a1ac1039286d5f187aba09
parentd3237463507271353b8081ab3dfe616b83f37efc (diff)
downloadaur-1ba8625f3672491d3f08fef838f9d49aef7e45df.tar.gz
Updated to version 113-1. main.rs needs no patch.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--main.patch38
3 files changed, 4 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24eac4ebf71e..49ca3329f77e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = system76-power-git
pkgdesc = System76 Power Management
- pkgver = 111
- pkgrel = 2
+ pkgver = 113
+ pkgrel = 1
url = https://github.com/pop-os/system76-power
install = system76-power-git.install
arch = any
@@ -13,10 +13,8 @@ pkgbase = system76-power-git
conflicts = system76-power
source = system76::git+https://github.com/pop-os/system76-power.git#branch=master
source = graphics.patch
- source = main.patch
sha1sums = SKIP
sha1sums = e486644709099b6348dc96d5f468ae289840dade
- sha1sums = 84d590e0f15ac601a74ab09ac7206a62c81edb84
pkgname = system76-power-git
diff --git a/PKGBUILD b/PKGBUILD
index 8c2c730d4ee6..c63d23b559e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=system76
_pkgbase=system76-power
pkgname=system76-power-git
-pkgver=111
-pkgrel=2
+pkgver=113
+pkgrel=1
pkgdesc="System76 Power Management"
arch=('any')
url="https://github.com/pop-os/system76-power"
@@ -21,12 +21,10 @@ makedepends=('rust')
source=(
'system76::git+https://github.com/pop-os/system76-power.git#branch=master'
'graphics.patch'
- 'main.patch'
)
sha1sums=(
'SKIP'
'e486644709099b6348dc96d5f468ae289840dade'
- '84d590e0f15ac601a74ab09ac7206a62c81edb84'
)
pkgver() {
@@ -37,7 +35,6 @@ pkgver() {
build() {
cd ${startdir}
patch -p0 < ${startdir}/graphics.patch
- patch -p0 < ${startdir}/main.patch
cd ${srcdir}/${_pkgname}
diff --git a/main.patch b/main.patch
deleted file mode 100644
index fda09c86b85e..000000000000
--- a/main.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/system76/src/main.rs 2018-09-21 21:38:37.639982440 -0700
-+++ src/system76/src/main.rs.new 2018-09-21 21:38:34.933315808 -0700
-@@ -110,22 +110,21 @@
- )
- )
- .get_matches();
--
-- if let Err(why) = logging::setup_logging(
-- if matches.is_present("verbose") {
-- LevelFilter::Debug
-- } else if matches.is_present("quiet") {
-- LevelFilter::Off
-- } else {
-- LevelFilter::Info
-- }
-- ) {
-- eprintln!("failed to set up logging: {}", why);
-- process::exit(1);
-- }
-
- let res = match matches.subcommand() {
-- ("daemon", Some(_matches)) => {
-+ ("daemon", Some(matches)) => {
-+ if let Err(why) = logging::setup_logging(
-+ if matches.is_present("verbose") {
-+ LevelFilter::Debug
-+ } else if matches.is_present("quiet") {
-+ LevelFilter::Off
-+ } else {
-+ LevelFilter::Info
-+ }
-+ ) {
-+ eprintln!("failed to set up logging: {}", why);
-+ process::exit(1);
-+ }
- if unsafe { libc::geteuid() } == 0 {
- daemon::daemon(matches.is_present("experimental"))
- } else {