summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2019-05-21 15:54:07 -0400
committerTony Lambiris2019-05-21 15:54:07 -0400
commit7ac5dd9f868f929486afaebe6bab77f967eeb1a2 (patch)
tree0d79486f58fba394e6a1b2db599c73984c177184
parentb1b30e768e5b8690a297c4a81f73f1a0f31988c2 (diff)
downloadaur-7ac5dd9f868f929486afaebe6bab77f967eeb1a2.tar.gz
Version bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--graphics.patch45
3 files changed, 17 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cceacd4c82c..3c4659a41238 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = system76-power-git
pkgdesc = System76 Power Management
- pkgver = r168.99e80af
+ pkgver = r185.1d361ba
pkgrel = 1
url = https://github.com/pop-os/system76-power
install = system76-power-git.install
@@ -16,7 +16,7 @@ pkgbase = system76-power-git
source = system76-power-git::git+https://github.com/pop-os/system76-power.git
source = graphics.patch
sha256sums = SKIP
- sha256sums = c951b97d420bd3e26178b404a24ae334cae54f96ca4930f53ce1d0bc8f83d1dc
+ sha256sums = c44423e11bbe3f045203ef5b836f64151728aec0762d798295a1787092fecf1b
pkgname = system76-power-git
diff --git a/PKGBUILD b/PKGBUILD
index e518b3ba1010..19ad000317ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=system76-power-git
-pkgver=r168.99e80af
+pkgver=r185.1d361ba
pkgrel=1
pkgdesc="System76 Power Management"
arch=('any')
@@ -15,7 +15,7 @@ depends=('dbus' 'systemd' 'system76-dkms')
source=("${pkgname}::git+https://github.com/pop-os/system76-power.git"
"graphics.patch")
sha256sums=('SKIP'
- 'c951b97d420bd3e26178b404a24ae334cae54f96ca4930f53ce1d0bc8f83d1dc')
+ 'c44423e11bbe3f045203ef5b836f64151728aec0762d798295a1787092fecf1b')
pkgver() {
cd ${pkgname}
diff --git a/graphics.patch b/graphics.patch
index 6117411b2223..e9ba30e4cbc6 100644
--- a/graphics.patch
+++ b/graphics.patch
@@ -1,37 +1,18 @@
diff --git a/src/graphics.rs b/src/graphics.rs
-index 6ff9020..e9a44ad 100644
+index d9d8af7..a8cb466 100644
--- a/src/graphics.rs
+++ b/src/graphics.rs
-@@ -14,11 +14,11 @@ blacklist nouveau
- blacklist nvidia
- blacklist nvidia-drm
- blacklist nvidia-modeset
--alias i2c_nvidia_gpu off
--alias nouveau off
--alias nvidia off
--alias nvidia-drm off
--alias nvidia-modeset off
-+#alias i2c_nvidia_gpu off
-+#alias nouveau off
-+#alias nvidia off
-+#alias nvidia-drm off
-+#alias nvidia-modeset off
- "#;
+@@ -248,10 +248,10 @@ impl Graphics {
+ warn!("systemctl: failed with {} (not an error if service does not exist!)", status);
+ }
- pub struct GraphicsDevice {
-@@ -204,12 +204,12 @@ impl Graphics {
- }
- }
-
-- info!("Updating initramfs");
-- let status = process::Command::new("update-initramfs").arg("-u").status()?;
-+ info!("Updating mkinitcpio");
-+ let status = process::Command::new("mkinitcpio").arg("-P").status()?;
- if ! status.success() {
- return Err(io::Error::new(
- io::ErrorKind::Other,
-- format!("update-initramfs: failed with {}", status)
-+ format!("mkinitcpio: failed with {}", status)
- ));
- }
+- info!("Updating initramfs");
+- const UPDATE_INITRAMFS_CMD: &str = "update-initramfs";
++ info!("Updating mkinitcpio");
++ const UPDATE_INITRAMFS_CMD: &str = "mkinitcpio";
+ let status = process::Command::new(UPDATE_INITRAMFS_CMD)
+- .arg("-u")
++ .arg("-P")
+ .status()
+ .map_err(|why| GraphicsDeviceError::Command { cmd: UPDATE_INITRAMFS_CMD, why })?;