summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2021-10-09 18:35:09 -0400
committerTony Lambiris2021-10-09 18:35:09 -0400
commitb2f2a35e4959187b635f21f8a60e43aa9800d57d (patch)
tree9b36dad02b717c7243dcc1dbf98e8593dd5877e0
parent6b4d9bbe19e77eefafbe7514e1e7021853fbc8b0 (diff)
downloadaur-b2f2a35e4959187b635f21f8a60e43aa9800d57d.tar.gz
Version bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--makefile.patch6
-rw-r--r--mkinitcpio.patch17
4 files changed, 24 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c70c70a172e8..8c9847dc1bbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = system76-power-git
pkgdesc = System76 Power Management
- pkgver = 1.1.17.r1.g82bf0f4
+ pkgver = 1.1.18.r12.g94b057e
pkgrel = 1
url = https://github.com/pop-os/system76-power
arch = any
@@ -16,7 +16,7 @@ pkgbase = system76-power-git
source = makefile.patch
source = mkinitcpio.patch
sha256sums = SKIP
- sha256sums = 97deb1f9cf6a312e8378bb96a4a83dae2498a4936c130e2ef5b125d13b92bb65
- sha256sums = 2ead269c71919c220a7880b0036c6d62aadeae3d6cde769029784d3565686539
+ sha256sums = 59c2b6a4ee4d5bf728d8f68fd9c066ba33cf9c91bf173bf16734924f6e641643
+ sha256sums = fefd4bd1c173cca2aafd3d5f03af20b9cfc5553f9a53f510a12d565cc90fe7ba
pkgname = system76-power-git
diff --git a/PKGBUILD b/PKGBUILD
index 3df6364a2f12..cfac0f270d8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Tony Lambiris <tony@libpcap.net>
pkgname=system76-power-git
-pkgver=1.1.17.r1.g82bf0f4
+pkgver=1.1.18.r12.g94b057e
pkgrel=1
pkgdesc="System76 Power Management"
arch=('any')
-url="https://github.com/pop-os/system76-power"
+url='https://github.com/pop-os/system76-power'
license=('GPL')
-conflicts=("system76-power")
-provides=("system76-power")
+conflicts=('system76-power')
+provides=('system76-power')
makedepends=('git' 'rust')
depends=('dbus' 'systemd' 'system76-dkms')
source=("${pkgname}::git+https://github.com/pop-os/system76-power.git"
"makefile.patch"
"mkinitcpio.patch")
sha256sums=('SKIP'
- '97deb1f9cf6a312e8378bb96a4a83dae2498a4936c130e2ef5b125d13b92bb65'
- '2ead269c71919c220a7880b0036c6d62aadeae3d6cde769029784d3565686539')
+ '59c2b6a4ee4d5bf728d8f68fd9c066ba33cf9c91bf173bf16734924f6e641643'
+ 'fefd4bd1c173cca2aafd3d5f03af20b9cfc5553f9a53f510a12d565cc90fe7ba')
pkgver() {
cd "${srcdir}/${pkgname}"
diff --git a/makefile.patch b/makefile.patch
index c60736d50d62..b6408000404a 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -1,10 +1,14 @@
+diff --git a/Makefile b/Makefile
+index eae8b9b..e431741 100644
--- a/Makefile
+++ b/Makefile
-@@ -35,7 +35,7 @@ distclean:
+@@ -36,8 +36,8 @@ distclean:
install: all
install -D -m 0755 "target/release/$(BIN)" "$(DESTDIR)$(bindir)/$(BIN)"
+- install -D -m 0644 "data/$(RDD).xml" "$(DESTDIR)$(sysconfdir)/dbus-1/interfaces/$(RDD).xml"
- install -D -m 0644 "data/$(BIN).conf" "$(DESTDIR)$(sysconfdir)/dbus-1/system.d/$(BIN).conf"
++ install -D -m 0644 "data/$(RDD).xml" "$(DESTDIR)$(datadir)/dbus-1/interfaces/$(RDD).xml"
+ install -D -m 0644 "data/$(BIN).conf" "$(DESTDIR)$(datadir)/dbus-1/system.d/$(BIN).conf"
install -D -m 0644 "debian/$(BIN).service" "$(DESTDIR)$(sysconfdir)/systemd/system/$(BIN).service"
install -D -m 0644 "data/$(POLICY).policy" $(DESTDIR)$(datadir)/polkit-1/actions/$(POLICY).policy
diff --git a/mkinitcpio.patch b/mkinitcpio.patch
index fee4a47c8677..8952285be491 100644
--- a/mkinitcpio.patch
+++ b/mkinitcpio.patch
@@ -1,17 +1,19 @@
+diff --git a/src/graphics.rs b/src/graphics.rs
+index ebdd9b6..7223a6e 100644
--- a/src/graphics.rs
+++ b/src/graphics.rs
-@@ -76,7 +76,7 @@ pub enum GraphicsDeviceError {
+@@ -80,7 +80,7 @@ pub enum GraphicsDeviceError {
SysFs(io::Error),
- #[error(display = "failed to unbind {} on PCI driver {}: {}", func, driver, why)]
+ #[error("failed to unbind {} on PCI driver {}: {}", func, driver, why)]
Unbind { func: String, driver: String, why: io::Error },
-- #[error(display = "update-initramfs failed with {} status", _0)]
-+ #[error(display = "failed to update initramfs: exit status {}", _0)]
+- #[error("update-initramfs failed with {} status", _0)]
++ #[error("initramfs update failed with {} status", _0)]
UpdateInitramfs(ExitStatus),
}
-
-@@ -423,9 +423,9 @@ impl Graphics {
+
+@@ -427,9 +427,9 @@ impl Graphics {
}
-
+
log::info!("Updating initramfs");
- const UPDATE_INITRAMFS_CMD: &str = "update-initramfs";
+ const UPDATE_INITRAMFS_CMD: &str = "mkinitcpio";
@@ -20,3 +22,4 @@
+ .arg("-P")
.status()
.map_err(|why| GraphicsDeviceError::Command { cmd: UPDATE_INITRAMFS_CMD, why })?;
+