summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2019-04-16 15:00:31 -0400
committerTony Lambiris2019-04-16 15:00:31 -0400
commitf795f9087d586adfdb5b4d192ee6f3edd77e24ea (patch)
tree9cd745750627747bb36fad2d4101e09f295edfe3
parent1ba8625f3672491d3f08fef838f9d49aef7e45df (diff)
downloadaur-f795f9087d586adfdb5b4d192ee6f3edd77e24ea.tar.gz
Version bump
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD62
-rw-r--r--graphics.patch14
4 files changed, 49 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49ca3329f77e..196f73aca5e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = system76-power-git
pkgdesc = System76 Power Management
- pkgver = 113
+ pkgver = r160.1c347b8
pkgrel = 1
url = https://github.com/pop-os/system76-power
install = system76-power-git.install
arch = any
license = GPL
+ makedepends = git
makedepends = rust
depends = dbus
depends = systemd
depends = system76-dkms
+ provides = system76-power
conflicts = system76-power
- source = system76::git+https://github.com/pop-os/system76-power.git#branch=master
+ source = system76-power-git::git+https://github.com/pop-os/system76-power.git
source = graphics.patch
- sha1sums = SKIP
- sha1sums = e486644709099b6348dc96d5f468ae289840dade
+ sha256sums = SKIP
+ sha256sums = c951b97d420bd3e26178b404a24ae334cae54f96ca4930f53ce1d0bc8f83d1dc
pkgname = system76-power-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..eb5975da7b15
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+system76-power-git
+*pkg.tar.xz
+tags
diff --git a/PKGBUILD b/PKGBUILD
index c63d23b559e6..b5da3eb86a55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,50 @@
-# Maintainer: Francisco Soto <ebobby(at)ebobby(dot)org>
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
-_pkgname=system76
-_pkgbase=system76-power
pkgname=system76-power-git
-pkgver=113
+pkgver=r160.1c347b8
pkgrel=1
pkgdesc="System76 Power Management"
arch=('any')
url="https://github.com/pop-os/system76-power"
license=('GPL')
-install="${pkgname}.install"
+install=system76-power-git.install
conflicts=("system76-power")
-makedepends=('git')
-depends=(
- 'dbus'
- 'systemd'
- 'system76-dkms'
-)
-makedepends=('rust')
-source=(
- 'system76::git+https://github.com/pop-os/system76-power.git#branch=master'
- 'graphics.patch'
- )
-sha1sums=(
- 'SKIP'
- 'e486644709099b6348dc96d5f468ae289840dade'
-)
+provides=("system76-power")
+makedepends=('git' 'rust')
+depends=('dbus' 'systemd' 'system76-dkms')
+source=("${pkgname}::git+https://github.com/pop-os/system76-power.git"
+ "graphics.patch")
+sha256sums=('SKIP'
+ 'c951b97d420bd3e26178b404a24ae334cae54f96ca4930f53ce1d0bc8f83d1dc')
pkgver() {
- cd ${srcdir}/${_pkgname}
- git rev-list --count HEAD
+ cd ${pkgname}
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname}
+
+ patch -p1 -i ${srcdir}/graphics.patch
}
build() {
- cd ${startdir}
- patch -p0 < ${startdir}/graphics.patch
+ cd ${pkgname}
- cd ${srcdir}/${_pkgname}
+ #patch -p0 < ${srcdir}/graphics.patch
- # Build and install base package
- cargo build --release
+ # Build and install base package
+ cargo build --release
}
package() {
- # Install daemons
- install -Dm755 ${srcdir}/${_pkgname}/target/release/system76-power ${pkgdir}/usr/bin/system76-power
+ # Install daemons
+ install -Dm755 ${srcdir}/${pkgname}/target/release/system76-power ${pkgdir}/usr/bin/system76-power
- # Install systemd unit files
- install -Dm644 ${srcdir}/${_pkgname}/debian/system76-power.service ${pkgdir}/usr/lib/systemd/system/system76-power.service
+ # Install systemd unit files
+ install -Dm644 ${srcdir}/${pkgname}/debian/system76-power.service ${pkgdir}/usr/lib/systemd/system/system76-power.service
- # Install scripts and configuration
- install -Dm755 ${srcdir}/${_pkgname}/data/system76-power.conf ${pkgdir}/usr/share/dbus-1/system.d/system76-power.conf
+ # Install scripts and configuration
+ install -Dm755 ${srcdir}/${pkgname}/data/system76-power.conf ${pkgdir}/usr/share/dbus-1/system.d/system76-power.conf
}
diff --git a/graphics.patch b/graphics.patch
index 8937050a20de..6117411b2223 100644
--- a/graphics.patch
+++ b/graphics.patch
@@ -1,21 +1,25 @@
---- src/system76/src/graphics.rs 2018-09-11 20:08:40.269995504 -0700
-+++ src/system76/src/graphics.rs.new 2018-09-11 20:10:14.403327798 -0700
-@@ -12,10 +12,10 @@
+diff --git a/src/graphics.rs b/src/graphics.rs
+index 6ff9020..e9a44ad 100644
+--- a/src/graphics.rs
++++ b/src/graphics.rs
+@@ -14,11 +14,11 @@ blacklist nouveau
blacklist nvidia
blacklist nvidia-drm
blacklist nvidia-modeset
+-alias i2c_nvidia_gpu off
-alias nouveau off
-alias nvidia off
-alias nvidia-drm off
-alias nvidia-modeset off
++#alias i2c_nvidia_gpu off
+#alias nouveau off
+#alias nvidia off
+#alias nvidia-drm off
+#alias nvidia-modeset off
"#;
- pub struct Graphics {
-@@ -135,12 +135,12 @@
+ pub struct GraphicsDevice {
+@@ -204,12 +204,12 @@ impl Graphics {
}
}