summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLink Dupont2016-05-20 21:57:28 -0700
committerLink Dupont2016-05-20 21:57:28 -0700
commit5702d5de1f9278b1787fd2ffef6d3fb44ffe75d1 (patch)
tree5f1eb7425ff3985ae8720540cdff46de73afa05a
downloadaur-5702d5de1f9278b1787fd2ffef6d3fb44ffe75d1.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD22
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23cc65bd85ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = system76-wallpapers
+ pkgdesc = A collection of System76 Wallpapers
+ pkgver = 16.04.1
+ pkgrel = 1
+ url = https://launchpad.net/system76-wallpapers
+ arch = any
+ license = GPL
+ source = https://launchpad.net/~system76-dev/+archive/stable/+files/system76-wallpapers_16.04.1.tar.gz
+ md5sums = c39c8f23906da9c67a292722f7cb3df8
+
+pkgname = system76-wallpapers
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5f2e227c89ad
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+src/
+pkg/
+
+*.tar.*
+*.tgz
+*.tbz2
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6f43d54928a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Link Dupont <link@fastmail.com>
+pkgname=system76-wallpapers
+pkgver=16.04.1
+pkgrel=1
+pkgdesc="A collection of System76 Wallpapers"
+arch=('any')
+url="https://launchpad.net/system76-wallpapers"
+license=('GPL')
+source=("https://launchpad.net/~system76-dev/+archive/stable/+files/${pkgname}_${pkgver}.tar.gz")
+md5sums=('c39c8f23906da9c67a292722f7cb3df8')
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -m755 -d ${pkgdir}/usr/share/backgrounds
+ install -m644 -D backgrounds/* ${pkgdir}/usr/share/backgrounds/
+ install -m644 -D ${pkgname}.xml ${pkgdir}/usr/share/gnome-background-properties/${pkgname}.xml
+}