summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-02-04 13:44:51 -0700
committerMark Wagie2021-02-04 13:44:51 -0700
commit8b571dda390e314dbbbe126b2f87f104e51d5da6 (patch)
treeaeb169796423b3a070ee16b259e1388e348f20c9
parent2fc986f3085707f56f2797bdacb60f1c13ee38b6 (diff)
downloadaur-8b571dda390e314dbbbe126b2f87f104e51d5da6.tar.gz
18.04.2~1611351210~20.04~52abc1e~dev
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD21
3 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7575e166d2cc..e5fe6e1db085 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = system76-wallpapers
pkgdesc = A collection of System76 Wallpapers
- pkgver = 18.04.2~1525874807~18.04~d6171e2~dev
+ pkgver = 18.04.2~1611351210~20.04~52abc1e~dev
pkgrel = 1
- url = https://launchpad.net/system76-wallpapers
+ url = https://github.com/pop-os/system76-wallpapers
arch = any
license = GPL
- source = https://launchpad.net/~system76-dev/+archive/stable/+files/system76-wallpapers_18.04.2~1525874807~18.04~d6171e2~dev.tar.xz
- sha256sums = dfe9b8c7092ae83d055943fcfeb8463cd14dffe8768e7af2caa663eec2675f2c
+ source = https://launchpad.net/~system76-dev/+archive/ubuntu/stable/+sourcefiles/system76-wallpapers/18.04.2~1611351210~20.04~52abc1e~dev/system76-wallpapers_18.04.2~1611351210~20.04~52abc1e~dev.tar.xz
+ sha256sums = 7944886badd733568b2d09c925e3a9c84d45372e8209068d2fed7fbc340bc1c2
pkgname = system76-wallpapers
diff --git a/.gitignore b/.gitignore
index 5f2e227c89ad..4dab8d6386e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,7 @@
-src/
-pkg/
+# Ignore everything
+*
-*.tar.*
-*.tgz
-*.tbz2
-*.zip
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 31a752440b3f..5993b3dc4598 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
-# Maintainer: Timo Schwichtenberg <therealbassx at yahoo dot de>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Timo Schwichtenberg <therealbassx at yahoo dot de>
# Contributor: Link Dupont <link@fastmail.com>
-
pkgname=system76-wallpapers
-pkgver=18.04.2~1525874807~18.04~d6171e2~dev
+pkgver=18.04.2~1611351210~20.04~52abc1e~dev
pkgrel=1
pkgdesc="A collection of System76 Wallpapers"
arch=('any')
-url="https://launchpad.net/system76-wallpapers"
+url="https://github.com/pop-os/system76-wallpapers"
license=('GPL')
-source=("https://launchpad.net/~system76-dev/+archive/stable/+files/${pkgname}_${pkgver}.tar.xz")
-sha256sums=('dfe9b8c7092ae83d055943fcfeb8463cd14dffe8768e7af2caa663eec2675f2c')
+source=("https://launchpad.net/~system76-dev/+archive/ubuntu/stable/+sourcefiles/$pkgname/$pkgver/${pkgname}_${pkgver}.tar.xz")
+sha256sums=('7944886badd733568b2d09c925e3a9c84d45372e8209068d2fed7fbc340bc1c2')
package() {
- cd "${srcdir}"
- install -m755 -d ${pkgdir}/usr/share/backgrounds
- install -m644 -D d6171e2708cb91fc3f5a7e6749cbfb27a547ca9f_bionic/backgrounds/* ${pkgdir}/usr/share/backgrounds/
- install -m644 -D d6171e2708cb91fc3f5a7e6749cbfb27a547ca9f_bionic/${pkgname}.xml ${pkgdir}/usr/share/gnome-background-properties/${pkgname}.xml
+ _commit='52abc1e8996891210beb66ae75796f5986bfea82_focal'
+
+ install -d "$pkgdir/usr/share/backgrounds"
+ install -Dm644 "$_commit/backgrounds/"* "$pkgdir/usr/share/backgrounds"
+ install -Dm644 "$_commit/$pkgname.xml" -t "$pkgdir/usr/share/gnome-background-properties"
}