summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2021-12-27 17:31:19 +0100
committerSefa Eyeoglu2021-12-27 17:31:19 +0100
commit0690a7905b821f02006f28350fba59d44fbd7919 (patch)
tree6ab32ebbffa043b3f2e337c93fa845d91e4c44cb
parent94eb011c8e73a8b5b42951cfd3f6491677c20c0e (diff)
downloadaur-systemd-boot-pacman-hook.tar.gz
upgpkg: systemd-boot-pacman-hook 3-1
Use systemd-boot-update.service instead of doing it ourselves. If the oneshot unit fails, systemctl returns with a non-zero exist code as well, so the user will still be notified of an error if there is one.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
-rw-r--r--systemd-boot.hook4
3 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b3a947a7926..624906641431 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = systemd-boot-pacman-hook
pkgdesc = Pacman hook to upgrade systemd-boot after systemd upgrade.
- pkgver = 2
- pkgrel = 2
+ pkgver = 3
+ pkgrel = 1
arch = any
license = GPL
depends = systemd
source = systemd-boot.hook
- md5sums = 13c7893e3e8b34479c42795d8f9e1ad3
+ md5sums = cd8b1e530ce6f239923362492fda3f4f
pkgname = systemd-boot-pacman-hook
-
diff --git a/PKGBUILD b/PKGBUILD
index 4f2c2b9bc42d..42a9850c0887 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Federico Di Pierro <nierro92@gmail.com>
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
pkgname=systemd-boot-pacman-hook
-pkgver=2
-pkgrel=2
+pkgver=3
+pkgrel=1
pkgdesc="Pacman hook to upgrade systemd-boot after systemd upgrade."
arch=("any")
license=("GPL")
depends=('systemd')
source=(systemd-boot.hook)
-md5sums=("13c7893e3e8b34479c42795d8f9e1ad3")
+md5sums=('cd8b1e530ce6f239923362492fda3f4f')
package() {
install -m755 -d "${pkgdir}/usr/share/libalpm/hooks"
diff --git a/systemd-boot.hook b/systemd-boot.hook
index 4c3dbab6de17..d65c027562c5 100644
--- a/systemd-boot.hook
+++ b/systemd-boot.hook
@@ -4,6 +4,6 @@ Operation = Upgrade
Target = systemd
[Action]
-Description = Upgrading systemd-boot...
+Description = Gracefully upgrading systemd-boot...
When = PostTransaction
-Exec = /usr/bin/bootctl update
+Exec = /usr/bin/systemctl restart systemd-boot-update.service