summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Di Pierro2016-06-18 18:12:27 +0200
committerFederico Di Pierro2016-06-18 18:12:27 +0200
commit13893d43db037dcf1c0151a2ae3b51d5414be284 (patch)
tree64fba5ea82379837e281ff68842976de0d6e9db7
parent3ccfd465b8c1e7b20eb210a3629391d901d243cd (diff)
downloadaur-13893d43db037dcf1c0151a2ae3b51d5414be284.tar.gz
updated
-rw-r--r--PKGBUILD6
-rw-r--r--systemd-boot.hook1
2 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 34643ced0476..ae7d5a65e14d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Federico Di Pierro <nierro92@gmail.com>
pkgname=systemd-boot-pacman-hook
-pkgver=1
+pkgver=2
pkgrel=1
pkgdesc="Pacman hook to upgrade systemd-boot after systemd upgrade."
arch=("any")
@@ -11,6 +11,6 @@ source=(systemd-boot.hook)
md5sums=("29f602ed5702c18f68eb7c2d293af04f")
package() {
- install -m755 -d "${pkgdir}/etc/pacman.d/hooks"
- install -m644 "${srcdir}/systemd-boot.hook" "${pkgdir}/etc/pacman.d/hooks/systemd-boot.hook"
+ install -m755 -d "${pkgdir}/usr/share/libalpm/hooks"
+ install -m644 "${srcdir}/systemd-boot.hook" "${pkgdir}/usr/share/libalpm/hooks/systemd-boot.hook"
}
diff --git a/systemd-boot.hook b/systemd-boot.hook
index 68db81e7ae83..4c3dbab6de17 100644
--- a/systemd-boot.hook
+++ b/systemd-boot.hook
@@ -1,6 +1,5 @@
[Trigger]
Type = Package
-Operation = Install
Operation = Upgrade
Target = systemd