summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Di Pierro2016-06-18 17:29:21 +0200
committerFederico Di Pierro2016-06-18 17:29:21 +0200
commit5eac288968a327725f105d7d31a1b787b924dafc (patch)
treeefb520014feae955c154cfc5ab45051ea825dd8c
downloadaur-5eac288968a327725f105d7d31a1b787b924dafc.tar.gz
first commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
-rw-r--r--systemd-boot.hook10
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ce71378aa1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = systemd-boot-pacman-hook
+ pkgdesc = Pacman hook to upgrade systemd-boot after systemd upgrade.
+ pkgver = 1
+ pkgrel = 1
+ arch = any
+ license = GPL
+ source = systemd-boot.hook
+ md5sums = 29f602ed5702c18f68eb7c2d293af04f
+
+pkgname = systemd-boot-pacman-hook
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8ce559e8670
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+# Maintainer: Federico Di Pierro <nierro92@gmail.com>
+
+pkgname=systemd-boot-pacman-hook
+pkgver=1
+pkgrel=1
+pkgdesc="Pacman hook to upgrade systemd-boot after systemd upgrade."
+arch=("any")
+license=("GPL")
+source=(systemd-boot.hook)
+md5sums=("29f602ed5702c18f68eb7c2d293af04f")
+
+package() {
+ install -m755 -d "${pkgdir}/etc/pacman.d/hooks"
+ install -m644 "${srcdir}/systemd-boot.hook" "${pkgdir}/etc/pacman.d/hooks/systemd-boot.hook"
+}
diff --git a/systemd-boot.hook b/systemd-boot.hook
new file mode 100644
index 000000000000..68db81e7ae83
--- /dev/null
+++ b/systemd-boot.hook
@@ -0,0 +1,10 @@
+[Trigger]
+Type = Package
+Operation = Install
+Operation = Upgrade
+Target = systemd
+
+[Action]
+Description = Upgrading systemd-boot...
+When = PostTransaction
+Exec = /usr/bin/bootctl update