summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2018-07-18 20:16:25 +0200
committerJakob Gahde2018-07-18 20:16:25 +0200
commitcf964edd2bdc77c586cbb81583ced968217563df (patch)
tree436d7e69002b1b106be437f4ec108ad726b35ffb
downloadaur-cf964edd2bdc77c586cbb81583ced968217563df.tar.gz
systemd-bootchart 233-1: New package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22136e3b5013
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = systemd-bootchart
+ pkgdesc = Boot performance graphing tool
+ pkgver = 233
+ pkgrel = 1
+ url = https://github.com/systemd/systemd-bootchart
+ arch = x86_64
+ license = GPL2
+ license = LGPL2.1
+ makedepends = docbook-xsl
+ depends = libsystemd
+ source = https://github.com/systemd/systemd-bootchart/releases/download/v233/systemd-bootchart-233.tar.xz
+ md5sums = fbe3fa306d4d0066301b9deadafbd157
+
+pkgname = systemd-bootchart
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..310dedf9534e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=systemd-bootchart
+pkgver=233
+pkgrel=1
+pkgdesc='Boot performance graphing tool'
+arch=('x86_64')
+url='https://github.com/systemd/systemd-bootchart'
+license=('GPL2' 'LGPL2.1')
+depends=('libsystemd')
+makedepends=('docbook-xsl')
+source=("https://github.com/systemd/systemd-bootchart/releases/download/v${pkgver}/systemd-bootchart-${pkgver}.tar.xz")
+md5sums=('fbe3fa306d4d0066301b9deadafbd157')
+
+build() {
+ cd "${srcdir}/systemd-bootchart-${pkgver}"
+
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "${srcdir}/systemd-bootchart-${pkgver}"
+
+ make install DESTDIR="${pkgdir}"
+}