summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Yuan2020-03-16 14:21:15 +0800
committerMike Yuan2020-03-16 14:21:15 +0800
commit891845aa1628202f1c8f7e22aa5505f08feedb34 (patch)
treed26226272806ea36fb9ecdbd9ebc4413cad27f15
downloadaur-891845aa1628202f1c8f7e22aa5505f08feedb34.tar.gz
Initial release
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0342489edf7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = systemd-cleanup-pacman-hook
+ pkgdesc = Pacman hook to stop and remove systemd units before removing packages
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/YHNdnzj/systemd-cleanup-pacman-hook
+ arch = any
+ license = MIT
+ source = systemd-cleanup-pacman-hook-1.tar.gz::https://github.com/YHNdnzj/systemd-cleanup-pacman-hook/archive/1.tar.gz
+ sha256sums = 35362d1067ac5dd4d19ca6a41c43203d2aededc7b8cd77ae6b1f161cdf627535
+
+pkgname = systemd-cleanup-pacman-hook
+ depends = findutils
+ depends = systemd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ab7af886965
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mike Yuan <me@yhndnzj.com>
+
+pkgname=systemd-cleanup-pacman-hook
+pkgver=1
+pkgrel=1
+pkgdesc="Pacman hook to stop and remove systemd units before removing packages"
+arch=('any')
+url="https://github.com/YHNdnzj/systemd-cleanup-pacman-hook"
+license=('MIT')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('35362d1067ac5dd4d19ca6a41c43203d2aededc7b8cd77ae6b1f161cdf627535')
+
+package() {
+ depends=('findutils' 'systemd')
+
+ install -Dm644 systemd-cleanup.hook "$pkgdir/usr/share/libalpm/hooks/systemd-cleanup.hook"
+ install -Dm755 systemd-cleanup "$pkgdir/usr/share/libalpm/scripts/systemd-cleanup"
+
+ install -Dm644 README.md "$pkgdir/usr/share/doc/systemd-cleanup-pacman-hook/README.md"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/systemd-cleanup-pacman-hook/LICENSE"
+}
+
+# vim: set ts=4 sw=4 et: