summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDwayne Bent2015-06-13 13:32:39 -0400
committerDwayne Bent2015-06-13 13:32:39 -0400
commit7585f425dc9b1973526a4f9d4ff3369ba7051c14 (patch)
treecb5a6a1085f4dccca2de1a8191a709cd0190a08e
downloadaur-7585f425dc9b1973526a4f9d4ff3369ba7051c14.tar.gz
v1.5.3-1
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD34
-rw-r--r--systemd-cron.install13
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b925c25a1a7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = systemd-cron
+ pkgdesc = systemd units to run cron scripts
+ pkgver = 1.5.3
+ pkgrel = 1
+ url = https://github.com/systemd-cron/systemd-cron
+ install = systemd-cron.install
+ arch = any
+ license = MIT
+ depends = systemd>=217
+ depends = run-parts
+ depends = python
+ optdepends = smtp-forwarder: sending emails
+ provides = cron
+ conflicts = cron
+ source = https://github.com/systemd-cron/systemd-cron/archive/v1.5.3.tar.gz
+ md5sums = 15da1cb2e1171d24927e3241de6f7969
+
+pkgname = systemd-cron
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e92d37556128
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/pkg/
+/src/
+
+*.tar.gz
+*.tar.xz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6acf567e0dda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Dwayne Bent <dbb@dbb.io>
+pkgname=systemd-cron
+pkgver=1.5.3
+pkgrel=1
+pkgdesc='systemd units to run cron scripts'
+arch=(any)
+url='https://github.com/systemd-cron/systemd-cron'
+license=('MIT')
+depends=('systemd>=217' 'run-parts' 'python')
+optdepends=('smtp-forwarder: sending emails')
+provides=('cron')
+conflicts=('cron')
+source=("https://github.com/systemd-cron/${pkgname}/archive/v${pkgver}.tar.gz")
+install=${pkgname}.install
+md5sums=('15da1cb2e1171d24927e3241de6f7969')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr --confdir=/etc \
+ --enable-minutely --enable-quarterly --enable-semi_annually --enable-yearly \
+ --enable-persistent --enable-setgid
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+
+ install -d "${pkgdir}"/etc/cron.{boot,minutely,hourly,daily,weekly,monthly,quarterly,semi-annually,yearly}
+ install -d "${pkgdir}"/var/spool/cron
+}
+
diff --git a/systemd-cron.install b/systemd-cron.install
new file mode 100644
index 000000000000..5bf8f123ee1d
--- /dev/null
+++ b/systemd-cron.install
@@ -0,0 +1,13 @@
+_post_install_or_upgrade() {
+ touch /run/crond.reboot
+ touch /run/crond.bootdir
+}
+
+post_install() {
+ _post_install_or_upgrade
+}
+
+post_upgrade() {
+ _post_install_or_upgrade
+}
+