summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDwayne Bent2023-09-08 11:21:54 -0400
committerDwayne Bent2023-09-08 11:21:54 -0400
commita159665f93a10ba2253142bd4c1898475b3a805d (patch)
tree831d01db63092140516f00792e82056fca93fe35
parent5774fb41768124a2648921f31b955a21fb994acd (diff)
downloadaur-a159665f93a10ba2253142bd4c1898475b3a805d.tar.gz
v2.1.0-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--systemd-cron.install16
3 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55e602848b4e..ed3ca2364a09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = systemd-cron
pkgdesc = systemd units to run cron scripts
- pkgver = 2.0.2
- pkgrel = 2
+ pkgver = 2.1.0
+ pkgrel = 1
url = https://github.com/systemd-cron/systemd-cron
install = systemd-cron.install
arch = x86_64
@@ -12,9 +12,9 @@ pkgbase = systemd-cron
provides = cron
conflicts = cron
options = debug
- source = systemd-cron-2.0.2.tar.gz::https://github.com/systemd-cron/systemd-cron/archive/refs/tags/v2.0.2.tar.gz
+ source = systemd-cron-2.1.0.tar.gz::https://github.com/systemd-cron/systemd-cron/archive/refs/tags/v2.1.0.tar.gz
source = sysusers.conf
- sha256sums = 412c2decc3c6e7d77b717f7ad623e7ecc45464a51472a31097e12e2602290953
+ sha256sums = eb1bbd9c8e3598ad256abe7be45bfd3e4a93f25717d92fd1b077df9d62018f9c
sha256sums = 9260221879cca05d4c82cd12deb88759c8d9148e106f4b9891700849cef5c41b
pkgname = systemd-cron
diff --git a/PKGBUILD b/PKGBUILD
index f817946b1671..1e2b4de7792c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dwayne Bent <dbb@dbb.io>
pkgname=systemd-cron
-pkgver=2.0.2
-pkgrel=2
+pkgver=2.1.0
+pkgrel=1
pkgdesc='systemd units to run cron scripts'
arch=('x86_64')
url='https://github.com/systemd-cron/systemd-cron'
@@ -14,7 +14,7 @@ options=('debug')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/systemd-cron/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz"
'sysusers.conf')
install=${pkgname}.install
-sha256sums=('412c2decc3c6e7d77b717f7ad623e7ecc45464a51472a31097e12e2602290953'
+sha256sums=('eb1bbd9c8e3598ad256abe7be45bfd3e4a93f25717d92fd1b077df9d62018f9c'
'9260221879cca05d4c82cd12deb88759c8d9148e106f4b9891700849cef5c41b')
build() {
diff --git a/systemd-cron.install b/systemd-cron.install
index c0d2ca45a9b3..d9b7bb9c8c19 100644
--- a/systemd-cron.install
+++ b/systemd-cron.install
@@ -1,3 +1,13 @@
+# Adapated from visual-studio-code-bin
+_note() {
+ off="$(tput sgr0)"
+ bold="$(tput bold)"
+ green="$(tput setaf 2)"
+ yellow="$(tput setaf 3)"
+
+ printf "${off}${bold}${green}==>${off} ${bold}${yellow}NOTE:${off} ${bold}${1}${off}\n"
+}
+
_post_install_or_upgrade() {
touch run/crond.reboot
touch run/crond.bootdir
@@ -18,8 +28,8 @@ post_install() {
post_upgrade() {
_post_install_or_upgrade
- echo ">> NOTE: systemd-cron>=2.0.2-1 now executes cron directory scripts without run-parts."
- echo ">> Therefore, lexical serialization of scripts is no longer done."
- echo ">> Please adjust scripts accordingly, e.g. combining serially dependent scripts."
+ _note \
+"systemd-cron>=2.0.2-1 now executes cron directory scripts without run-parts.
+Therefore, lexical serialization of scripts is no longer supported; please adjust scripts accordingly, e.g. combining serially dependent scripts."
}