summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlias Stamatis2017-04-07 03:28:30 +0300
committerIlias Stamatis2017-04-07 03:28:30 +0300
commit5492b52fdc82ef90b9d3a56c568ca6279288cb4d (patch)
tree895674fdf0f9a8d149908db44bc79363b43dbe13
parenta35bf96bf4ffa37663dc4ccfaea9d1063c403f9f (diff)
downloadaur-5492b52fdc82ef90b9d3a56c568ca6279288cb4d.tar.gz
change to fixed version numbering, version 1.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ce03df98725..a7023d8fe7d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = systemd-denotify
pkgdesc = A set of python classes that provide desktop notification upon a user login and when a systemd service fails.
- pkgver = r441.3e0887d
+ pkgver = 1.2
pkgrel = 1
url = https://github.com/gkarakou/systemd-denotify
install = systemd-denotify.install
@@ -16,8 +16,8 @@ pkgbase = systemd-denotify
depends = python2-notify
depends = libnotify
backup = etc/systemd-denotify.conf
- source = systemd-denotify::git+https://github.com/gkarakou/systemd-denotify
- md5sums = SKIP
+ source = https://github.com/gkarakou/systemd-denotify/archive/v1.2.tar.gz
+ md5sums = c1c7603bbb19a4705721a21f4c0fdb5a
pkgname = systemd-denotify
diff --git a/PKGBUILD b/PKGBUILD
index a2be32c713fb..3a41d9d5e837 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ilias Stamatis <stamatis.iliass at gmail dot com>
pkgname=systemd-denotify
-pkgver=r441.3e0887d
+pkgver=1.2
pkgrel=1
pkgdesc='A set of python classes that provide desktop notification upon a user login and when a systemd service fails.'
arch=(any)
@@ -11,15 +11,10 @@ depends=('python2' 'python2-dbus' 'python2-gobject' 'python2-pyinotify' 'python2
makedepends=('git' 'python2-setuptools')
backup=('etc/systemd-denotify.conf')
install=systemd-denotify.install
-source=("${pkgname}::git+https://github.com/gkarakou/systemd-denotify")
-md5sums=('SKIP')
-
-pkgver() {
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+source=("https://github.com/gkarakou/systemd-denotify/archive/v${pkgver}.tar.gz")
+md5sums=('c1c7603bbb19a4705721a21f4c0fdb5a')
package() {
- cd "$pkgname"
- python2 setup.py install --root="${pkgdir}/"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
}