summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlias Stamatis2015-06-08 16:06:46 +0300
committerIlias Stamatis2015-06-08 16:08:15 +0300
commita35bf96bf4ffa37663dc4ccfaea9d1063c403f9f (patch)
treee01c5fc0df0d28cfb5cadf57b040be8e018f8c76
downloadaur-a35bf96bf4ffa37663dc4ccfaea9d1063c403f9f.tar.gz
initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD25
-rw-r--r--systemd-denotify.install4
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ce03df98725
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = systemd-denotify
+ pkgdesc = A set of python classes that provide desktop notification upon a user login and when a systemd service fails.
+ pkgver = r441.3e0887d
+ pkgrel = 1
+ url = https://github.com/gkarakou/systemd-denotify
+ install = systemd-denotify.install
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-dbus
+ depends = python2-gobject
+ depends = python2-pyinotify
+ depends = python2-systemd
+ depends = python2-notify
+ depends = libnotify
+ backup = etc/systemd-denotify.conf
+ source = systemd-denotify::git+https://github.com/gkarakou/systemd-denotify
+ md5sums = SKIP
+
+pkgname = systemd-denotify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2be32c713fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ilias Stamatis <stamatis.iliass at gmail dot com>
+
+pkgname=systemd-denotify
+pkgver=r441.3e0887d
+pkgrel=1
+pkgdesc='A set of python classes that provide desktop notification upon a user login and when a systemd service fails.'
+arch=(any)
+url='https://github.com/gkarakou/systemd-denotify'
+license=('GPL')
+depends=('python2' 'python2-dbus' 'python2-gobject' 'python2-pyinotify' 'python2-systemd' 'python2-notify' 'libnotify')
+makedepends=('git' 'python2-setuptools')
+backup=('etc/systemd-denotify.conf')
+install=systemd-denotify.install
+source=("${pkgname}::git+https://github.com/gkarakou/systemd-denotify")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ python2 setup.py install --root="${pkgdir}/"
+}
diff --git a/systemd-denotify.install b/systemd-denotify.install
new file mode 100644
index 000000000000..d6f6c975454f
--- /dev/null
+++ b/systemd-denotify.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "==> Don't forget that you need a notification server for this."
+ echo " You can configure notifications by editing /etc/systemd-denotify.conf"
+}