summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Stefani2020-03-27 21:19:34 +0100
committerLuca Stefani2020-03-27 21:19:55 +0100
commit9267a1b395ad764f75533607d59e3e8c37979964 (patch)
treec49df8f2f30aa0165d7aec238bdb82f4246c4b6c
parentc24d4ea17d59473bf458cd97a717d39db8ce313b (diff)
downloadaur-9267a1b395ad764f75533607d59e3e8c37979964.tar.gz
Fix linux load address
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--systemd-efi.hook2
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7bdc9f297fd..c0be5387d6a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = systemd-efi-pacman-hook
pkgdesc = Pacman hook to upgrade Linux EFI after systemd upgrade and Linux.
pkgver = 1
- pkgrel = 5
+ pkgrel = 6
arch = any
license = GPL
depends = systemd
depends = linux
source = systemd-efi.hook
- md5sums = cb5d743346429b77827045bc9011e268
+ md5sums = 51d270ea53c1c85671c1b820ea56a399
pkgname = systemd-efi-pacman-hook
diff --git a/PKGBUILD b/PKGBUILD
index e37c66a2b44d..a377e15cc136 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
pkgname=systemd-efi-pacman-hook
pkgver=1
-pkgrel=5
+pkgrel=6
pkgdesc="Pacman hook to upgrade Linux EFI after systemd upgrade and Linux."
arch=("any")
license=("GPL")
depends=('systemd' 'linux')
source=(systemd-efi.hook)
-md5sums=('cb5d743346429b77827045bc9011e268')
+md5sums=('51d270ea53c1c85671c1b820ea56a399')
package() {
install -m755 -d "${pkgdir}/usr/share/libalpm/hooks"
diff --git a/systemd-efi.hook b/systemd-efi.hook
index 6f5276509422..d95cc944cd98 100644
--- a/systemd-efi.hook
+++ b/systemd-efi.hook
@@ -8,4 +8,4 @@ Target = usr/lib/systemd/boot/efi/linuxx64.efi.stub
[Action]
Description = Generating linux.efi...
When = PostTransaction
-Exec = /bin/sh -c '/usr/bin/mkdir -p "/boot/EFI/Linux"; /usr/bin/objcopy --add-section .osrel="/usr/lib/os-release" --change-section-vma .osrel=0x20000 --add-section .cmdline="/boot/kernel-command-line" --change-section-vma .cmdline=0x30000 --add-section .splash="/usr/share/systemd/bootctl/splash-arch.bmp" --change-section-vma .splash=0x40000 --add-section .linux="/boot/vmlinuz-linux" --change-section-vma .linux=0x40000 --add-section .initrd="/boot/initramfs-linux.img" --change-section-vma .initrd=0x3000000 "/usr/lib/systemd/boot/efi/linuxx64.efi.stub" "/boot/EFI/Linux/linux.efi"'
+Exec = /bin/sh -c '/usr/bin/mkdir -p "/boot/EFI/Linux"; /usr/bin/objcopy --add-section .osrel="/usr/lib/os-release" --change-section-vma .osrel=0x20000 --add-section .cmdline="/boot/kernel-command-line" --change-section-vma .cmdline=0x30000 --add-section .splash="/usr/share/systemd/bootctl/splash-arch.bmp" --change-section-vma .splash=0x40000 --add-section .linux="/boot/vmlinuz-linux" --change-section-vma .linux=0x2000000 --add-section .initrd="/boot/initramfs-linux.img" --change-section-vma .initrd=0x3000000 "/usr/lib/systemd/boot/efi/linuxx64.efi.stub" "/boot/EFI/Linux/linux.efi"'