summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMerlin Jehli2024-06-20 05:58:58 +0200
committerMerlin Jehli2024-06-20 05:58:58 +0200
commit1eb705acd18d7191c3809b2f3ee8111207b30cee (patch)
tree3b101e6297da881f11123924836a00adc7ef1916
parent088feca080d64e0149bae307687bdf0da6961c74 (diff)
downloadaur-1eb705acd18d7191c3809b2f3ee8111207b30cee.tar.gz
update to 256.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a83eed4c01d..097ad2839e91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = systemd-fml
pkgdesc = systemd with machine id from hw patch: https://github.com/systemd/systemd/pull/32086
pkgver = 256.1
- pkgrel = 3
+ pkgrel = 4
url = https://www.github.com/systemd/systemd
arch = x86_64
license = LGPL-2.1-or-later
@@ -97,7 +97,7 @@ pkgname = systemd-fml
license = CC0-1.0
license = GPL-2.0-or-later
license = MIT-0
- depends = systemd-libs-fml=256.1
+ depends = systemd-lib=256.1
depends = acl
depends = libacl.so
depends = bash
@@ -194,7 +194,7 @@ pkgname = systemd-libs-fml
pkgname = systemd-resolvconf-fml
pkgdesc = systemd resolvconf replacement (for use with systemd-resolved)
- depends = systemd-fml=256.1
+ depends = systemd=256.1
provides = openresolv
provides = resolvconf
provides = systemd-resolvconf=256.1
@@ -203,14 +203,14 @@ pkgname = systemd-resolvconf-fml
pkgname = systemd-sysvcompat-fml
pkgdesc = sysvinit compat for systemd
- depends = systemd-fml=256.1
+ depends = systemd=256.1
provides = systemd-sysvcompat=256.1
conflicts = sysvinit
conflicts = systemd-sysvcompat
pkgname = systemd-ukify-fml
pkgdesc = Combine kernel and initrd into a signed Unified Kernel Image
- depends = systemd-fml=256.1
+ depends = systemd=256.1
depends = binutils
depends = python-cryptography
depends = python-pefile
diff --git a/PKGBUILD b/PKGBUILD
index 135ba644afd0..3a0994ed7f97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ _tag='256.1'
# way or another. So we replace dashes and tildes with the empty string to
# make sure pacman's version comparing does the right thing for rc versions:
pkgver="${_tag/[-~]/}"
-pkgrel=3
+pkgrel=4
arch=('x86_64')
license=('LGPL-2.1-or-later')
url='https://www.github.com/systemd/systemd'
@@ -188,7 +188,7 @@ package_systemd-fml() {
'GPL-2.0-or-later' # udev
'MIT-0' # documentation and config files
)
- depends=("systemd-libs-fml=${pkgver}"
+ depends=("systemd-lib=${pkgver}"
'acl' 'libacl.so' 'bash' 'cryptsetup' 'libcryptsetup.so' 'dbus'
'dbus-units' 'kbd' 'kmod' 'hwdata' 'libcap' 'libcap.so'
'libgcrypt' 'libxcrypt' 'libcrypt.so' 'libidn2' 'lz4' 'pam'
@@ -315,7 +315,7 @@ package_systemd-libs-fml() {
package_systemd-resolvconf-fml() {
pkgdesc='systemd resolvconf replacement (for use with systemd-resolved)'
- depends=("systemd-fml=${pkgver}")
+ depends=("systemd=${pkgver}")
provides=('openresolv' 'resolvconf')
provides+=("systemd-resolvconf=$pkgver")
conflicts=('resolvconf')
@@ -333,7 +333,7 @@ package_systemd-sysvcompat-fml() {
provides=("systemd-sysvcompat=$pkgver")
conflicts=('sysvinit')
conflicts+=('systemd-sysvcompat')
- depends=("systemd-fml=${pkgver}")
+ depends=("systemd=${pkgver}")
install -D -m0644 -t "$pkgdir"/usr/share/man/man8 \
build/man/{halt,poweroff,reboot,shutdown}.8
@@ -347,7 +347,7 @@ package_systemd-sysvcompat-fml() {
package_systemd-tests() {
pkgdesc='systemd tests'
- depends=("systemd-fml=${pkgver}")
+ depends=("systemd=${pkgver}")
install -d -m0755 "$pkgdir"/usr/lib/systemd
mv systemd-tests/tests "$pkgdir"/usr/lib/systemd/tests
@@ -358,7 +358,7 @@ package_systemd-ukify-fml() {
provides=('ukify')
provides+=("systemd-ukify=$pkgver")
conflicts=('systemd-ukify')
- depends=("systemd-fml=${pkgver}" 'binutils' 'python-cryptography' 'python-pefile')
+ depends=("systemd=${pkgver}" 'binutils' 'python-cryptography' 'python-pefile')
optdepends=('python-pillow: Show the size of splash image'
'sbsigntools: Sign the embedded kernel')