summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMerlin Jehli2024-04-03 16:26:33 +0200
committerMerlin Jehli2024-04-03 16:26:33 +0200
commit3338d1876de2a4dc4eb911931813f160310bfca3 (patch)
tree4ea94ebef47722896efb830fb35bb288504e8941
parent5d6550dadd9e2e03d0ac23b8905f59cee7dea579 (diff)
downloadaur-3338d1876de2a4dc4eb911931813f160310bfca3.tar.gz
updated PKGBUILD
-rw-r--r--.gitignore58
-rw-r--r--PKGBUILD19
2 files changed, 67 insertions, 10 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1bd797f58c32
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,58 @@
+### C template
+# Prerequisites
+*.d
+
+# Object files
+*.o
+*.ko
+*.obj
+*.elf
+
+# Linker output
+*.ilk
+*.map
+*.exp
+
+# Precompiled Headers
+*.gch
+*.pch
+
+# Libraries
+*.lib
+*.a
+*.la
+*.lo
+
+# Shared objects (inc. Windows DLLs)
+*.dll
+*.so
+*.so.*
+*.dylib
+
+# Executables
+*.exe
+*.out
+*.app
+*.i*86
+*.x86_64
+*.hex
+
+# Debug files
+*.dSYM/
+*.su
+*.idb
+*.pdb
+
+# Kernel Module Compile Results
+*.mod*
+*.cmd
+.tmp_versions/
+modules.order
+Module.symvers
+Mkfile.old
+dkms.conf
+
+src
+pkg
+systemd-fml
+.idea
diff --git a/PKGBUILD b/PKGBUILD
index 8d14b20b1e6e..5d854815a244 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,7 +48,7 @@ source=("$pkgbase::git+https://github.com/FML128/systemd#tag=v${_tag}"
'30-systemd-tmpfiles.hook'
'30-systemd-udev-reload.hook'
'30-systemd-update.hook')
-sha512sums=('SKIP'
+sha512sums=('ef9b32eacd1fe7c6aed74b6579c896b8f11b3b157614b4cf4833b9da8ac769aae10db8816878521493efe67ea02cedda01235d836b8ec2d7c810dece9c962330'
'3ccf783c28f7a1c857120abac4002ca91ae1f92205dcd5a84aff515d57e706a3f9240d75a0a67cff5085716885e06e62597baa86897f298662ec36a940cf410e'
'61032d29241b74a0f28446f8cf1be0e8ec46d0847a61dadb2a4f096e8686d5f57fe5c72bcf386003f6520bc4b5856c32d63bf3efe7eb0bc0deefc9f68159e648'
'c416e2121df83067376bcaacb58c05b01990f4614ad9de657d74b6da3efa441af251d13bf21e3f0f71ddcb4c9ea658b81da3d915667dc5c309c87ec32a1cb5a5'
@@ -106,23 +106,22 @@ build() {
-Dshared-lib-tag="${_meson_version/~/}"
-Dmode="${_meson_mode}"
- -Dapparmor=false
- -Dbootloader=true
- -Dxenctrl=false
- -Dbpf-framework=true
+ -Dapparmor=disabled
+ -Dbootloader=enabled
+ -Dxenctrl=disabled
+ -Dbpf-framework=enabled
-Dima=false
- -Dlibidn2=true
- -Dlz4=true
- -Dman=true
+ -Dlibidn2=enabled
+ -Dlz4=enabled
+ -Dman=enabled
-Dnscd=false
- -Dselinux=false
+ -Dselinux=disabled
# We disable DNSSEC by default, it still causes trouble:
# https://github.com/systemd/systemd/issues/10579
-Ddbuspolicydir=/usr/share/dbus-1/system.d
-Ddefault-dnssec=no
- -Ddefault-hierarchy=unified
-Ddefault-kill-user-processes=false
-Ddefault-locale='C.UTF-8'
-Dlocalegen-path=/usr/bin/locale-gen