summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMerlin Jehli2024-06-20 09:46:37 +0200
committerMerlin Jehli2024-06-20 09:46:37 +0200
commit5a3c263b4662f303767f78889e26587b79818bdc (patch)
tree3dc05c1312c8937b27f513f0c8f17252eded5283
parenta80bea14cc0dee2fcc2c59f60e6dc02c527d3777 (diff)
downloadaur-5a3c263b4662f303767f78889e26587b79818bdc.tar.gz
update to 256.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69cd159f053e..ebffae1cb174 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -97,7 +97,7 @@ pkgname = systemd-fml
license = CC0-1.0
license = GPL-2.0-or-later
license = MIT-0
- depends = systemd-lib-fml=256.1
+ depends = systemd-lib
depends = acl
depends = libacl.so
depends = bash
@@ -194,7 +194,7 @@ pkgname = systemd-libs-fml
pkgname = systemd-resolvconf-fml
pkgdesc = systemd resolvconf replacement (for use with systemd-resolved)
- depends = systemd-fml=256.1
+ depends = systemd
provides = openresolv
provides = resolvconf
provides = systemd-resolvconf=256.1
@@ -203,14 +203,14 @@ pkgname = systemd-resolvconf-fml
pkgname = systemd-sysvcompat-fml
pkgdesc = sysvinit compat for systemd
- depends = systemd-fml=256.1
+ depends = systemd
provides = systemd-sysvcompat=256.1
conflicts = sysvinit
conflicts = systemd-sysvcompat
pkgname = systemd-ukify-fml
pkgdesc = Combine kernel and initrd into a signed Unified Kernel Image
- depends = systemd-fml=256.1
+ depends = systemd
depends = binutils
depends = python-cryptography
depends = python-pefile
diff --git a/PKGBUILD b/PKGBUILD
index 6201918021ea..ab6763504f90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -188,7 +188,7 @@ package_systemd-fml() {
'GPL-2.0-or-later' # udev
'MIT-0' # documentation and config files
)
- depends=("systemd-lib-fml=${pkgver}"
+ depends=("systemd-lib"
'acl' 'libacl.so' 'bash' 'cryptsetup' 'libcryptsetup.so' 'dbus'
'dbus-units' 'kbd' 'kmod' 'hwdata' 'libcap' 'libcap.so'
'libgcrypt' 'libxcrypt' 'libcrypt.so' 'libidn2' 'lz4' 'pam'
@@ -315,7 +315,7 @@ package_systemd-libs-fml() {
package_systemd-resolvconf-fml() {
pkgdesc='systemd resolvconf replacement (for use with systemd-resolved)'
- depends=("systemd-fml=${pkgver}")
+ depends=("systemd")
provides=('openresolv' 'resolvconf')
provides+=("systemd-resolvconf=$pkgver")
conflicts=('resolvconf')
@@ -333,7 +333,7 @@ package_systemd-sysvcompat-fml() {
provides=("systemd-sysvcompat=$pkgver")
conflicts=('sysvinit')
conflicts+=('systemd-sysvcompat')
- depends=("systemd-fml=${pkgver}")
+ depends=("systemd")
install -D -m0644 -t "$pkgdir"/usr/share/man/man8 \
build/man/{halt,poweroff,reboot,shutdown}.8
@@ -347,7 +347,7 @@ package_systemd-sysvcompat-fml() {
package_systemd-tests() {
pkgdesc='systemd tests'
- depends=("systemd-fml=${pkgver}")
+ depends=("systemd")
install -d -m0755 "$pkgdir"/usr/lib/systemd
mv systemd-tests/tests "$pkgdir"/usr/lib/systemd/tests
@@ -358,7 +358,7 @@ package_systemd-ukify-fml() {
provides=('ukify')
provides+=("systemd-ukify=$pkgver")
conflicts=('systemd-ukify')
- depends=("systemd-fml=${pkgver}" 'binutils' 'python-cryptography' 'python-pefile')
+ depends=("systemd" 'binutils' 'python-cryptography' 'python-pefile')
optdepends=('python-pillow: Show the size of splash image'
'sbsigntools: Sign the embedded kernel')