summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2019-02-17 11:14:39 +0100
committerYurii Kolesnykov2019-02-17 11:14:39 +0100
commit3963921039881d275aff543f459467b581b09198 (patch)
treed519f8d1c079656c04795e5bd922bc810f457523
parent597035c717ac0bc58e0d3342fce77a1b42663d6d (diff)
downloadaur-3963921039881d275aff543f459467b581b09198.tar.gz
241.78
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
2 files changed, 33 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35f124076b9d..dbe44fe1ab43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = systemd-git
pkgdesc = systemd (git version)
- pkgver = 241.rc2.66
+ pkgver = 241.78
pkgrel = 1
url = https://www.github.com/systemd/systemd
arch = x86_64
@@ -91,8 +91,9 @@ pkgname = systemd-git
depends = hwids
depends = libcap
depends = libgcrypt
- depends = libsystemd
+ depends = systemd-libs
depends = libidn2
+ depends = libidn2.so
depends = lz4
depends = pam
depends = libelf
@@ -106,10 +107,10 @@ pkgname = systemd-git
optdepends = systemd-sysvcompat-git: symlink package to provide sysvinit binaries
optdepends = polkit: allow administration as unprivileged user
optdepends = curl: machinectl pull-tar and pull-raw
- provides = systemd=241.rc2.66
+ provides = systemd=241.78
provides = nss-myhostname
- provides = systemd-tools=241.rc2.66
- provides = udev=241.rc2.66
+ provides = systemd-tools=241.78
+ provides = udev=241.78
conflicts = systemd
conflicts = nss-myhostname
conflicts = systemd-tools
@@ -130,23 +131,26 @@ pkgname = systemd-git
backup = etc/systemd/user.conf
backup = etc/udev/udev.conf
-pkgname = libsystemd-git
+pkgname = systemd-libs-git
pkgdesc = systemd client libraries (git version)
- license = GPL2
+ license = LGPL2.1
depends = glibc
depends = libcap
depends = libgcrypt
depends = lz4
depends = xz
+ provides = systemd-libs
provides = libsystemd
provides = libsystemd.so
provides = libudev.so
+ conflicts = systemd-libs
conflicts = libsystemd
+ replaces = systemd-libs
replaces = libsystemd
pkgname = systemd-resolvconf-git
- pkgdesc = systemd resolvconf replacement (git version)
- license = GPL2
+ pkgdesc = systemd resolvconf replacement (for use with systemd-resolved, git version)
+ license = LGPL2.1
depends = systemd-git
provides = systemd-resolvconf
provides = openresolv
diff --git a/PKGBUILD b/PKGBUILD
index 4bdc4d4569f3..71a0b91a7787 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
pkgbase=systemd-git
_pkgbase=systemd
-pkgname=('systemd-git' 'libsystemd-git' 'systemd-resolvconf-git' 'systemd-sysvcompat-git')
+pkgname=('systemd-git' 'systemd-libs-git' 'systemd-resolvconf-git' 'systemd-sysvcompat-git')
pkgdesc="systemd (git version)"
-pkgver=241.rc2.66
+pkgver=241.78
pkgrel=1
arch=('x86_64')
url='https://www.github.com/systemd/systemd'
@@ -121,8 +121,8 @@ package_systemd-git() {
pkgdesc="system and service manager (git version)"
license=('GPL2' 'LGPL2.1')
depends=('acl' 'bash' 'cryptsetup' 'dbus' 'iptables' 'kbd' 'kmod' 'hwids' 'libcap'
- 'libgcrypt' 'libsystemd' 'libidn2' 'lz4' 'pam' 'libelf' 'libseccomp'
- 'util-linux' 'xz' 'pcre2' 'audit')
+ 'libgcrypt' 'systemd-libs' 'libidn2' 'libidn2.so' 'lz4' 'pam' 'libelf'
+ 'libseccomp' 'util-linux' 'xz' 'pcre2' 'audit')
provides=("${_pkgbase}=$pkgver" 'nss-myhostname' "systemd-tools=$pkgver" "udev=$pkgver")
replaces=("${_pkgbase}" 'nss-myhostname' 'systemd-tools' 'udev')
conflicts=("${_pkgbase}" 'nss-myhostname' 'systemd-tools' 'udev')
@@ -153,9 +153,9 @@ package_systemd-git() {
# we'll create this on installation
rmdir "$pkgdir"/var/log/journal/remote
- # runtime libraries shipped with libsystemd
- install -d -m0755 libsystemd
- mv "$pkgdir"/usr/lib/lib{nss,systemd,udev}*.so* libsystemd
+ # runtime libraries shipped with systemd-libs
+ install -d -m0755 systemd-libs
+ mv "$pkgdir"/usr/lib/lib{nss,systemd,udev}*.so* systemd-libs
# manpages shipped with systemd-sysvcompat
rm "$pkgdir"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8
@@ -203,25 +203,25 @@ package_systemd-git() {
install -D -m0644 systemd-user.pam "$pkgdir"/etc/pam.d/systemd-user
}
-package_libsystemd-git() {
- pkgdesc="systemd client libraries (git version)"
+package_systemd-libs-git() {
+ pkgdesc='systemd client libraries (git version)'
depends=('glibc' 'libcap' 'libgcrypt' 'lz4' 'xz')
- license=('GPL2')
- provides=('libsystemd' 'libsystemd.so' 'libudev.so')
- replaces=('libsystemd')
- conflicts=('libsystemd')
+ license=('LGPL2.1')
+ provides=('systemd-libs' 'libsystemd' 'libsystemd.so' 'libudev.so')
+ conflicts=('systemd-libs' 'libsystemd')
+ replaces=('systemd-libs' 'libsystemd')
install -d -m0755 "$pkgdir"/usr
- mv libsystemd "$pkgdir"/usr/lib
+ mv systemd-libs "$pkgdir"/usr/lib
}
package_systemd-resolvconf-git() {
- pkgdesc='systemd resolvconf replacement (git version)'
- license=('GPL2')
- depends=("${pkgbase}")
+ pkgdesc='systemd resolvconf replacement (for use with systemd-resolved, git version)'
+ license=('LGPL2.1')
+ depends=('systemd-git')
provides=('systemd-resolvconf' 'openresolv' 'resolvconf')
- replaces=('systemd-resolvconf')
conflicts=('systemd-resolvconf' 'openresolv')
+ replaces=('systemd-resolvconf')
install -d -m0755 "$pkgdir"/usr/bin
ln -s resolvectl "$pkgdir"/usr/bin/resolvconf
@@ -234,10 +234,10 @@ package_systemd-resolvconf-git() {
package_systemd-sysvcompat-git() {
pkgdesc='sysvinit compat for systemd (git version)'
license=('GPL2')
+ depends=('systemd-git')
provides=('systemd-sysvcompat')
- replaces=('systemd-sysvcompat')
conflicts=('systemd-sysvcompat' 'sysvinit')
- depends=("${pkgbase}")
+ replaces=('systemd-sysvcompat')
install -D -m0644 -t "$pkgdir"/usr/share/man/man8 \
build/man/{telinit,halt,reboot,poweroff,runlevel,shutdown}.8