summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2019-01-21 22:38:14 +0100
committerYurii Kolesnykov2019-01-21 22:38:14 +0100
commit5fa25d90d0a91f9d069a6fa33ac43b0e3876d8f4 (patch)
treea1d664945016139d41c928075981d63d992e4865
parent75fbba1a66871fcf132e93bbf216078813bd925e (diff)
downloadaur-5fa25d90d0a91f9d069a6fa33ac43b0e3876d8f4.tar.gz
240.285
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD15
2 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 229f888993d..21f353b8b87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = systemd-git
pkgdesc = systemd (git version)
- pkgver = 240.222
+ pkgver = 240.285
pkgrel = 1
url = https://www.github.com/systemd/systemd
arch = x86_64
@@ -106,10 +106,10 @@ pkgname = systemd-git
optdepends = systemd-sysvcompat-git: symlink package to provide sysvinit binaries
optdepends = polkit: allow administration as unprivileged user
optdepends = curl: machinectl pull-tar and pull-raw
- provides = systemd=240.222
+ provides = systemd=240.285
provides = nss-myhostname
- provides = systemd-tools=240.222
- provides = udev=240.222
+ provides = systemd-tools=240.285
+ provides = udev=240.285
conflicts = systemd
conflicts = nss-myhostname
conflicts = systemd-tools
@@ -138,26 +138,29 @@ pkgname = libsystemd-git
depends = libgcrypt
depends = lz4
depends = xz
+ provides = libsystemd
provides = libsystemd.so
provides = libudev.so
- provides = libsystemd
conflicts = libsystemd
+ replaces = libsystemd
pkgname = systemd-resolvconf-git
pkgdesc = systemd resolvconf replacement (git version)
license = GPL2
depends = systemd-git
+ provides = systemd-resolvconf
provides = openresolv
provides = resolvconf
- provides = systemd-resolvconf
- conflicts = openresolv
conflicts = systemd-resolvconf
+ conflicts = openresolv
+ replaces = systemd-resolvconf
pkgname = systemd-sysvcompat-git
pkgdesc = sysvinit compat for systemd (git version)
license = GPL2
depends = systemd-git
provides = systemd-sysvcompat
- conflicts = sysvinit
conflicts = systemd-sysvcompat
+ conflicts = sysvinit
+ replaces = systemd-sysvcompat
diff --git a/PKGBUILD b/PKGBUILD
index d16f1077825..671e4a96d49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgbase=systemd-git
_pkgbase=systemd
pkgname=('systemd-git' 'libsystemd-git' 'systemd-resolvconf-git' 'systemd-sysvcompat-git')
pkgdesc="systemd (git version)"
-pkgver=240.222
+pkgver=240.285
pkgrel=1
arch=('x86_64')
url='https://www.github.com/systemd/systemd'
@@ -96,8 +96,8 @@ build() {
-Dlz4=true
-Ddbuspolicydir=/usr/share/dbus-1/system.d
- # TODO(dreisner): consider changing this to unified
-Ddefault-hierarchy=hybrid
+ -Ddefault-locale=C
-Ddefault-kill-user-processes=false
-Dfallback-hostname='archlinux'
-Dntp-servers="${_timeservers[*]}"
@@ -206,7 +206,8 @@ package_libsystemd-git() {
pkgdesc="systemd client libraries (git version)"
depends=('glibc' 'libcap' 'libgcrypt' 'lz4' 'xz')
license=('GPL2')
- provides=('libsystemd.so' 'libudev.so' 'libsystemd')
+ provides=('libsystemd' 'libsystemd.so' 'libudev.so')
+ replaces=('libsystemd')
conflicts=('libsystemd')
install -d -m0755 "$pkgdir"/usr
@@ -217,8 +218,9 @@ package_systemd-resolvconf-git() {
pkgdesc='systemd resolvconf replacement (git version)'
license=('GPL2')
depends=("${pkgbase}")
- provides=('openresolv' 'resolvconf' 'systemd-resolvconf')
- conflicts=('openresolv' 'systemd-resolvconf')
+ provides=('systemd-resolvconf' 'openresolv' 'resolvconf')
+ replaces=('systemd-resolvconf')
+ conflicts=('systemd-resolvconf' 'openresolv')
install -d -m0755 "$pkgdir"/usr/bin
ln -s resolvectl "$pkgdir"/usr/bin/resolvconf
@@ -232,7 +234,8 @@ package_systemd-sysvcompat-git() {
pkgdesc='sysvinit compat for systemd (git version)'
license=('GPL2')
provides=('systemd-sysvcompat')
- conflicts=('sysvinit' 'systemd-sysvcompat')
+ replaces=('systemd-sysvcompat')
+ conflicts=('systemd-sysvcompat' 'sysvinit')
depends=("${pkgbase}")
install -D -m0644 -t "$pkgdir"/usr/share/man/man8 \