summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2017-02-07 15:39:17 +0300
committerYurii Kolesnykov2017-02-07 15:39:17 +0300
commitf891bf73700c6521a8178a4e5a86177c56d24da8 (patch)
treebc86327f0df538ba39c678cd5e106700b7272775
parentcad28c3818b1ebfb9523652e04270c72f0897ca2 (diff)
downloadaur-f891bf73700c6521a8178a4e5a86177c56d24da8.tar.gz
port fix from stable package
-rw-r--r--PKGBUILD4
-rw-r--r--systemd.install10
2 files changed, 12 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b723e100afc0..501152092f72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgbase=systemd-git
pkgname=('systemd-git' 'libsystemd-git' 'systemd-sysvcompat-git')
pkgdesc="systemd from git"
-pkgver=232.r615.g88e4dbd50
-pkgrel=3
+pkgver=232.r752.g1fb857974
+pkgrel=1
branch='master'
arch=('i686' 'x86_64')
url="https://www.github.com/systemd/systemd"
diff --git a/systemd.install b/systemd.install
index b59de2008a1c..f799c882d53a 100644
--- a/systemd.install
+++ b/systemd.install
@@ -36,6 +36,15 @@ _230_1_changes() {
echo ':: systemd-bootchart is no longer included with systemd'
}
+_232_8_changes() {
+ # paper over possible effects of CVE-2016-10156
+ local stamps=(/var/lib/systemd/timers/*.timer)
+
+ if [[ -f ${stamps[0]} ]]; then
+ chmod 0644 "${stamps[@]}"
+ fi
+}
+
post_install() {
systemd-machine-id-setup
@@ -68,6 +77,7 @@ post_upgrade() {
219-2
219-4
230-1
+ 232-8
)
for v in "${upgrades[@]}"; do