summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Rabbito2022-01-30 18:13:09 -0500
committerAnthony Rabbito2022-01-30 18:13:09 -0500
commit56a1b7578e86006b7244c5141f9a770ad8c64b53 (patch)
treebb0d28eaa89828ba4b6468f29ad4ed3ec922b5d1
parentebe07451979693a6bfc59dd30facfce3ca9399f8 (diff)
downloadaur-56a1b7578e86006b7244c5141f9a770ad8c64b53.tar.gz
fix: source build
Signed-off-by: Anthony Rabbito <hello@anthonyrabbito.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a02d6e8d8a0..a2b3b900c44e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = systemd-homed-containers
pkgver = 250.3
- pkgrel = 3
+ pkgrel = 5
url = https://www.github.com/systemd/systemd
arch = x86_64
makedepends = acl
@@ -88,7 +88,7 @@ pkgbase = systemd-homed-containers
sha512sums = 825b9dd0167c072ba62cabe0677e7cd20f2b4b850328022540f122689d8b25315005fa98ce867cf6e7460b2b26df16b88bb3b5c9ebf721746dce4e2271af7b97
pkgname = systemd-homed-containers
- pkgdesc = system and service manager patched for homed rootless containers
+ pkgdesc = system and service manager
install = systemd.install
license = GPL2
license = LGPL2.1
diff --git a/PKGBUILD b/PKGBUILD
index c9311e9380f7..14d08be2ee30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgname=('systemd-homed-containers' 'systemd-libs-homed-containers' 'systemd-res
_tag='d066a4f747b225d47c5f5c97a8843d30878995b8' # git rev-parse v${_tag_name}
_tag_name=250.3
pkgver="${_tag_name/-/}"
-pkgrel=4
+pkgrel=5
arch=('x86_64')
url='https://www.github.com/systemd/systemd'
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
@@ -71,7 +71,7 @@ _reverts=(
)
prepare() {
- cd "$pkgbase-stable"
+ cd "systemd-stable"
# add upstream repository for cherry-picking
git remote add -f upstream ../systemd
@@ -146,7 +146,7 @@ build() {
-Dsbat-distro-url="https://aur.archlinux.org/packages/systemd-homed-containers/"
)
- arch-meson "$pkgbase-stable" build "${_meson_options[@]}"
+ arch-meson "systemd-stable" build "${_meson_options[@]}"
ninja -C build
}