summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorone-d-wide2022-10-25 22:17:52 +0300
committerone-d-wide2022-10-25 22:18:21 +0300
commitf0af7aac5f2b5365c4ca3bb20196c88b7e28f33e (patch)
treef5871137b4952e968ee06d6f694d8eb098c4784a
parenteb9bd2abadad64ab30beb05a2556c727280d846c (diff)
downloadaur-f0af7aac5f2b5365c4ca3bb20196c88b7e28f33e.tar.gz
Switch to tarball pumping
-rw-r--r--PKGBUILD16
-rw-r--r--systemd-hosts.d.install2
2 files changed, 6 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6398b9367ab9..01c87f09eb26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,19 @@
# Maintainer: onedwide <one-d-wide@protonmail.com>
pkgname=systemd-hosts.d
-pkgver=0.4
-pkgrel=2
+pkgver=1.0
+pkgrel=1
pkgdesc='Keep your hosts records in logically separated files'
url='https://github.com/one-d-wide/systemd-hosts.d'
arch=('any')
license=(GPL3)
depends=('filesystem' 'systemd')
-makedepends=('git')
install=$pkgname.install
-source=("git+$url.git")
-sha256sums=('SKIP')
-
-pkgver() {
- cd $pkgname
- printf "0.%s" "$(git rev-list --count HEAD)"
-}
+source=("$pkgname.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('6777c25be3308cdf926e57b5de0f5710dea55679360c2aa99cac03d23d7cd972')
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
mkdir -pm755 "$pkgdir/etc/hosts.d"
install -Dm644 systemd-hosts.d.{path,service} -t "$pkgdir"/usr/lib/systemd/system
}
diff --git a/systemd-hosts.d.install b/systemd-hosts.d.install
index 76acc77cf0c5..c9c0d4b57de7 100644
--- a/systemd-hosts.d.install
+++ b/systemd-hosts.d.install
@@ -12,6 +12,6 @@ pre_remove() {
mv /etc/hosts.d/hosts.conf /etc/hosts ||
mv /run/hosts /etc/hosts ||
touch /etc/hosts
- systemctl disable --now systemd-hosts.d.service
systemctl disable --now systemd-hosts.d.path
+ systemctl disable --now systemd-hosts.d.service
}