summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTilo Brueckner2018-06-06 07:46:00 +0200
committerTilo Brueckner2018-06-06 07:46:00 +0200
commit736211c700ab4a8627ca8a96fde843babf21fe2d (patch)
tree65865a8d4cb445ed797c446d79b86999021b099a
parent492d33a7081ba717caa54b145bc940ad90c8c949 (diff)
downloadaur-736211c700ab4a8627ca8a96fde843babf21fe2d.tar.gz
Buildfix for Qt 5.11 (Thanks to Tara)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--qt5_use_modules.patch8
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6c967e5c3eb..c022350ef559 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
+# Generated by makepkg 5.1.0
+# Wed Jun 6 05:43:59 UTC 2018
pkgbase = systemd-kcm
pkgdesc = Systemd control module for KDE
pkgver = 1.2.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/rthomsen/kcmsystemd
arch = x86_64
license = GPL
makedepends = extra-cmake-modules
depends = kio
source = http://download.kde.org/stable/systemd-kcm/systemd-kcm-1.2.1.tar.xz
+ source = qt5_use_modules.patch
sha256sums = 51960f4d3b4a1ceae28737c172c35aec8c1f4e534327fbc6dda76f1c17341389
+ sha256sums = 2829fbc268c0cac5ecf8da05cf15d8548d5d5d40bd5982851b35f143d42c8b7a
pkgname = systemd-kcm
diff --git a/PKGBUILD b/PKGBUILD
index deb32e7a918e..bbd324673913 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,27 @@
pkgname=systemd-kcm
pkgver=1.2.1
-pkgrel=3
+pkgrel=4
pkgdesc="Systemd control module for KDE"
arch=(x86_64)
url='https://github.com/rthomsen/kcmsystemd'
license=(GPL)
depends=(kio)
makedepends=(extra-cmake-modules)
-source=("http://download.kde.org/stable/$pkgname/$pkgname-$pkgver.tar.xz")
-sha256sums=('51960f4d3b4a1ceae28737c172c35aec8c1f4e534327fbc6dda76f1c17341389')
+source=("http://download.kde.org/stable/$pkgname/$pkgname-$pkgver.tar.xz"
+ qt5_use_modules.patch)
+sha256sums=('51960f4d3b4a1ceae28737c172c35aec8c1f4e534327fbc6dda76f1c17341389'
+ '2829fbc268c0cac5ecf8da05cf15d8548d5d5d40bd5982851b35f143d42c8b7a')
prepare() {
mkdir -p build
# fix kdesu path (FS#44396)
sed -e 's|/lib/libexec/kdesu|/lib/kf5/kdesu|' -i $pkgname-$pkgver/src/kcmsystemd.cpp
+
+ # patch qt5_use_modules error
+ cd $pkgname-$pkgver
+ patch -p1 -i ../qt5_use_modules.patch
}
build() {
diff --git a/qt5_use_modules.patch b/qt5_use_modules.patch
new file mode 100644
index 000000000000..2454b188346e
--- /dev/null
+++ b/qt5_use_modules.patch
@@ -0,0 +1,8 @@
+--- a/src/CMakeLists.txt 2018-06-06 07:27:52.477251004 +0200
++++ b/src/CMakeLists.txt 2018-06-06 07:28:26.045157447 +0200
+@@ -38,4 +38,4 @@
+ ${JOURNALD_LIBRARIES})
+ install(TARGETS kcm_systemd DESTINATION ${CMAKE_INSTALL_PLUGINDIR})
+
+-qt5_use_modules(kcm_systemd Widgets DBus)
++target_link_libraries(kcm_systemd Qt5::Widgets Qt5::DBus)