summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado2015-09-11 21:15:18 -0300
committerAndré Fabian Silva Delgado2015-09-11 21:15:18 -0300
commit250504ef25153d558e46a98cbf43843fe2606900 (patch)
tree0b3cb9829bb71e4415ee05ca8bbb21775fcd0400
parent6be4a309ac33efc8ed3500d6ef018712501dc479 (diff)
downloadaur-250504ef25153d558e46a98cbf43843fe2606900.tar.gz
Update to 225-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
-rw-r--r--gnu+linux.patch493
3 files changed, 517 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9d352fb7137..031e1261b088 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = systemd-knock
- pkgver = 224
+ pkgver = 225
pkgrel = 1
url = http://www.freedesktop.org/wiki/Software/systemd
arch = i686
@@ -28,7 +28,7 @@ pkgbase = systemd-knock
makedepends = git
options = strip
options = debug
- source = git://github.com/systemd/systemd.git#tag=v224
+ source = git://github.com/systemd/systemd.git#tag=v225
source = https://repo.parabola.nu/other/knock/patches/systemd/0001-adds-TCP-Stealth-support-to-systemd-221.patch
source = https://repo.parabola.nu/other/systemd-knock/splash-parabola.bmp
source = initcpio-hook-udev
@@ -36,6 +36,7 @@ pkgbase = systemd-knock
source = initcpio-install-udev
source = parabola.conf
source = loader.conf
+ source = gnu+linux.patch
md5sums = SKIP
md5sums = 936208db8995db77efbb388735f950af
md5sums = db7c5e4aaa501c1af4301e011f4f5966
@@ -44,6 +45,7 @@ pkgbase = systemd-knock
md5sums = 1b3aa3a0551b08af9305d33f85b5c2fc
md5sums = 36ee74767ac8734dede1cbd0f4f275d7
md5sums = 9b9f4a58e4c4009bf5290c5b297600c3
+ md5sums = 5d7e15f4bd660cba06a7323b53c1e777
pkgname = systemd-knock
pkgdesc = system and service manager with support for stealth TCP sockets (Parabola rebranded)
@@ -72,9 +74,9 @@ pkgname = systemd-knock
optdepends = systemd-knock-sysvcompat: symlink package to provide sysvinit binaries
optdepends = polkit: allow administration as unprivileged user
provides = nss-myhostname
- provides = systemd-tools=224
- provides = udev=224
- provides = systemd=224
+ provides = systemd-tools=225
+ provides = udev=225
+ provides = systemd=225
conflicts = nss-myhostname
conflicts = systemd-tools
conflicts = udev
@@ -116,14 +118,14 @@ pkgname = libsystemd-knock
provides = libsystemd-journal.so
provides = libsystemd-login.so
provides = libudev.so
- provides = libsystemd=224
+ provides = libsystemd=225
conflicts = libsystemd
pkgname = systemd-knock-sysvcompat
pkgdesc = sysvinit compat for systemd-knock
license = GPL2
depends = systemd-knock
- provides = systemd-sysvcompat=224
+ provides = systemd-sysvcompat=225
conflicts = sysvinit
conflicts = systemd-sysvcompat
diff --git a/PKGBUILD b/PKGBUILD
index 1e117fb78297..e8a8f7ba0f37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgbase=systemd
pkgbase=systemd-knock
pkgname=('systemd-knock' 'libsystemd-knock' 'systemd-knock-sysvcompat')
-pkgver=224
+pkgver=225
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.freedesktop.org/wiki/Software/systemd"
@@ -23,7 +23,8 @@ source=("git://github.com/systemd/systemd.git#tag=v$pkgver"
'initcpio-install-systemd'
'initcpio-install-udev'
'parabola.conf'
- 'loader.conf')
+ 'loader.conf'
+ 'gnu+linux.patch')
md5sums=('SKIP'
'936208db8995db77efbb388735f950af'
'db7c5e4aaa501c1af4301e011f4f5966'
@@ -31,16 +32,22 @@ md5sums=('SKIP'
'976c5511b6493715e381f43f16cdb151'
'1b3aa3a0551b08af9305d33f85b5c2fc'
'36ee74767ac8734dede1cbd0f4f275d7'
- '9b9f4a58e4c4009bf5290c5b297600c3')
+ '9b9f4a58e4c4009bf5290c5b297600c3'
+ '5d7e15f4bd660cba06a7323b53c1e777')
prepare() {
cd "$_pkgbase"
- patch -Np1 <../0001-adds-TCP-Stealth-support-to-systemd-221.patch
+ # Rename "Linux" -> "GNU/Linux"
+ patch -Np1 -i "$srcdir/gnu+linux.patch"
+ sed -i '\|os_name| s|Linux|GNU/Linux|' src/journal-remote/journal-gatewayd.c
+ sed -i '\|pretty_name| s|Linux|GNU/Linux|' src/analyze/analyze.c src/core/main.c src/firstboot/firstboot.c
+ sed -i '\|PRETTY_NAME| s|Linux|GNU/Linux|' src/kernel-install/90-loaderentry.install
+
+ # Rename "Linux Boot Manager" -> "Systemd Boot Manager"
+ sed -i 's|Linux Boot Manager|Systemd Boot Manager|' src/boot/bootctl.c
- # networkd: fix networkd crash
- # https://github.com/systemd/systemd/commit/49f6e11e89b4
- git cherry-pick -n 49f6e11e89b4
+ patch -Np1 <../0001-adds-TCP-Stealth-support-to-systemd-221.patch
./autogen.sh
}
@@ -114,7 +121,7 @@ package_systemd-knock() {
rm -r "$pkgdir/usr/lib/rpm"
# add back tmpfiles.d/legacy.conf
- install -m644 "systemd/tmpfiles.d/legacy.conf" "$pkgdir/usr/lib/tmpfiles.d"
+ install -m644 "$_pkgbase/tmpfiles.d/legacy.conf" "$pkgdir/usr/lib/tmpfiles.d"
# Replace dialout/tape/cdrom group in rules with uucp/storage/optical group
sed -i 's#GROUP="dialout"#GROUP="uucp"#g;
diff --git a/gnu+linux.patch b/gnu+linux.patch
new file mode 100644
index 000000000000..3dbe5259b299
--- /dev/null
+++ b/gnu+linux.patch
@@ -0,0 +1,493 @@
+diff -Nur a/man/bootup.xml b/man/bootup.xml
+--- a/man/bootup.xml 2015-09-11 14:55:47.363340869 -0300
++++ b/man/bootup.xml 2015-09-11 14:57:22.649010069 -0300
+@@ -54,7 +54,7 @@
+ boot. Immediately after power-up, the system BIOS will do minimal
+ hardware initialization, and hand control over to a boot loader
+ stored on a persistent storage device. This boot loader will then
+- invoke an OS kernel from disk (or the network). In the Linux case,
++ invoke an OS kernel from disk (or the network). In the GNU/Linux case,
+ this kernel (optionally) extracts and executes an initial RAM disk
+ image (initrd), such as generated by
+ <citerefentry project='die-net'><refentrytitle>dracut</refentrytitle><manvolnum>8</manvolnum></citerefentry>,
+diff -Nur a/man/custom-html.xsl b/man/custom-html.xsl
+--- a/man/custom-html.xsl 2015-09-11 14:55:47.363340869 -0300
++++ b/man/custom-html.xsl 2015-09-11 15:00:26.850353104 -0300
+@@ -82,10 +82,10 @@
+ </a>
+ </xsl:template>
+
+-<xsl:template match="citerefentry[@project='archlinux']">
++<xsl:template match="citerefentry[@project='parabola']">
+ <a>
+ <xsl:attribute name="href">
+- <xsl:text>https://www.archlinux.org/</xsl:text>
++ <xsl:text>https://www.parabola.nu/</xsl:text>
+ <xsl:value-of select="refentrytitle"/>
+ <xsl:text>/</xsl:text>
+ <xsl:value-of select="refentrytitle"/>
+@@ -95,19 +95,6 @@
+ </xsl:attribute>
+ <xsl:call-template name="inline.charseq"/>
+ </a>
+-</xsl:template>
+-
+-<xsl:template match="citerefentry[@project='freebsd']">
+- <a>
+- <xsl:attribute name="href">
+- <xsl:text>https://www.freebsd.org/cgi/man.cgi?</xsl:text>
+- <xsl:value-of select="refentrytitle"/>
+- <xsl:text>(</xsl:text>
+- <xsl:value-of select="manvolnum"/>
+- <xsl:text>)</xsl:text>
+- </xsl:attribute>
+- <xsl:call-template name="inline.charseq"/>
+- </a>
+ </xsl:template>
+
+ <xsl:template match="citerefentry[@project='dbus']">
+diff -Nur a/man/daemon.xml b/man/daemon.xml
+--- a/man/daemon.xml 2015-09-11 14:55:47.364340876 -0300
++++ b/man/daemon.xml 2015-09-11 15:01:31.162860171 -0300
+@@ -74,7 +74,7 @@
+ <listitem><para>Close all open file descriptors except
+ standard input, output, and error (i.e. the first three file
+ descriptors 0, 1, 2). This ensures that no accidentally passed
+- file descriptor stays around in the daemon process. On Linux,
++ file descriptor stays around in the daemon process. On GNU/Linux,
+ this is best implemented by iterating through
+ <filename>/proc/self/fd</filename>, with a fallback of
+ iterating from file descriptor 3 to the value returned by
+@@ -168,7 +168,7 @@
+ <refsect2>
+ <title>New-Style Daemons</title>
+
+- <para>Modern services for Linux should be implemented as
++ <para>Modern services for GNU/Linux should be implemented as
+ new-style daemons. This makes it easier to supervise and control
+ them at runtime and simplifies their implementation.</para>
+
+@@ -311,7 +311,7 @@
+ as detailed in the <ulink
+ url="http://refspecs.linuxbase.org/LSB_3.1.1/LSB-Core-generic/LSB-Core-generic/iniscrptact.html">LSB
+ Linux Standard Base Core Specification</ulink>. This method of
+- activation is supported ubiquitously on Linux init systems, both
++ activation is supported ubiquitously on GNU/Linux init systems, both
+ old-style and new-style systems. Among other issues, SysV init
+ scripts have the disadvantage of involving shell scripts in the
+ boot process. New-style init systems generally employ updated
+@@ -479,7 +479,7 @@
+ start daemons or <filename>.socket</filename> units when a
+ specific IP address is configured on a network interface,
+ because network sockets shall be bound to the address. However,
+- an alternative to implement this is by utilizing the Linux
++ an alternative to implement this is by utilizing the GNU/Linux
+ <constant>IP_FREEBIND</constant> socket option, as accessible
+ via <varname>FreeBind=yes</varname> in systemd socket files (see
+ <citerefentry><refentrytitle>systemd.socket</refentrytitle><manvolnum>5</manvolnum></citerefentry>
+@@ -491,7 +491,7 @@
+ for service activation is low system load. However, here too, a
+ more convincing approach might be to make proper use of features
+ of the operating system, in particular, the CPU or IO scheduler
+- of Linux. Instead of scheduling jobs from userspace based on
++ of GNU/Linux. Instead of scheduling jobs from userspace based on
+ monitoring the OS scheduler, it is advisable to leave the
+ scheduling of processes to the OS scheduler itself. systemd
+ provides fine-grained access to the CPU and IO schedulers. If a
+diff -Nur a/man/kernel-install.xml b/man/kernel-install.xml
+--- a/man/kernel-install.xml 2015-09-11 14:55:47.366340890 -0300
++++ b/man/kernel-install.xml 2015-09-11 15:04:24.500215627 -0300
+@@ -106,7 +106,7 @@
+ <replaceable>PRETTY_NAME</replaceable> parameter specified
+ in <filename>/etc/os-release</filename> or
+ <filename>/usr/lib/os-release</filename> (if the former is
+- missing), or "Linux
++ missing), or "GNU/Linux
+ <replaceable>KERNEL-VERSION</replaceable>", if unset. If
+ the file <filename>initrd</filename> is found next to the
+ <filename>linux</filename> file, the initrd will be added to
+diff -Nur a/man/os-release.xml b/man/os-release.xml
+--- a/man/os-release.xml 2015-09-11 14:55:47.368340904 -0300
++++ b/man/os-release.xml 2015-09-11 15:30:35.417171013 -0300
+@@ -121,8 +121,8 @@
+ <listitem><para>A string identifying the operating system,
+ without a version component, and suitable for presentation to
+ the user. If not set, defaults to
+- <literal>NAME=Linux</literal>. Example:
+- <literal>NAME=Fedora</literal> or <literal>NAME="Debian
++ <literal>NAME=GNU/Linux</literal>. Example:
++ <literal>NAME=BLAG</literal> or <literal>NAME="gNewSense
+ GNU/Linux"</literal>.</para></listitem>
+ </varlistentry>
+
+@@ -133,8 +133,8 @@
+ version, excluding any OS name information, possibly including
+ a release code name, and suitable for presentation to the
+ user. This field is optional. Example:
+- <literal>VERSION=17</literal> or <literal>VERSION="17 (Beefy
+- Miracle)"</literal>.</para></listitem>
++ <literal>VERSION=210k</literal> or <literal>VERSION="210k"
++ </literal>.</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+@@ -145,9 +145,9 @@
+ the operating system, excluding any version information and
+ suitable for processing by scripts or usage in generated
+ filenames. If not set, defaults to
+- <literal>ID=linux</literal>. Example:
+- <literal>ID=fedora</literal> or
+- <literal>ID=debian</literal>.</para></listitem>
++ <literal>ID=gnu-plus-linux</literal>. Example:
++ <literal>ID=blag</literal> or
++ <literal>ID=gnewsense</literal>.</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+@@ -168,9 +168,9 @@
+ should be listed in order of how closely the local operating
+ system relates to the listed ones, starting with the closest.
+ This field is optional. Example: for an operating system with
+- <literal>ID=centos</literal>, an assignment of
++ <literal>ID=blag</literal>, an assignment of
+ <literal>ID_LIKE="rhel fedora"</literal> would be appropriate.
+- For an operating system with <literal>ID=ubuntu</literal>, an
++ For an operating system with <literal>ID=gnewsense</literal>, an
+ assignment of <literal>ID_LIKE=debian</literal> is
+ appropriate.</para></listitem>
+ </varlistentry>
+@@ -183,8 +183,8 @@
+ identifying the operating system version, excluding any OS
+ name information or release code name, and suitable for
+ processing by scripts or usage in generated filenames. This
+- field is optional. Example: <literal>VERSION_ID=17</literal>
+- or <literal>VERSION_ID=11.04</literal>.</para></listitem>
++ field is optional. Example: <literal>VERSION_ID=210k</literal>
++ or <literal>VERSION_ID=7.0</literal>.</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+@@ -194,9 +194,8 @@
+ suitable for presentation to the user. May or may not contain
+ a release code name or OS version of some kind, as suitable.
+ If not set, defaults to
+- <literal>PRETTY_NAME="Linux"</literal>. Example:
+- <literal>PRETTY_NAME="Fedora 17 (Beefy
+- Miracle)"</literal>.</para></listitem>
++ <literal>PRETTY_NAME="GNU/Linux"</literal>. Example:
++ <literal>PRETTY_NAME="BLAG 210k"</literal>.</para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+@@ -218,7 +217,7 @@
+ the <ulink url="https://cpe.mitre.org/specification/">Common
+ Platform Enumeration Specification</ulink> as proposed by the
+ MITRE Corporation. This field is optional. Example:
+- <literal>CPE_NAME="cpe:/o:fedoraproject:fedora:17"</literal>
++ <literal>CPE_NAME="cpe:/o:blagblagblag:blag:210k"</literal>
+ </para></listitem>
+ </varlistentry>
+
+@@ -253,8 +252,8 @@
+ one URL shall be listed in each setting. If multiple resources
+ need to be referenced, it is recommended to provide an online
+ landing page linking all available resources. Examples:
+- <literal>HOME_URL="https://fedoraproject.org/"</literal> and
+- <literal>BUG_REPORT_URL="https://bugzilla.redhat.com/"</literal></para></listitem>
++ <literal>HOME_URL="https://www.blagblagblag.org/"</literal> and
++ <literal>BUG_REPORT_URL="https://blag.fsf.org/"</literal></para></listitem>
+ </varlistentry>
+
+ <varlistentry>
+@@ -329,21 +328,22 @@
+ recommended to prefix new fields with an OS specific
+ name in order to avoid name clashes. Applications
+ reading this file must ignore unknown fields. Example:
+- <literal>DEBIAN_BTS="debbugs://bugs.debian.org/"</literal></para>
++ <literal>DEBIAN_BTS="debbugs://bugs.gnewsense.org/"</literal></para>
+ </refsect1>
+
+ <refsect1>
+ <title>Example</title>
+
+- <programlisting>NAME=Fedora
+-VERSION="17 (Beefy Miracle)"
+-ID=fedora
+-VERSION_ID=17
+-PRETTY_NAME="Fedora 17 (Beefy Miracle)"
+-ANSI_COLOR="0;34"
+-CPE_NAME="cpe:/o:fedoraproject:fedora:17"
+-HOME_URL="https://fedoraproject.org/"
+-BUG_REPORT_URL="https://bugzilla.redhat.com/"</programlisting>
++ <programlisting>NAME=Parabola
++VERSION="rolling-release"
++ID=parabola
++ID_LIKE=arch
++VERSION_ID=rolling-release
++PRETTY_NAME="Parabola GNU/Linux-libre"
++ANSI_COLOR="1;35"
++CPE_NAME="cpe:/o:parabola:parabola:rolling-release"
++HOME_URL="https://www.parabola.nu/"
++BUG_REPORT_URL="https://labs.parabola.nu/"</programlisting>
+ </refsect1>
+
+ <refsect1>
+diff -Nur a/man/sd_bus_error_add_map.xml b/man/sd_bus_error_add_map.xml
+--- a/man/sd_bus_error_add_map.xml 2015-09-11 14:55:47.369340911 -0300
++++ b/man/sd_bus_error_add_map.xml 2015-09-11 15:31:21.081524317 -0300
+@@ -82,7 +82,7 @@
+
+ <para>The <function>sd_bus_error_add_map()</function> call may be
+ used to register additional mappings for converting D-Bus errors
+- to Linux <varname>errno</varname>-style errors. The mappings
++ to GNU/Linux <varname>errno</varname>-style errors. The mappings
+ defined with this call are consulted by calls such as
+ <citerefentry><refentrytitle>sd_bus_error_set</refentrytitle><manvolnum>3</manvolnum></citerefentry>
+ or
+diff -Nur a/man/sd-bus-errors.xml b/man/sd-bus-errors.xml
+--- a/man/sd-bus-errors.xml 2015-09-11 14:55:47.368340904 -0300
++++ b/man/sd-bus-errors.xml 2015-09-11 15:31:32.009608698 -0300
+@@ -126,7 +126,7 @@
+
+ <para>In addition to this list, in sd-bus the special error
+ namespace <literal>System.Error.</literal> is used to map
+- arbitrary Linux system errors (as defined by <citerefentry
++ arbitrary GNU/Linux system errors (as defined by <citerefentry
+ project='man-pages'><refentrytitle>errno</refentrytitle><manvolnum>3</manvolnum></citerefentry>)
+ to D-Bus errors and back. For example, the error
+ <constant>EUCLEAN</constant> is mapped to
+diff -Nur a/man/sd_is_fifo.xml b/man/sd_is_fifo.xml
+--- a/man/sd_is_fifo.xml 2015-09-11 14:55:47.372340932 -0300
++++ b/man/sd_is_fifo.xml 2015-09-11 15:32:47.346188708 -0300
+@@ -145,7 +145,7 @@
+ the <parameter>path</parameter> parameter is
+ <constant>NULL</constant>. For normal file system
+ <constant>AF_UNIX</constant> sockets, set the
+- <parameter>length</parameter> parameter to 0. For Linux abstract
++ <parameter>length</parameter> parameter to 0. For GNU/Linux abstract
+ namespace sockets, set the <parameter>length</parameter> to the
+ size of the address, including the initial 0 byte, and set the
+ <parameter>path</parameter> to the initial 0 byte of the socket
+diff -Nur a/man/sd-login.xml b/man/sd-login.xml
+--- a/man/sd-login.xml 2015-09-11 14:55:47.368340904 -0300
++++ b/man/sd-login.xml 2015-09-11 15:33:41.770605951 -0300
+@@ -68,8 +68,8 @@
+
+ <para>See <ulink
+ url="http://www.freedesktop.org/wiki/Software/systemd/multiseat">Multi-Seat
+- on Linux</ulink> for an introduction into multi-seat support on
+- Linux, the background for this set of APIs.</para>
++ on GNU/Linux</ulink> for an introduction into multi-seat support on
++ GNU/Linux, the background for this set of APIs.</para>
+
+ <para>Note that these APIs only allow purely passive access and
+ monitoring of seats, sessions and users. To actively make changes
+diff -Nur a/man/sd_notify.xml b/man/sd_notify.xml
+--- a/man/sd_notify.xml 2015-09-11 14:55:47.374340946 -0300
++++ b/man/sd_notify.xml 2015-09-11 15:34:14.466855938 -0300
+@@ -295,7 +295,7 @@
+ referenced in the <varname>$NOTIFY_SOCKET</varname> environment
+ variable. If the first character of
+ <varname>$NOTIFY_SOCKET</varname> is <literal>@</literal>, the
+- string is understood as Linux abstract namespace socket. The
++ string is understood as GNU/Linux abstract namespace socket. The
+ datagram is accompanied by the process credentials of the sending
+ service, using SCM_CREDENTIALS.</para>
+ </refsect1>
+diff -Nur a/man/systemd-detect-virt.xml b/man/systemd-detect-virt.xml
+--- a/man/systemd-detect-virt.xml 2015-09-11 14:55:47.377340967 -0300
++++ b/man/systemd-detect-virt.xml 2015-09-11 15:43:31.015047569 -0300
+@@ -104,16 +104,6 @@
+ </row>
+
+ <row>
+- <entry><varname>vmware</varname></entry>
+- <entry>VMware Workstation or Server, and related products</entry>
+- </row>
+-
+- <row>
+- <entry><varname>microsoft</varname></entry>
+- <entry>Hyper-V, also known as Viridian or Windows Server Virtualization</entry>
+- </row>
+-
+- <row>
+ <entry><varname>oracle</varname></entry>
+ <entry>Oracle VM VirtualBox (historically marketed by innotek and Sun Microsystems)</entry>
+ </row>
+@@ -141,12 +131,12 @@
+
+ <row>
+ <entry><varname>lxc</varname></entry>
+- <entry>Linux container implementation by LXC</entry>
++ <entry>GNU/Linux container implementation by (G)LXC</entry>
+ </row>
+
+ <row>
+ <entry><varname>lxc-libvirt</varname></entry>
+- <entry>Linux container implementation by libvirt</entry>
++ <entry>GNU/Linux container implementation by libvirt</entry>
+ </row>
+
+ <row>
+diff -Nur a/man/systemd-logind.service.xml b/man/systemd-logind.service.xml
+--- a/man/systemd-logind.service.xml 2015-09-11 14:55:47.378340974 -0300
++++ b/man/systemd-logind.service.xml 2015-09-11 15:45:37.799989107 -0300
+@@ -94,7 +94,7 @@
+
+ <para>See <ulink
+ url="http://www.freedesktop.org/wiki/Software/systemd/multiseat">Multi-Seat
+- on Linux</ulink> for an introduction into basic concepts of logind
++ on GNU/Linux</ulink> for an introduction into basic concepts of logind
+ such as users, sessions and seats.</para>
+
+ <para>See the <ulink
+diff -Nur a/man/systemd-machine-id-setup.xml b/man/systemd-machine-id-setup.xml
+--- a/man/systemd-machine-id-setup.xml 2015-09-11 14:55:47.379340981 -0300
++++ b/man/systemd-machine-id-setup.xml 2015-09-11 15:46:03.880182303 -0300
+@@ -78,7 +78,7 @@
+ must ensure that the UUID passed is sufficiently unique and is
+ different for every booted instanced of the VM.</para>
+
+- <para>Similar, if run inside a Linux container environment and a
++ <para>Similar, if run inside a GNU/Linux container environment and a
+ UUID is set for the container this is used to initialize the
+ machine ID. For details see the documentation of the <ulink
+ url="http://www.freedesktop.org/wiki/Software/systemd/ContainerInterface">Container
+diff -Nur a/man/systemd-nspawn.xml b/man/systemd-nspawn.xml
+--- a/man/systemd-nspawn.xml 2015-09-11 14:55:47.379340981 -0300
++++ b/man/systemd-nspawn.xml 2015-09-11 16:07:48.210766346 -0300
+@@ -91,7 +91,7 @@
+
+ <para>In contrast to
+ <citerefentry project='man-pages'><refentrytitle>chroot</refentrytitle><manvolnum>1</manvolnum></citerefentry> <command>systemd-nspawn</command>
+- may be used to boot full Linux-based operating systems in a
++ may be used to boot full GNU/Linux-based operating systems in a
+ container.</para>
+
+ <para>Use a tool like
+@@ -99,7 +99,7 @@
+ <citerefentry project='die-net'><refentrytitle>yum</refentrytitle><manvolnum>8</manvolnum></citerefentry>,
+ <citerefentry project='die-net'><refentrytitle>debootstrap</refentrytitle><manvolnum>8</manvolnum></citerefentry>,
+ or
+- <citerefentry project='archlinux'><refentrytitle>pacman</refentrytitle><manvolnum>8</manvolnum></citerefentry>
++ <citerefentry project='parabola'><refentrytitle>pacman</refentrytitle><manvolnum>8</manvolnum></citerefentry>
+ to set up an OS directory tree suitable as file system hierarchy
+ for <command>systemd-nspawn</command> containers.</para>
+
+@@ -783,46 +783,35 @@
+ <title>Examples</title>
+
+ <example>
+- <title>Download a Fedora image and start a shell in it</title>
++ <title>Build and boot a minimal BLAG distribution in a container</title>
+
+- <programlisting># machinectl pull-raw --verify=no http://ftp.halifax.rwth-aachen.de/fedora/linux/releases/21/Cloud/Images/x86_64/Fedora-Cloud-Base-20141203-21.x86_64.raw.xz
+-# systemd-nspawn -M Fedora-Cloud-Base-20141203-21</programlisting>
+-
+- <para>This downloads an image using
+- <citerefentry><refentrytitle>machinectl</refentrytitle><manvolnum>1</manvolnum></citerefentry>
+- and opens a shell in it.</para>
+- </example>
+-
+- <example>
+- <title>Build and boot a minimal Fedora distribution in a container</title>
+-
+- <programlisting># dnf -y --releasever=21 --nogpg --installroot=/srv/mycontainer --disablerepo='*' --enablerepo=fedora install systemd passwd dnf fedora-release vim-minimal
++ <programlisting># dnf -y --releasever=210k --nogpg --installroot=/srv/mycontainer --disablerepo='*' --enablerepo=blag install systemd passwd dnf blag-release vim-minimal
+ # systemd-nspawn -bD /srv/mycontainer</programlisting>
+
+- <para>This installs a minimal Fedora distribution into the
++ <para>This installs a minimal BLAG distribution into the
+ directory <filename noindex='true'>/srv/mycontainer/</filename>
+ and then boots an OS in a namespace container in it.</para>
+ </example>
+
+ <example>
+- <title>Spawn a shell in a container of a minimal Debian unstable distribution</title>
++ <title>Spawn a shell in a container of a minimal gNewSense unstable distribution</title>
+
+ <programlisting># debootstrap --arch=amd64 unstable ~/debian-tree/
+-# systemd-nspawn -D ~/debian-tree/</programlisting>
++# systemd-nspawn -D ~/gnewsense-tree/</programlisting>
+
+- <para>This installs a minimal Debian unstable distribution into
+- the directory <filename>~/debian-tree/</filename> and then
++ <para>This installs a minimal gNewSense unstable distribution into
++ the directory <filename>~/gnewsense-tree/</filename> and then
+ spawns a shell in a namespace container in it.</para>
+ </example>
+
+ <example>
+- <title>Boot a minimal Arch Linux distribution in a container</title>
++ <title>Boot a minimal Parabola GNU/Linux-libre distribution in a container</title>
+
+- <programlisting># pacstrap -c -d ~/arch-tree/ base
+-# systemd-nspawn -bD ~/arch-tree/</programlisting>
++ <programlisting># pacstrap -c -d ~/parabola-tree/ base
++# systemd-nspawn -bD ~/parabola-tree/</programlisting>
+
+- <para>This installs a minimal Arch Linux distribution into the
+- directory <filename>~/arch-tree/</filename> and then boots an OS
++ <para>This installs a minimal Parabola GNU/Linux-libre distribution into the
++ directory <filename>~/parabola-tree/</filename> and then boots an OS
+ in a namespace container in it.</para>
+ </example>
+
+@@ -860,7 +849,7 @@
+ <citerefentry project='mankier'><refentrytitle>dnf</refentrytitle><manvolnum>8</manvolnum></citerefentry>,
+ <citerefentry project='die-net'><refentrytitle>yum</refentrytitle><manvolnum>8</manvolnum></citerefentry>,
+ <citerefentry project='die-net'><refentrytitle>debootstrap</refentrytitle><manvolnum>8</manvolnum></citerefentry>,
+- <citerefentry project='archlinux'><refentrytitle>pacman</refentrytitle><manvolnum>8</manvolnum></citerefentry>,
++ <citerefentry project='parabola'><refentrytitle>pacman</refentrytitle><manvolnum>8</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>systemd.slice</refentrytitle><manvolnum>5</manvolnum></citerefentry>,
+ <citerefentry><refentrytitle>machinectl</refentrytitle><manvolnum>1</manvolnum></citerefentry>,
+ <citerefentry project='man-pages'><refentrytitle>btrfs</refentrytitle><manvolnum>8</manvolnum></citerefentry>
+diff -Nur a/man/systemd-sleep.conf.xml b/man/systemd-sleep.conf.xml
+--- a/man/systemd-sleep.conf.xml 2015-09-11 14:55:47.380340988 -0300
++++ b/man/systemd-sleep.conf.xml 2015-09-11 16:08:59.858313702 -0300
+@@ -165,7 +165,7 @@
+ <title>Example: freeze</title>
+
+ <para>Example: to exploit the <quote>freeze</quote> mode added
+- in Linux 3.9, one can use <command>systemctl suspend</command>
++ in Linux 3.9 kernel, one can use <command>systemctl suspend</command>
+ with
+ <programlisting>[Sleep]
+ SuspendState=freeze</programlisting></para>
+diff -Nur a/man/systemd.socket.xml b/man/systemd.socket.xml
+--- a/man/systemd.socket.xml 2015-09-11 14:55:47.385341023 -0300
++++ b/man/systemd.socket.xml 2015-09-11 16:09:44.235652283 -0300
+@@ -255,7 +255,7 @@
+ <listitem><para>Specifies a POSIX message queue name to listen
+ on. This expects a valid message queue name (i.e. beginning
+ with /). Behavior otherwise is very similar to the
+- <varname>ListenFIFO=</varname> directive above. On Linux
++ <varname>ListenFIFO=</varname> directive above. On GNU/Linux
+ message queue descriptors are actually file descriptors and
+ can be inherited between processes.</para></listitem>
+ </varlistentry>
+diff -Nur a/man/systemd.xml b/man/systemd.xml
+--- a/man/systemd.xml 2015-09-11 14:55:47.386341030 -0300
++++ b/man/systemd.xml 2015-09-11 16:31:49.069636893 -0300
+@@ -61,7 +61,7 @@
+ <refsect1>
+ <title>Description</title>
+
+- <para>systemd is a system and service manager for Linux operating
++ <para>systemd is a system and service manager for GNU/Linux operating
+ systems. When run as first process on boot (as PID 1), it acts as
+ init system that brings up and maintains userspace
+ services.</para>
+@@ -826,10 +826,10 @@
+ <title>Kernel Command Line</title>
+
+ <para>When run as system instance systemd parses a number of
+- kernel command line arguments<footnote><para>If run inside a Linux
++ kernel command line arguments<footnote><para>If run inside a GNU/Linux
+ container these arguments may be passed as command line arguments
+ to systemd itself, next to any of the command line options listed
+- in the Options section above. If run outside of Linux containers,
++ in the Options section above. If run outside of GNU/Linux containers,
+ these arguments are parsed from <filename>/proc/cmdline</filename>
+ instead.</para></footnote>:</para>
+