summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2017-05-28 23:17:27 -0300
committerHugo Osvaldo Barrera2017-05-28 23:17:27 -0300
commit008329273468268c47b91d9c40c49d2eb23022e8 (patch)
treedee7831d2e4ff75cb78887385a9215d17201c304
downloadaur-008329273468268c47b91d9c40c49d2eb23022e8.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4780a4092cd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Mon May 29 02:17:05 UTC 2017
+pkgbase = systemd-lock-handler
+ pkgdesc = Logind lock event to systemd target translation.
+ pkgver = r1.f40a415
+ pkgrel = 1
+ url = https://github.com/hobarrera/systemd-lock-handler
+ arch = any
+ license = ISC
+ depends = python2-txdbus
+ source = systemd-lock-handler::git+https://github.com/hobarrera/systemd-lock-handler.git
+ md5sums = SKIP
+
+pkgname = systemd-lock-handler
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0658e301f051
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+
+pkgname="systemd-lock-handler"
+pkgver=r1.f40a415
+pkgrel=1
+pkgdesc="Logind lock event to systemd target translation."
+arch=('any')
+url="https://github.com/hobarrera/systemd-lock-handler"
+license=('ISC')
+depends=('python2-txdbus')
+source=("$pkgname::git+https://github.com/hobarrera/systemd-lock-handler.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $srcdir/$pkgname
+
+ make DESTDIR="$pkgdir/" install
+}