summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorswyter2015-06-10 21:48:19 +0200
committerswyter2015-06-10 21:48:19 +0200
commit325fd298b0a6e3f03b18c5a4c0747efab8b8b7a6 (patch)
tree91ba99a9df91fa98b3eeb6d990cf2b200b4a53dc
downloadaur-325fd298b0a6e3f03b18c5a4c0747efab8b8b7a6.tar.gz
*first commit, hello world!
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD139
-rw-r--r--systemd-readahead.install18
3 files changed, 176 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e59f3214fa60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = systemd-readahead
+ pkgdesc = Standalone version of the fast built-in readahead implementation dropped in systemd 217
+ pkgver = 216
+ pkgrel = 1
+ url = https://dev.gentoo.org/~pacho/systemd-readahead.html
+ install = systemd-readahead.install
+ arch = i686
+ arch = x86_64
+ license = LGPL-2.1 MIT
+ makedepends = make
+ makedepends = autoconf
+ makedepends = gperf
+ makedepends = sed
+ depends = systemd>216
+ source = http://www.freedesktop.org/software/systemd/systemd-216.tar.xz
+ md5sums = 04fda588a04f549da0f397dce3ae6a39
+
+pkgname = systemd-readahead
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d9c5fb17070
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,139 @@
+# Maintainer: swyter <swyterzone+aur@gmail.com>
+
+# Based on the excellent Gentoo ebuild created by Pacho Ramos <pacho@gentoo.org>
+# <https://github.com/gentoo/gentoo-portage-rsync-mirror/blob/master/sys-apps/systemd-readahead/systemd-readahead-216.ebuild>
+
+pkgname=systemd-readahead
+pkgver=216
+pkgrel=1
+epoch=
+pkgdesc="Standalone version of the fast built-in readahead implementation dropped in systemd 217"
+arch=('i686' 'x86_64')
+url="https://dev.gentoo.org/~pacho/systemd-readahead.html"
+license=('LGPL-2.1 MIT')
+depends=("systemd>$pkgver")
+makedepends=('make' 'autoconf' 'gperf' 'sed')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+install=systemd-readahead.install
+source=("http://www.freedesktop.org/software/systemd/systemd-$pkgver.tar.xz")
+md5sums=('04fda588a04f549da0f397dce3ae6a39')
+
+prepare()
+{
+ cd "systemd-$pkgver"
+
+ # systemd-notify no longer supports readahead playing
+ sed -i -e 's:ExecStart=@SYSTEMD_NOTIFY@ --readahead=done:ExecStart=/bin/touch /run/systemd/readahead/done:' \
+ units/systemd-readahead-done.service.in || die
+}
+
+build()
+{
+ cd "systemd-$pkgver"
+
+ ./configure --enable-readahead --prefix=/usr \
+ --disable-maintainer-mode \
+ --localstatedir=/var \
+ --enable-split-usr \
+ \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --sysconfdir=/etc \
+ \
+ --with-rootprefix=/usr \
+ --with-rootlibdir=/usr/lib \
+ --with-sysvinit-path= \
+ --with-sysvrcnd-path= \
+ --disable-efi \
+ --disable-ima \
+ --disable-acl \
+ --disable-apparmor \
+ --disable-audit \
+ --disable-libcryptsetup \
+ --disable-libcurl \
+ --disable-gtk-doc \
+ --disable-elfutils \
+ --disable-gcrypt \
+ --disable-gudev \
+ --disable-microhttpd \
+ --disable-gnutls \
+ --disable-libidn \
+ --disable-introspection \
+ --disable-kdbus \
+ --disable-kmod \
+ --disable-lz4 \
+ --disable-xz \
+ --disable-pam \
+ --disable-polkit \
+ --without-python \
+ --disable-python-devel \
+ --disable-qrencode \
+ --disable-seccomp \
+ --disable-selinux \
+ --disable-tests \
+ --disable-dbus \
+ --disable-smack \
+ --disable-blkid \
+ --disable-multi-seat-x \
+ --disable-myhostname \
+ \
+ --disable-backlight \
+ --disable-binfmt \
+ --disable-bootchart \
+ --disable-coredump \
+ --disable-firstboot \
+ --disable-hostnamed \
+ --disable-localed \
+ --disable-logind \
+ --disable-machined \
+ --disable-networkd \
+ --disable-quotacheck \
+ --disable-randomseed \
+ --disable-resolved \
+ --disable-rfkill \
+ --disable-sysusers \
+ --disable-timedated \
+ --disable-timesyncd \
+ --disable-tmpfiles \
+ --disable-vconsole \
+ \
+ --disable-chkconfig \
+ \
+ --with-dbuspolicydir=/etc/dbus-1/system.d \
+ --with-dbussessionservicedir=/usr/share/dbus-1/services \
+ --with-dbussystemservicedir=/usr/share/dbus-1/system-services \
+ --with-dbusinterfacedir=/usr/share/dbus-1/interfaces
+
+ echo 'BUILT_SOURCES: $(BUILT_SOURCES)' > ./Makefile.extra
+ make -f Makefile -f ./Makefile.extra BUILT_SOURCES
+
+ make systemd-readahead
+ make units/systemd-readahead-{drop,collect,replay,done}.service units/systemd-readahead-done.timer
+ make man/{sd-readahead.3,sd_readahead.3,systemd-readahead-replay.service.8}
+}
+
+package()
+{
+ cd "systemd-$pkgver"
+
+ # Install main app
+ install -Dm 755 "systemd-readahead" "$pkgdir/usr/lib/systemd/systemd-readahead"
+
+ # Install unit files
+ install -Dm 644 "units/systemd-readahead-drop.service" "$pkgdir/usr/lib/systemd/system/systemd-readahead-drop.service"
+ install -Dm 644 "units/systemd-readahead-collect.service" "$pkgdir/usr/lib/systemd/system/systemd-readahead-collect.service"
+ install -Dm 644 "units/systemd-readahead-replay.service" "$pkgdir/usr/lib/systemd/system/systemd-readahead-replay.service"
+ install -Dm 644 "units/systemd-readahead-done.service" "$pkgdir/usr/lib/systemd/system/systemd-readahead-done.service"
+ install -Dm 644 "units/systemd-readahead-done.timer" "$pkgdir/usr/lib/systemd/system/systemd-readahead-done.timer"
+
+ # Install manpages and aliases
+ install -Dm 644 "man/systemd-readahead-collect.service.8" "$pkgdir/usr/share/man/man8/systemd-readahead-collect.service.8"
+ install -Dm 644 "man/systemd-readahead-done.service.8" "$pkgdir/usr/share/man/man8/systemd-readahead-done.service.8"
+ install -Dm 644 "man/systemd-readahead-done.timer.8" "$pkgdir/usr/share/man/man8/systemd-readahead-done.timer.8"
+ install -Dm 644 "man/systemd-readahead-replay.service.8" "$pkgdir/usr/share/man/man8/systemd-readahead-replay.service.8"
+ install -Dm 644 "man/systemd-readahead.8" "$pkgdir/usr/share/man/man8/systemd-readahead.8"
+}
diff --git a/systemd-readahead.install b/systemd-readahead.install
new file mode 100644
index 000000000000..aca739dfd1ea
--- /dev/null
+++ b/systemd-readahead.install
@@ -0,0 +1,18 @@
+# Maintainer: swyter <swyterzone+aur@gmail.com>
+
+post_install()
+{
+ echo ""
+ echo -e "\e[1mImportant:\e[0m for it to work you need to enable the \e[3msystemd\e[0m services like this:"
+ echo -e "\e[7m>> \e[3msystemctl enable systemd-readahead-collect\e[0m"
+ echo -e "\e[7m>> \e[3msystemctl enable systemd-readahead-replay\e[0m"
+ echo ""
+ echo -e "For more info use \e[3mman\e[0m or just take a look to the original help page:"
+ echo -e "<\e[4mhttp://www.freedesktop.org/software/systemd/man/systemd-readahead.html\e[0m>"
+ echo ""
+}
+
+post_upgrade()
+{
+ post_install
+}