summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwyter2022-03-05 01:28:12 +0100
committerSwyter2022-03-05 01:28:12 +0100
commitb792238ed5e28d4db4b350ca248c76f948df91e7 (patch)
tree4ad70a05714a599386a5e996725f392e2567daf4
parentf9a75087aaa79e35bafcbcdca472af3962884b1d (diff)
downloadaur-b792238ed5e28d4db4b350ca248c76f948df91e7.tar.gz
Minor cleanups, remove setting $CC to `clang`. Add a patch checksum. Make it tidy.
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28280cbfe62a..0fba4f26d4b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,8 @@ conflicts=()
replaces=()
install=systemd-readahead.install
source=("https://freedesktop.org/software/systemd/systemd-$pkgver.tar.xz" "systemd-$pkgver-fixes.patch")
-md5sums=('04fda588a04f549da0f397dce3ae6a39' 'SKIP')
+md5sums=('04fda588a04f549da0f397dce3ae6a39'
+ 'e680c9819960a97b0691b27f3d0afb37')
prepare()
{
@@ -37,8 +38,6 @@ build()
{
cd "systemd-$pkgver"
- export CC=clang
-
./configure --enable-readahead --prefix=/usr \
--disable-maintainer-mode \
--localstatedir=/var \
@@ -127,9 +126,10 @@ package()
# Install main app
install -Dm 755 "systemd-readahead" "$pkgdir/usr/lib/systemd/systemd-readahead"
- install -d "$pkgdir/usr/lib/systemd/system/"
# Install unit files
+ install -d "$pkgdir/usr/lib/systemd/system/"
+
install -Dm 644 "units/systemd-readahead-drop.service" "$pkgdir/usr/lib/systemd/system/"
install -Dm 644 "units/systemd-readahead-collect.service" "$pkgdir/usr/lib/systemd/system/"
install -Dm 644 "units/systemd-readahead-replay.service" "$pkgdir/usr/lib/systemd/system/"
@@ -137,9 +137,9 @@ package()
install -Dm 644 "units/systemd-readahead-done.timer" "$pkgdir/usr/lib/systemd/system/"
+ # Install manpages and aliases
install -d "$pkgdir/usr/share/man/man8/"
- # Install manpages and aliases
install -Dm 644 "man/systemd-readahead-collect.service.8" "$pkgdir/usr/share/man/man8/"
install -Dm 644 "man/systemd-readahead-done.service.8" "$pkgdir/usr/share/man/man8/"
install -Dm 644 "man/systemd-readahead-done.timer.8" "$pkgdir/usr/share/man/man8/"