summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2019-02-19 22:58:59 +0100
committerNicolas Iooss2019-02-19 22:58:59 +0100
commit74e55e89385df1b9cb5f9f310253958cd9cb6d84 (patch)
tree3f7a5caf6bf159cec74bd7e47539181802c21c05
parent20a87a0efaba6df01cde6758a70c4b0fbd156217 (diff)
downloadaur-74e55e89385df1b9cb5f9f310253958cd9cb6d84.tar.gz
systemd-selinux 241.0-1 update
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD26
2 files changed, 31 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4641554dee40..d139874492bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = systemd-selinux
- pkgver = 240.95
+ pkgver = 241.0
pkgrel = 1
url = https://www.github.com/systemd/systemd
arch = x86_64
@@ -36,8 +36,8 @@ pkgbase = systemd-selinux
makedepends = bash-completion
makedepends = libselinux
options = strip
- source = git+https://github.com/systemd/systemd-stable#tag=v240?signed
- source = git+https://github.com/systemd/systemd#tag=v240?signed
+ source = git+https://github.com/systemd/systemd-stable#tag=v241?signed
+ source = git+https://github.com/systemd/systemd#tag=v241?signed
source = 0001-Use-Arch-Linux-device-access-groups.patch
source = initcpio-hook-udev
source = initcpio-install-systemd
@@ -94,7 +94,7 @@ pkgname = systemd-selinux
depends = hwids
depends = libcap
depends = libgcrypt
- depends = libsystemd-selinux
+ depends = systemd-libs-selinux
depends = libidn2
depends = libidn2.so
depends = lz4
@@ -111,9 +111,9 @@ pkgname = systemd-selinux
optdepends = polkit: allow administration as unprivileged user
optdepends = curl: machinectl pull-tar and pull-raw
provides = nss-myhostname
- provides = systemd-tools=240.95
- provides = udev=240.95
- provides = systemd=240.95-1
+ provides = systemd-tools=241.0
+ provides = udev=241.0
+ provides = systemd=241.0-1
conflicts = nss-myhostname
conflicts = systemd-tools
conflicts = udev
@@ -131,7 +131,7 @@ pkgname = systemd-selinux
backup = etc/systemd/user.conf
backup = etc/udev/udev.conf
-pkgname = libsystemd-selinux
+pkgname = systemd-libs-selinux
pkgdesc = systemd client libraries with SELinux support
license = LGPL2.1
depends = glibc
@@ -140,10 +140,13 @@ pkgname = libsystemd-selinux
depends = lz4
depends = xz
depends = libselinux
+ provides = libsystemd
provides = libsystemd.so
provides = libudev.so
- provides = libsystemd=240.95-1
- conflicts = libsystemd
+ provides = libsystemd-selinux
+ provides = systemd-libs=241.0-1
+ conflicts = systemd-libs
+ replaces = libsystemd-selinux
pkgname = systemd-resolvconf-selinux
pkgdesc = systemd resolvconf replacement with SELinux support (for use with systemd-resolved)
@@ -151,16 +154,16 @@ pkgname = systemd-resolvconf-selinux
depends = systemd-selinux
provides = openresolv
provides = resolvconf
- provides = systemd-resolvconf=240.95-1
+ provides = systemd-resolvconf=241.0-1
conflicts = openresolv
- conflicts = systemd-resolvconf=240.95-1
+ conflicts = systemd-resolvconf=241.0-1
pkgname = systemd-sysvcompat-selinux
pkgdesc = sysvinit compat for systemd with SELinux support
license = GPL2
depends = systemd-selinux
- provides = systemd-sysvcompat=240.95-1
- provides = selinux-systemd-sysvcompat=240.95-1
+ provides = systemd-sysvcompat=241.0-1
+ provides = selinux-systemd-sysvcompat=241.0-1
conflicts = sysvinit
conflicts = systemd-sysvcompat
conflicts = selinux-systemd-sysvcompat
diff --git a/PKGBUILD b/PKGBUILD
index d0ccf269305a..efc307de8c9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,10 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgbase=systemd-selinux
-pkgname=('systemd-selinux' 'libsystemd-selinux' 'systemd-resolvconf-selinux' 'systemd-sysvcompat-selinux')
+pkgname=('systemd-selinux' 'systemd-libs-selinux' 'systemd-resolvconf-selinux' 'systemd-sysvcompat-selinux')
# Can be from either systemd or systemd-stable
-_commit='0430af90ef28a229e51136ad364e1da7e76c8638'
-pkgver=240.95
+_commit='e62a7fea757f259eb330da5b6d3ab4ede46400a2'
+pkgver=241.0
pkgrel=1
arch=('x86_64')
url='https://www.github.com/systemd/systemd'
@@ -78,8 +78,6 @@ sha512sums=('SKIP'
'209b01b044877cc986757fa4009a92ea98f480306c2530075d153203c3cd2b3afccab6aacc1453dee8857991e04270572f1700310705d7a0f4d5bed27fab8c67')
_backports=(
- # https://github.com/systemd/systemd/issues/11259
- '8ca9e92c742602b8bcd431001e6f5b78c28c184f'
)
_reverts=(
@@ -132,6 +130,8 @@ build() {
)
local _meson_options=(
+ -Dversion-tag="${pkgver}-${pkgrel}-arch"
+
-Daudit=true
-Dgnu-efi=true
-Dima=false
@@ -177,7 +177,7 @@ package_systemd-selinux() {
pkgdesc='system and service manager with SELinux support'
license=('GPL2' 'LGPL2.1')
depends=('acl' 'bash' 'cryptsetup' 'dbus' 'iptables' 'kbd' 'kmod' 'hwids' 'libcap'
- 'libgcrypt' 'libsystemd-selinux' 'libidn2' 'libidn2.so' 'lz4' 'pam-selinux' 'libelf'
+ 'libgcrypt' 'systemd-libs-selinux' 'libidn2' 'libidn2.so' 'lz4' 'pam-selinux' 'libelf'
'libseccomp' 'util-linux-selinux' 'xz' 'pcre2' 'audit')
provides=('nss-myhostname' "systemd-tools=$pkgver" "udev=$pkgver"
"${pkgname/-selinux}=${pkgver}-${pkgrel}")
@@ -210,9 +210,9 @@ package_systemd-selinux() {
# we'll create this on installation
rmdir "$pkgdir"/var/log/journal/remote
- # runtime libraries shipped with libsystemd
- install -d -m0755 libsystemd
- mv "$pkgdir"/usr/lib/lib{nss,systemd,udev}*.so* libsystemd
+ # runtime libraries shipped with systemd-libs
+ install -d -m0755 systemd-libs
+ mv "$pkgdir"/usr/lib/lib{nss,systemd,udev}*.so* systemd-libs
# manpages shipped with systemd-sysvcompat
rm "$pkgdir"/usr/share/man/man8/{halt,poweroff,reboot,runlevel,shutdown,telinit}.8
@@ -260,16 +260,18 @@ package_systemd-selinux() {
install -D -m0644 systemd-user.pam "$pkgdir"/etc/pam.d/systemd-user
}
-package_libsystemd-selinux() {
+package_systemd-libs-selinux() {
pkgdesc='systemd client libraries with SELinux support'
depends=('glibc' 'libcap' 'libgcrypt' 'lz4' 'xz' 'libselinux')
license=('LGPL2.1')
- provides=('libsystemd.so' 'libudev.so'
+ provides=('libsystemd' 'libsystemd.so' 'libudev.so'
+ 'libsystemd-selinux'
"${pkgname/-selinux}=${pkgver}-${pkgrel}")
conflicts=("${pkgname/-selinux}")
+ replaces=('libsystemd-selinux')
install -d -m0755 "$pkgdir"/usr
- mv libsystemd "$pkgdir"/usr/lib
+ mv systemd-libs "$pkgdir"/usr/lib
}
package_systemd-resolvconf-selinux() {