summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2015-10-02 21:12:35 +0200
committerNicolas Iooss2015-10-02 21:12:35 +0200
commitd2e26a54efcdcc5f9c60ae15796e3bf5395d7f98 (patch)
treedc2fb76155d14cc2356fdef13cca008424689426
parent77358db68eaf129f33c6cd075c9a434550debb18 (diff)
downloadaur-d2e26a54efcdcc5f9c60ae15796e3bf5395d7f98.tar.gz
systemd-selinux 226-3 update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44501dff49e0..ef0f9ca17a37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = systemd-selinux
pkgver = 226
- pkgrel = 1
+ pkgrel = 3
url = http://www.freedesktop.org/wiki/Software/systemd
arch = i686
arch = x86_64
@@ -76,7 +76,7 @@ pkgname = systemd-selinux
provides = nss-myhostname
provides = systemd-tools=226
provides = udev=226
- provides = systemd=226-1
+ provides = systemd=226-3
conflicts = nss-myhostname
conflicts = systemd-tools
conflicts = udev
@@ -120,15 +120,15 @@ pkgname = libsystemd-selinux
provides = libsystemd-journal.so
provides = libsystemd-login.so
provides = libudev.so
- provides = libsystemd=226-1
+ provides = libsystemd=226-3
conflicts = libsystemd
pkgname = systemd-sysvcompat-selinux
pkgdesc = sysvinit compat for systemd with SELinux support
license = GPL2
depends = systemd-selinux
- provides = systemd-sysvcompat=226-1
- provides = selinux-systemd-sysvcompat=226-1
+ provides = systemd-sysvcompat=226-3
+ provides = selinux-systemd-sysvcompat=226-3
conflicts = sysvinit
conflicts = systemd-sysvcompat
conflicts = selinux-systemd-sysvcompat
diff --git a/PKGBUILD b/PKGBUILD
index 6a997339cedb..d0eba4cc350b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=systemd-selinux
pkgname=('systemd-selinux' 'libsystemd-selinux' 'systemd-sysvcompat-selinux')
pkgver=226
-pkgrel=1
+pkgrel=3
arch=('i686' 'x86_64')
url="http://www.freedesktop.org/wiki/Software/systemd"
groups=('selinux')
@@ -139,17 +139,11 @@ package_systemd-selinux() {
# ship default policy to leave services disabled
echo 'disable *' >"$pkgdir"/usr/lib/systemd/system-preset/99-default.preset
- ### split out manpages for sysvcompat
- rm -rf "$srcdir/_sysvcompat"
- install -dm755 "$srcdir"/_sysvcompat/usr/share/man/man8/
- mv "$pkgdir"/usr/share/man/man8/{telinit,halt,reboot,poweroff,runlevel,shutdown}.8 \
- "$srcdir"/_sysvcompat/usr/share/man/man8
+ ### manpages shipped with systemd-sysvcompat
+ rm "$pkgdir"/usr/share/man/man8/{telinit,halt,reboot,poweroff,runlevel,shutdown}.8
- ### split off runtime libraries
- rm -rf "$srcdir/_libsystemd"
- install -dm755 "$srcdir"/_libsystemd/usr/lib
- cd "$srcdir"/_libsystemd
- mv "$pkgdir"/usr/lib/lib{systemd,udev}*.so* usr/lib
+ ### runtime libraries shipped with libsystemd
+ rm "$pkgdir"/usr/lib/lib{nss,systemd,udev}*.so*
# add example bootctl configuration
install -Dm644 "$srcdir/arch.conf" "$pkgdir"/usr/share/systemd/bootctl/arch.conf
@@ -166,7 +160,7 @@ package_libsystemd-selinux() {
"${pkgname/-selinux}=${pkgver}-${pkgrel}")
conflicts=("${pkgname/-selinux}")
- mv "$srcdir/_libsystemd"/* "$pkgdir"
+ make -C "${pkgbase/-selinux}" DESTDIR="$pkgdir" install-libLTLIBRARIES
}
package_systemd-sysvcompat-selinux() {
@@ -178,7 +172,10 @@ package_systemd-sysvcompat-selinux() {
"selinux-systemd-sysvcompat=${pkgver}-${pkgrel}")
replaces=("${pkgname/-selinux}")
- mv "$srcdir/_sysvcompat"/* "$pkgdir"
+ install -dm755 "$pkgdir"/usr/share/man/man8
+ cp -d --no-preserve=ownership,timestamp \
+ "${pkgbase/-selinux}"/man/{telinit,halt,reboot,poweroff,runlevel,shutdown}.8 \
+ "$pkgdir"/usr/share/man/man8
install -dm755 "$pkgdir/usr/bin"
for tool in runlevel reboot shutdown poweroff halt telinit; do