summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2015-06-29 21:03:12 +0800
committerNicolas Iooss2015-07-01 21:10:29 +0800
commitf87df71afeb1355f85ec83022e3c38c283cfff6b (patch)
tree36e40219d9cd7f23212e78ddcf69e4f9a5d6e5dd
parent3a48bb65a7b98e20cc0fe82f024fd2f6ff24ce6d (diff)
downloadaur-f87df71afeb1355f85ec83022e3c38c283cfff6b.tar.gz
systemd-selinux 221-2 update
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
-rw-r--r--initcpio-install-systemd11
3 files changed, 34 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffe798d64e30..35297c8cf982 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = systemd-selinux
pkgver = 221
- pkgrel = 1
+ pkgrel = 2
url = http://www.freedesktop.org/wiki/Software/systemd
arch = i686
arch = x86_64
@@ -8,6 +8,7 @@ pkgbase = systemd-selinux
makedepends = acl
makedepends = cryptsetup
makedepends = docbook-xsl
+ makedepends = gperf
makedepends = lz4
makedepends = xz
makedepends = pam-selinux
@@ -39,7 +40,7 @@ pkgbase = systemd-selinux
source = splash-arch.bmp::https://projects.archlinux.org/svntogit/packages.git/plain/trunk/splash-arch.bmp?h=packages/systemd&id=e43ddb71a5b1ab56e898347a63e54c5d5d07728a
md5sums = SKIP
md5sums = 90ea67a7bb237502094914622a39e281
- md5sums = 8516a7bd65157d0115c113118c10c3f3
+ md5sums = 976c5511b6493715e381f43f16cdb151
md5sums = bde43090d4ac0ef048e3eaee8202a407
md5sums = 20ead378f5d6df4b2a3e670301510a7d
md5sums = ddaef54f68f6c86c6c07835fc668f62a
@@ -78,7 +79,7 @@ pkgname = systemd-selinux
provides = nss-myhostname
provides = systemd-tools=221
provides = udev=221
- provides = systemd=221-1
+ provides = systemd=221-2
conflicts = nss-myhostname
conflicts = systemd-tools
conflicts = udev
@@ -123,15 +124,15 @@ pkgname = libsystemd-selinux
provides = libsystemd-journal.so
provides = libsystemd-login.so
provides = libudev.so
- provides = libsystemd=221-1
+ provides = libsystemd=221-2
conflicts = libsystemd
pkgname = systemd-sysvcompat-selinux
pkgdesc = sysvinit compat for systemd with SELinux support
license = GPL2
depends = systemd-selinux
- provides = systemd-sysvcompat=221-1
- provides = selinux-systemd-sysvcompat=221-1
+ provides = systemd-sysvcompat=221-2
+ provides = selinux-systemd-sysvcompat=221-2
conflicts = sysvinit
conflicts = systemd-sysvcompat
conflicts = selinux-systemd-sysvcompat
diff --git a/PKGBUILD b/PKGBUILD
index 8a85826b6ab2..4c7f1ec797e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@
pkgbase=systemd-selinux
pkgname=('systemd-selinux' 'libsystemd-selinux' 'systemd-sysvcompat-selinux')
pkgver=221
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="http://www.freedesktop.org/wiki/Software/systemd"
groups=('selinux')
-makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'lz4' 'xz' 'pam-selinux'
+makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam-selinux'
'intltool' 'iptables' 'kmod' 'libcap' 'libidn' 'libgcrypt'
'libmicrohttpd' 'libxslt' 'util-linux' 'linux-api-headers'
'python' 'python-lxml' 'quota-tools' 'shadow-selinux' 'gnu-efi-libs' 'git'
@@ -28,7 +28,7 @@ source=("git://github.com/systemd/systemd.git#tag=v$pkgver"
'splash-arch.bmp::https://projects.archlinux.org/svntogit/packages.git/plain/trunk/splash-arch.bmp?h=packages/systemd&id=e43ddb71a5b1ab56e898347a63e54c5d5d07728a')
md5sums=('SKIP'
'90ea67a7bb237502094914622a39e281'
- '8516a7bd65157d0115c113118c10c3f3'
+ '976c5511b6493715e381f43f16cdb151'
'bde43090d4ac0ef048e3eaee8202a407'
'20ead378f5d6df4b2a3e670301510a7d'
'ddaef54f68f6c86c6c07835fc668f62a'
@@ -37,7 +37,25 @@ md5sums=('SKIP'
prepare() {
cd "${pkgname/-selinux}"
- # 'git cherry-pick -n' upstream fixes here
+ # pam_systemd: Properly check kdbus availability
+ # https://github.com/systemd/systemd/commit/c5d452bb228e
+ git cherry-pick -n c5d452bb228e
+
+ # udevd: suppress warning if we don't find cgroup
+ # https://github.com/systemd/systemd/commit/11b9fb15be96
+ git cherry-pick -n 11b9fb15be96
+
+ # core: fix reversed dependency check in unit_check_unneeded
+ # https://github.com/systemd/systemd/commit/084918ba41ac
+ git cherry-pick -n 084918ba41ac
+
+ # rules: remove all power management from udev
+ # https://github.com/systemd/systemd/commit/e2452eef02a8
+ git cherry-pick -n e2452eef02a8
+
+ # logind: fix delayed execution regression
+ # https://github.com/systemd/systemd/commit/418b22b88f79
+ git cherry-pick -n 418b22b88f79
./autogen.sh
}
diff --git a/initcpio-install-systemd b/initcpio-install-systemd
index acd8a226d161..96df98ada271 100644
--- a/initcpio-install-systemd
+++ b/initcpio-install-systemd
@@ -102,14 +102,13 @@ build() {
add_binary /usr/lib/systemd/systemd /init
map add_binary \
+ /usr/bin/systemd-tmpfiles \
/usr/lib/systemd/systemd-hibernate-resume \
- /usr/lib/systemd/system-generators/systemd-hibernate-resume-generator \
- /usr/bin/systemd-tmpfiles
-
- # generators
- map add_file \
/usr/lib/systemd/system-generators/systemd-fstab-generator \
- /usr/lib/systemd/system-generators/systemd-gpt-auto-generator
+ /usr/lib/systemd/system-generators/systemd-gpt-auto-generator \
+ /usr/lib/systemd/system-generators/systemd-hibernate-resume-generator
+
+ add_module "kdbus?"
# udev rules and systemd units
map add_udev_rule "$rules" \