summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas DOREL2019-12-31 18:40:48 +0100
committerJonas DOREL2019-12-31 18:40:48 +0100
commit0959c08a0b60dca9b963c632300517c9c7f6925d (patch)
treec21760ba24fd4dd56400f5a4fbf19d5c5ff0c654
downloadaur-0959c08a0b60dca9b963c632300517c9c7f6925d.tar.gz
Initial PKGBUILD
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9eab0cfc98a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = systemd-service-pacman-download-updates-git
+ pkgdesc = Systemd service to download packages updates
+ pkgver = latest
+ pkgrel = 1
+ url = https://gitlab.com/jdorel-archlinux/systemd-pacman-download-updates
+ arch = any
+ license = GPL
+ makedepends = git
+ source = systemd-service-pacman-download-updates-git::git+https://gitlab.com/jdorel-archlinux/systemd-pacman-download-updates
+ md5sums = SKIP
+
+pkgname = systemd-service-pacman-download-updates-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1906b555f89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jonas DOREL <jonas at dorel dot me>
+pkgname=systemd-service-pacman-download-updates-git
+pkgver=latest
+pkgrel=1
+pkgdesc="Systemd service to download packages updates"
+arch=('any')
+url="https://gitlab.com/jdorel-archlinux/systemd-pacman-download-updates"
+license=('GPL')
+makedepends=('git')
+source=("${pkgname}::git+https://gitlab.com/jdorel-archlinux/systemd-pacman-download-updates")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ #printf "latest"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm 644 pacman-download-updates.service "$pkgdir/usr/lib/systemd/system/pacman-download-updates.service"
+}