summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFunami2022-09-17 00:11:02 +0200
committerFunami2022-09-17 00:11:02 +0200
commit42b844ef21eb7b757e4f7f95cafe9d60cde51d0c (patch)
tree60f59cd64f32be924e13441b565671a2322728de
downloadaur-42b844ef21eb7b757e4f7f95cafe9d60cde51d0c.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..215df72752a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = systemd-stub-x64
+ pkgdesc = A simple UEFI kernel boot stub
+ pkgver = 251.4
+ pkgrel = 1
+ url = https://www.github.com/systemd/systemd
+ arch = x86_64
+ license = GPL2
+ license = LGPL2.1
+ provides = systemd-stub
+ conflicts = systemd-stub
+ source = https://archive.archlinux.org/packages/s/systemd/systemd-251.4-1-x86_64.pkg.tar.zst
+ sha256sums = aa439ec93a6b7094a50d0cb128c0659ec303539dc3eda4aa51c8bb24a20d499d
+
+pkgname = systemd-stub-x64
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de4f9e979fda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Funami
+pkgname=systemd-stub-x64
+pkgver=251.4
+pkgrel=1
+pkgdesc="A simple UEFI kernel boot stub"
+arch=('x86_64')
+url="https://www.github.com/systemd/systemd"
+license=('GPL2' 'LGPL2.1')
+provides=('systemd-stub')
+conflicts=('systemd-stub')
+source=("https://archive.archlinux.org/packages/s/systemd/systemd-${pkgver}-1-x86_64.pkg.tar.zst")
+sha256sums=('aa439ec93a6b7094a50d0cb128c0659ec303539dc3eda4aa51c8bb24a20d499d')
+
+package() {
+ install -Dm755 "${srcdir}/usr/lib/systemd/boot/efi/linuxx64.efi.stub" -t "${pkgdir}/usr/lib/systemd/boot/efi/"
+}