summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Nicoulaud2019-02-14 15:38:34 +0100
committerJulien Nicoulaud2019-02-14 15:38:34 +0100
commit279524f2d1d16c320d4f541da7c66ce903753c56 (patch)
tree34a299ec95fd1e4eaa376b52c1b20f3ec0f7e745
downloadaur-279524f2d1d16c320d4f541da7c66ce903753c56.tar.gz
1.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD18
-rw-r--r--systemd.sudoers3
4 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9d359a6e4ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = systemd-sudo-variables
+ pkgdesc = Rules for propagating SYSTEMD and LESS environment variables with sudo.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://aur.archlinux.org/packages/systemd-sudo-variables
+ arch = any
+ license = custom:Public Domain
+ depends = sudo
+ source = systemd.sudoers
+ sha256sums = 2e4e2a6ac15320c86056128c62f9d2e7f22cc8f57f6d6c589d2adb0d914f6231
+
+pkgname = systemd-sudo-variables
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8eab14e54627
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/pkg/
+/src/
+/*.tar.gz
+/*.xz
+/*.zst
+/*.swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ceda6423c97a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Julien Nicoulaud <julien dot nicoulaud at gmail dot com>
+
+pkgname=systemd-sudo-variables
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Rules for propagating SYSTEMD and LESS environment variables with sudo.'
+arch=('any')
+url='https://aur.archlinux.org/packages/systemd-sudo-variables'
+license=('custom:Public Domain')
+depends=('sudo')
+source=(systemd.sudoers)
+sha256sums=('2e4e2a6ac15320c86056128c62f9d2e7f22cc8f57f6d6c589d2adb0d914f6231')
+
+package() {
+ install -dm750 "$pkgdir/etc/sudoers.d"
+ install -m400 systemd.sudoers "$pkgdir/etc/sudoers.d/systemd"
+}
+
diff --git a/systemd.sudoers b/systemd.sudoers
new file mode 100644
index 000000000000..e7f8370f6d12
--- /dev/null
+++ b/systemd.sudoers
@@ -0,0 +1,3 @@
+# from https://aur.archlinux.org/packages/systemd-sudo-variables
+Defaults env_keep += "SYSTEMD_EDITOR SYSTEMD_PAGER SYSTEMD_LESS SYSTEMD_LESSCHARSET LESS_TERMCAP_mb LESS_TERMCAP_md LESS_TERMCAP_me LESS_TERMCAP_so LESS_TERMCAP_se LESS_TERMCAP_us LESS_TERMCAP_ue LESS_TERMCAP_mr LESS_TERMCAP_mh"
+