summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Hebb2014-03-02 10:05:33 -0500
committerThomas Hebb2014-03-02 10:05:33 -0500
commit9d0808904024a4243b9fc421bcca76ca5c678482 (patch)
treeeaa56befd4ebc9ca67492c34fb24a318f0bcf7bb
downloadaur-9d0808904024a4243b9fc421bcca76ca5c678482.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD37
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f23a2d62fd3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = systemd-user-session-units-git
+ pkgdesc = A collection of units for the systemd user session.
+ pkgver = 58
+ pkgrel = 1
+ url = https://github.com/sofar/user-session-units
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = dbus
+ depends = systemd-xorg-launch-helper-git
+ provides = user-session-units
+ conflicts = user-session-units
+ source = user-session-units::git+https://github.com/sofar/user-session-units.git
+ sha256sums = SKIP
+
+pkgname = systemd-user-session-units-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..a20129a3d360
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Alucryd <alucryd at gmail dot com>
+
+pkgname=systemd-user-session-units-git
+pkgver=58
+pkgrel=1
+pkgdesc="A collection of units for the systemd user session."
+arch=('any')
+url="https://github.com/sofar/user-session-units"
+license=('GPL3')
+depends=('dbus' 'systemd-xorg-launch-helper-git')
+makedepends=('git')
+provides=('user-session-units')
+conflicts=('user-session-units')
+source=('user-session-units::git+https://github.com/sofar/user-session-units.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}"/user-session-units
+
+ git rev-list --count HEAD
+}
+
+build () {
+ cd "${srcdir}"/user-session-units
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}"/user-session-units
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: