summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThatOneCalculator2024-02-02 18:10:36 -0800
committerThatOneCalculator2024-02-02 18:10:36 -0800
commit63489388bdda243d60a4cbe0dca05af7c5d22884 (patch)
tree927102b1214e521fb1a346d8b63a6e5e348129c4
parent26364e448a8a16d97083a20bd6bce5c349b5dcf0 (diff)
downloadaur-63489388bdda243d60a4cbe0dca05af7c5d22884.tar.gz
fix service
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56e1506adeb8..86ef156d6dc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = systemd-yodad
pkgdesc = Plays the yoda death sound effect randomly
- pkgver = 2.0.0
- pkgrel = 2
+ pkgver = 2.1.0
+ pkgrel = 1
url = https://github.com/thatonecalculator/systemd-yodad
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index ada875c1de43..397fb4067a1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: ThatOneCalculator <kainoa@t1c.dev>
pkgname="systemd-yodad"
-pkgver=2.0.0
-pkgrel=2
+pkgver=2.1.0
+pkgrel=1
pkgdesc="Plays the yoda death sound effect randomly"
arch=(any)
url="https://github.com/thatonecalculator/systemd-yodad"
@@ -19,8 +19,15 @@ package() {
cd "${srcdir}/${pkgname}"
install -Dm755 yoda -t "${pkgdir}/usr/bin"
mkdir -p "${pkgdir}/usr/share/yoda"
- install -Dm644 yodad.service "${pkgdir}/usr/lib/systemd/system/yodad.service"
- install -Dm644 yoda.mp3 -t "${pkgdir}/usr/share/yoda/"
+ install -Dm644 yodad.service "${pkgdir}/usr/lib/systemd/user/yodad.service"
+ install -Dm644 yoda.mp3 -t "${pkgdir}/usr/share/yoda/"
install -Dm644 yoda_longer.mp3 -t "${pkgdir}/usr/share/yoda/"
- echo "pretty please systemctl enable --now yodad.service"
+}
+
+post_install() {
+ echo "Pretty please systemctl --user enable --now yodad.service"
+}
+
+post_upgrade() {
+ post_install
}