summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThatOneCalculator2024-02-01 18:06:49 -0800
committerThatOneCalculator2024-02-01 18:06:49 -0800
commita9f600101552757895185e6b74ec8a79f2ee2f2c (patch)
treeefafc97711a28348e25d5219ad2fc79cd8042087
downloadaur-a9f600101552757895185e6b74ec8a79f2ee2f2c.tar.gz
gay
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03d9f4982058
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = systemd-yodad
+ pkgdesc = Waaaaaaargu
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/thatonecalculator/systemd-yodad
+ arch = any
+ license = MIT
+ depends = systemd
+ depends = mpg123
+ options = !makeflags
+ options = !buildflags
+ options = !strip
+ source = systemd-yodad::git+https://github.com/thatonecalculator/systemd-yodad.git
+ sha256sums = SKIP
+
+pkgname = systemd-yodad
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0a5ad1489cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: ThatOneCalculator <kainoa@t1c.dev>
+
+pkgname="systemd-yodad"
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Waaaaaaargu"
+arch=(any)
+url="https://github.com/thatonecalculator/systemd-yodad"
+license=('MIT')
+depends=(
+ systemd
+ mpg123
+)
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+options=(!makeflags !buildflags !strip)
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -Dm755 yoda -t "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/yoda"
+ install -Dm644 yodad.service "$pkgdir/usr/lib/systemd/system/yodad.service"
+ install -Dm644 yoda.mp3 -t "${pkgdir}/usr/share/yoda/${_pkgname}"
+ echo "pretty please systemctl enable --now yodad.service"
+}