summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCan Celasun2015-06-08 13:34:47 +0300
committerCan Celasun2015-06-08 13:34:47 +0300
commit70aed34c8a714d74ee3a19b2c71b6befe62a007e (patch)
tree8108d865ab9c87d8d7df55ded924b019df235cc2
downloadaur-70aed34c8a714d74ee3a19b2c71b6befe62a007e.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD40
-rw-r--r--systems-nominal.desktop8
-rw-r--r--systems-nominal.pngbin0 -> 85056 bytes
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a96f5064ea2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = systems-nominal
+ pkgdesc = An experimental game by Nerd^3
+ pkgver = 1.0
+ pkgrel = 2
+ url = http://www.nerdcubed.co.uk/games/
+ arch = i686
+ arch = x86_64
+ license = custom: commercial
+ depends = libgl
+ depends = gconf
+ depends = cairo
+ depends = fontconfig
+ depends = gtk2
+ depends = nss
+ depends = libxtst
+ depends = gcc-libs
+ depends = alsa-lib
+ depends = libudev.so.0
+ source = http://assets.nerdcubed.co.uk/systems_nominal_1.0_linux.7z
+ source = systems-nominal.desktop
+ source = systems-nominal.png
+ md5sums = 688f9172036bb86ee372bd7fbfd254f5
+ md5sums = ab6dfe6c1ce9f311aace15c5a6855c75
+ md5sums = db0da9f5e3708f8f5fd7a14678c07fd5
+
+pkgname = systems-nominal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b444be21050e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: D. Can Celasun <dcelasun[at]gmail[dot]com>
+
+pkgname=systems-nominal
+pkgver=1.0
+pkgrel=2
+pkgdesc="An experimental game by Nerd^3"
+arch=('i686' 'x86_64')
+url="http://www.nerdcubed.co.uk/games/"
+license=('custom: commercial')
+depends=('libgl' 'gconf' 'cairo' 'fontconfig' 'gtk2' 'nss' 'libxtst' 'gcc-libs' 'alsa-lib' 'libudev.so.0')
+md5sums=('688f9172036bb86ee372bd7fbfd254f5'
+ 'ab6dfe6c1ce9f311aace15c5a6855c75'
+ 'db0da9f5e3708f8f5fd7a14678c07fd5')
+PKGEXT=.pkg.tar
+source=(http://assets.nerdcubed.co.uk/systems_nominal_${pkgver}_linux.7z
+ ${pkgname}.desktop
+ ${pkgname}.png)
+
+_game_path=systems_nominal_${pkgver}_linux
+
+if test "$CARCH" == i686; then
+ __arch=linux32
+elif test "$CARCH" == x86_64; then
+ __arch=linux64
+fi
+
+package() {
+ cd "${srcdir}"
+
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/share/icons"
+ install -d "${pkgdir}/usr/share/${pkgname}"
+
+ cp -r ${__arch}/* "${pkgdir}"/usr/share/${pkgname}
+ install -m644 "${srcdir}"/${pkgname}.desktop "${pkgdir}"/usr/share/applications/${pkgname}.desktop
+ install -m644 "${srcdir}"/${pkgname}.png "${pkgdir}"/usr/share/icons/
+
+ ln -s /usr/share/${pkgname}/systemsnominal "${pkgdir}"/usr/bin/${pkgname}
+}
diff --git a/systems-nominal.desktop b/systems-nominal.desktop
new file mode 100644
index 000000000000..cabc5e48ba98
--- /dev/null
+++ b/systems-nominal.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Categories=Game;
+Exec=/usr/bin/systems-nominal
+Icon=systems-nominal
+Terminal=false
+Type=Application
+Name=Systems Nominal
+Comment=An experimental game by Nerd^3
diff --git a/systems-nominal.png b/systems-nominal.png
new file mode 100644
index 000000000000..66b21a6c2157
--- /dev/null
+++ b/systems-nominal.png
Binary files differ