summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Squartini2015-07-21 09:43:57 +0900
committerNicola Squartini2015-07-21 09:43:57 +0900
commit887de7591d9a3d1a80470df2df73a5cd41998c01 (patch)
treec7de63041166a70a793807c75af5c69444a2fad6
downloadaur-887de7591d9a3d1a80470df2df73a5cd41998c01.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--99-systemsim-cell.rules2
-rw-r--r--PKGBUILD33
-rw-r--r--systemsim-cell.sh1
4 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70e2678050b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = systemsim-cell
+ pkgdesc = IBM Full-System Simulator for the Cell Broadband Engine Processor
+ pkgver = 3.1
+ pkgrel = 1
+ url = http://www.ibm.com/
+ arch = x86_64
+ groups = Cell Simulator
+ license = IBM Licensed Materials
+ makedepends = rpmextract
+ depends = gcc-libs
+ depends = perl
+ depends = tk
+ noextract = systemsim-cell-3.1-25.f9.x86_64.rpm
+ options = !strip
+ source = http://git.gitbrew.org/openclit/packages/CELL_EMULATOR/systemsim-cell-3.1-25.f9.x86_64.rpm
+ source = 99-systemsim-cell.rules
+ source = systemsim-cell.sh
+ md5sums = 4b069cebf26bd16cec8e768d2c68e830
+ md5sums = e470b6ef7d042cfe4ade6180b5c45cb8
+ md5sums = bf46bc7b66e0aa4f3c8894a49bdbade8
+
+pkgname = systemsim-cell
+
diff --git a/99-systemsim-cell.rules b/99-systemsim-cell.rules
new file mode 100644
index 000000000000..039b47625584
--- /dev/null
+++ b/99-systemsim-cell.rules
@@ -0,0 +1,2 @@
+# Custom permissions for tun/tap for use with systemsim
+KERNEL=="tun", MODE="0666"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47be6b4434ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Nicola Squartini <tensor5@gmail.com>
+pkgname=systemsim-cell
+pkgver=3.1
+pkgrel=1
+pkgdesc="IBM Full-System Simulator for the Cell Broadband Engine Processor"
+arch=(x86_64)
+url="http://www.ibm.com/"
+license="IBM Licensed Materials"
+groups=('Cell Simulator')
+depends=(gcc-libs perl tk)
+makedepends=(rpmextract)
+options=(!strip)
+source=(http://git.gitbrew.org/openclit/packages/CELL_EMULATOR/systemsim-cell-3.1-25.f9.x86_64.rpm
+ 99-systemsim-cell.rules
+ systemsim-cell.sh)
+noextract=(systemsim-cell-3.1-25.f9.x86_64.rpm)
+md5sums=('4b069cebf26bd16cec8e768d2c68e830'
+ 'e470b6ef7d042cfe4ade6180b5c45cb8'
+ 'bf46bc7b66e0aa4f3c8894a49bdbade8')
+
+package() {
+ mkdir -p "${pkgdir}"
+ cd "${pkgdir}"
+ rpmextract.sh "${srcdir}/systemsim-cell-3.1-25.f9.x86_64.rpm"
+
+ chmod 4755 "${pkgdir}/opt/ibm/systemsim-cell/bin/snif"
+
+ mkdir -p "${pkgdir}/usr/lib/udev/rules.d"
+ cp "${srcdir}/99-systemsim-cell.rules" "${pkgdir}/usr/lib/udev/rules.d"
+
+ mkdir -p "${pkgdir}/etc/profile.d"
+ cp "${srcdir}/systemsim-cell.sh" "${pkgdir}/etc/profile.d"
+}
diff --git a/systemsim-cell.sh b/systemsim-cell.sh
new file mode 100644
index 000000000000..4b319c6acfde
--- /dev/null
+++ b/systemsim-cell.sh
@@ -0,0 +1 @@
+export PATH="${PATH}:/opt/ibm/systemsim-cell/bin"