summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Angelopoulos2018-06-03 19:06:43 +0200
committerGeorge Angelopoulos2018-06-03 19:06:43 +0200
commit0512430e396ae40b3289c43ee75b86910fd4b050 (patch)
tree335a3882c6a7c72e464dd58e61d6cb244bb8195d
parenta2db70026d5b044f8110c7b39591cca716ba536a (diff)
downloadaur-0512430e396ae40b3289c43ee75b86910fd4b050.tar.gz
backport timer fix for >=4.15 kernels
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--fix-timers-for-4.15-kernel.patch243
3 files changed, 255 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5151c684e90..3ef0e3658e7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jun 3 14:33:59 UTC 2018
+# Sun Jun 3 17:06:32 UTC 2018
pkgbase = systemtap
pkgdesc = provides infrastructure to simplify the gathering of information about the running system.
pkgver = 3.2
- pkgrel = 3
+ pkgrel = 4
url = http://sourceware.org/systemtap/
install = systemtap.install
arch = x86_64
@@ -19,10 +19,12 @@ pkgbase = systemtap
source = systemtap-3.2.tar.gz.asc::https://sourceware.org/systemtap/ftp/releases/systemtap-3.2.tar.gz.asc
source = stp_remove_install_hooks.patch
source = fixes-for-gcc-8.patch
+ source = fix-timers-for-4.15-kernel.patch
sha512sums = 6036ed1b5189fd3fcfdeeaa526a3539ac632d0b687a063b5e3424e8f613bfc2c8d079742b0262b547128e97e30e4beb61898b23761657aee519e61346ac92e94
sha512sums = SKIP
sha512sums = 1d2758e9f875e06d08d37679587454fb43e025aa83ceeb405b1bc8d3277476502f2d67cf9e8383cc4c63ae545d7d0e9ebaab814f880b2f53bba47bef4afcd537
sha512sums = 970d83ace43909e5a1bfc4112d78dd913af6d59e4b8dc8c4461370b022092b0cdb6830427b52bcf5b7409ff6d7c79dab778e53398ba65de71bd4a270c66a2d3a
+ sha512sums = 3cbf261cf34df23454e0a9aa4566664241b8bcf4b44a28617cce483d0f24632b9fcd4ac8b37f488e736d0ce02308fb67e7b4dd52f6349a9010e2390d8c94190d
pkgname = systemtap
diff --git a/PKGBUILD b/PKGBUILD
index 77ca142a9fc2..5af45230ec79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor:dront78 <dront78@gmail.com>
pkgname=systemtap
pkgver=3.2
-pkgrel=3
+pkgrel=4
pkgdesc="provides infrastructure to simplify the gathering of information about the running system."
url="http://sourceware.org/systemtap/"
arch=('x86_64' 'i686')
@@ -13,11 +13,15 @@ optdepends=('sqlite3: for storing results in a database')
source=("${pkgname}-${pkgver}.tar.gz::https://sourceware.org/systemtap/ftp/releases/${pkgname}-${pkgver}.tar.gz"
"${pkgname}-${pkgver}.tar.gz.asc::https://sourceware.org/systemtap/ftp/releases/${pkgname}-${pkgver}.tar.gz.asc"
'stp_remove_install_hooks.patch'
- 'fixes-for-gcc-8.patch')
+ 'fixes-for-gcc-8.patch'
+ 'fix-timers-for-4.15-kernel.patch'
+ )
sha512sums=('6036ed1b5189fd3fcfdeeaa526a3539ac632d0b687a063b5e3424e8f613bfc2c8d079742b0262b547128e97e30e4beb61898b23761657aee519e61346ac92e94'
'SKIP'
'1d2758e9f875e06d08d37679587454fb43e025aa83ceeb405b1bc8d3277476502f2d67cf9e8383cc4c63ae545d7d0e9ebaab814f880b2f53bba47bef4afcd537'
- '970d83ace43909e5a1bfc4112d78dd913af6d59e4b8dc8c4461370b022092b0cdb6830427b52bcf5b7409ff6d7c79dab778e53398ba65de71bd4a270c66a2d3a')
+ '970d83ace43909e5a1bfc4112d78dd913af6d59e4b8dc8c4461370b022092b0cdb6830427b52bcf5b7409ff6d7c79dab778e53398ba65de71bd4a270c66a2d3a'
+ '3cbf261cf34df23454e0a9aa4566664241b8bcf4b44a28617cce483d0f24632b9fcd4ac8b37f488e736d0ce02308fb67e7b4dd52f6349a9010e2390d8c94190d'
+ )
install='systemtap.install'
validpgpkeys=('5D38116FA4D3A7CC77E378D37E83610126DCC2E8')
@@ -25,6 +29,7 @@ prepare() {
cd "${pkgname}-${pkgver}"
patch -Np1 -i "${srcdir}/stp_remove_install_hooks.patch"
patch -Np1 -i "${srcdir}/fixes-for-gcc-8.patch"
+ patch -Np1 -i "${srcdir}/fix-timers-for-4.15-kernel.patch"
autoreconf -i
}
build() {
diff --git a/fix-timers-for-4.15-kernel.patch b/fix-timers-for-4.15-kernel.patch
new file mode 100644
index 000000000000..3ca7c401e4ca
--- /dev/null
+++ b/fix-timers-for-4.15-kernel.patch
@@ -0,0 +1,243 @@
+diff --git a/runtime/linux/runtime.h b/runtime/linux/runtime.h
+index 9c585a20d..df9b74c5c 100644
+--- a/runtime/linux/runtime.h
++++ b/runtime/linux/runtime.h
+@@ -34,7 +34,7 @@
+ #include <linux/compat.h>
+ #include <linux/sched.h>
+ #include <linux/mm.h>
+-#include <linux/timer.h>
++#include "timer_compatibility.h"
+ #include <linux/delay.h>
+ #include <linux/profile.h>
+ #include <linux/rcupdate.h>
+diff --git a/runtime/linux/timer_compatibility.h b/runtime/linux/timer_compatibility.h
+new file mode 100644
+index 000000000..ac03de998
+--- /dev/null
++++ b/runtime/linux/timer_compatibility.h
+@@ -0,0 +1,76 @@
++/*
++ * linux/timer.h compatibility defines and inlines
++ * Copyright (C) 2017 Red Hat Inc.
++ *
++ * This file is part of systemtap, and is free software. You can
++ * redistribute it and/or modify it under the terms of the GNU General
++ * Public License (GPL); either version 2, or (at your option) any
++ * later version.
++ */
++
++#ifndef _TIMER_COMPATIBILITY_H_
++#define _TIMER_COMPATIBILITY_H_
++
++#include <linux/timer.h>
++
++/*
++ * Starting with the 4.15 kernel, the timer interface
++ * changed. Originally, you'd do something like:
++ *
++ * static void timer_func(unsigned long val);
++ *
++ * init_timer(&timer);
++ * timer.expires = jiffies + STP_RELAY_TIMER_INTERVAL;
++ * timer.function = timer_func;
++ * timer.data = 0;
++ * add_timer(&timer);
++ *
++ * The 'data' parameter would get passed to the callback
++ * function. Starting with 4.15, you'd do something like this:
++ *
++ * static void timer_func(struct timer_list *val);
++ *
++ * timer_setup(&timer, timer_func, 0);
++ * timer.expires = jiffies + STP_RELAY_TIMER_INTERVAL;
++ * add_timer(&timer);
++ *
++ * With the new code, the timer that caused the callback gets passed
++ * to the timer callback function. The 'data' field has been removed.
++ *
++ * So, we're going to use the new interface. To hide the differences
++ * between the callback function parameter type, we'll define a new
++ * type, 'stp_timer_callback_parameter_t'.
++ *
++ * If code needs to figure out the difference between the old and new
++ * interface, it should test the TIMER_TRACE_FLAGMASK define (which
++ * only exists in the new interface).
++ */
++
++#if defined(TIMER_TRACE_FLAGMASK)
++/* This is the >= 4.15 kernel interface. */
++
++typedef struct timer_list * stp_timer_callback_parameter_t;
++
++#else
++/* This is the < 4.15 kernel interface. */
++
++typedef unsigned long stp_timer_callback_parameter_t;
++
++/**
++ * timer_setup - prepare a timer for first use
++ * @timer: the timer in question
++ * @callback: the function to call when timer expires
++ * @flags: any TIMER_* flags (note that anything other than 0 is an
++ * error, since this compatibility function can't support any
++ * of the TIMER_* flags)
++ */
++#define timer_setup(timer, callback, flags) \
++ { \
++ init_timer((timer)); \
++ (timer)->function = callback; \
++ (timer)->data = 0; \
++ BUILD_BUG_ON_ZERO((flags) != 0); \
++ }
++#endif
++
++#endif /* _TIMER_COMPATIBILITY_H_ */
+diff --git a/runtime/time.c b/runtime/time.c
+index 2e666d54c..91ceafa6a 100644
+--- a/runtime/time.c
++++ b/runtime/time.c
+@@ -168,10 +168,10 @@ __stp_time_smp_callback(void *val)
+
+ /* The timer callback is in a softIRQ -- interrupts enabled. */
+ static void
+-__stp_time_timer_callback(unsigned long val)
++__stp_time_timer_callback(stp_timer_callback_parameter_t unused)
+ {
+ stp_time_t *time =__stp_time_local_update();
+- (void) val;
++ (void) unused;
+
+ /* PR6481: make sure IRQs are enabled before resetting the timer
+ (IRQs are disabled and then reenabled in
+@@ -200,9 +200,8 @@ __stp_init_time(void *info)
+ time->freq = __stp_get_freq();
+ __stp_time_local_update();
+
+- init_timer(&time->timer);
++ timer_setup(&time->timer, __stp_time_timer_callback, 0);
+ time->timer.expires = jiffies + STP_TIME_SYNC_INTERVAL;
+- time->timer.function = __stp_time_timer_callback;
+
+ #ifndef STAPCONF_ADD_TIMER_ON
+ add_timer(&time->timer);
+diff --git a/runtime/transport/relay_v2.c b/runtime/transport/relay_v2.c
+index f81d75dfa..135951a8e 100644
+--- a/runtime/transport/relay_v2.c
++++ b/runtime/transport/relay_v2.c
+@@ -30,7 +30,7 @@
+ #include <linux/debugfs.h>
+ #include <linux/mm.h>
+ #include <linux/relay.h>
+-#include <linux/timer.h>
++#include "../linux/timer_compatibility.h"
+ #include "../uidgid_compatibility.h"
+ #include "relay_compat.h"
+
+@@ -120,7 +120,7 @@ static void __stp_relay_wakeup_readers(struct rchan_buf *buf)
+ wake_up_interruptible(&buf->read_wait);
+ }
+
+-static void __stp_relay_wakeup_timer(unsigned long val)
++static void __stp_relay_wakeup_timer(stp_timer_callback_parameter_t unused)
+ {
+ #ifdef STP_BULKMODE
+ int i;
+@@ -151,10 +151,8 @@ static void __stp_relay_wakeup_timer(unsigned long val)
+ static void __stp_relay_timer_init(void)
+ {
+ atomic_set(&_stp_relay_data.wakeup, 0);
+- init_timer(&_stp_relay_data.timer);
++ timer_setup(&_stp_relay_data.timer, __stp_relay_wakeup_timer, 0);
+ _stp_relay_data.timer.expires = jiffies + STP_RELAY_TIMER_INTERVAL;
+- _stp_relay_data.timer.function = __stp_relay_wakeup_timer;
+- _stp_relay_data.timer.data = 0;
+ add_timer(&_stp_relay_data.timer);
+ smp_mb();
+ }
+diff --git a/runtime/transport/transport.c b/runtime/transport/transport.c
+index 3400f220a..320fd187e 100644
+--- a/runtime/transport/transport.c
++++ b/runtime/transport/transport.c
+@@ -311,7 +311,7 @@ static void _stp_detach(void)
+ }
+
+
+-static void _stp_ctl_work_callback(unsigned long val);
++static void _stp_ctl_work_callback(stp_timer_callback_parameter_t unused);
+
+ /*
+ * Called when stapio opens the control channel.
+@@ -320,13 +320,12 @@ static void _stp_attach(void)
+ {
+ dbug_trans(1, "attach\n");
+ _stp_pid = current->pid;
+- if (_stp_namespaces_pid < 1)
+- _stp_namespaces_pid = _stp_pid;
++ if (_stp_namespaces_pid < 1)
++ _stp_namespaces_pid = _stp_pid;
+ _stp_transport_data_fs_overwrite(0);
+- init_timer(&_stp_ctl_work_timer);
++
++ timer_setup(&_stp_ctl_work_timer, _stp_ctl_work_callback, 0);
+ _stp_ctl_work_timer.expires = jiffies + STP_CTL_TIMER_INTERVAL;
+- _stp_ctl_work_timer.function = _stp_ctl_work_callback;
+- _stp_ctl_work_timer.data= 0;
+ add_timer(&_stp_ctl_work_timer);
+ }
+
+@@ -341,7 +340,7 @@ static void _stp_attach(void)
+ * notified. Reschedules itself if someone is still attached
+ * to the cmd channel.
+ */
+-static void _stp_ctl_work_callback(unsigned long val)
++static void _stp_ctl_work_callback(stp_timer_callback_parameter_t unused)
+ {
+ int do_io = 0;
+ unsigned long flags;
+diff --git a/tapset-timers.cxx b/tapset-timers.cxx
+index 1a40bcda0..0ab4d69cd 100644
+--- a/tapset-timers.cxx
++++ b/tapset-timers.cxx
+@@ -122,9 +122,13 @@ timer_derived_probe_group::emit_module_decls (systemtap_session& s)
+ s.op->newline(-1) << "};";
+ s.op->newline();
+
+- s.op->newline() << "static void enter_timer_probe (unsigned long val) {";
++ s.op->newline() << "static void enter_timer_probe (stp_timer_callback_parameter_t val) {";
++ s.op->newline() << "#if defined(TIMER_TRACE_FLAGMASK)";
++ s.op->newline(1) << "struct stap_timer_probe* stp = container_of(val, struct stap_timer_probe, timer_list);";
++ s.op->newline(-1) << "#else";
+ s.op->newline(1) << "struct stap_timer_probe* stp = & stap_timer_probes [val];";
+- s.op->newline() << "if ((atomic_read (session_state()) == STAP_SESSION_STARTING) ||";
++ s.op->newline(-1) << "#endif";
++ s.op->newline(1) << "if ((atomic_read (session_state()) == STAP_SESSION_STARTING) ||";
+ s.op->newline() << " (atomic_read (session_state()) == STAP_SESSION_RUNNING))";
+ s.op->newline(1) << "mod_timer (& stp->timer_list, jiffies + ";
+ emit_interval (s.op);
+@@ -148,9 +152,11 @@ timer_derived_probe_group::emit_module_init (systemtap_session& s)
+ s.op->newline() << "for (i=0; i<" << probes.size() << "; i++) {";
+ s.op->newline(1) << "struct stap_timer_probe* stp = & stap_timer_probes [i];";
+ s.op->newline() << "probe_point = stp->probe->pp;";
+- s.op->newline() << "init_timer (& stp->timer_list);";
+- s.op->newline() << "stp->timer_list.function = & enter_timer_probe;";
++
++ s.op->newline() << "timer_setup (& stp->timer_list, enter_timer_probe, 0);";
++ s.op->newline() << "#if !defined(TIMER_TRACE_FLAGMASK)";
+ s.op->newline() << "stp->timer_list.data = i;"; // NB: important!
++ s.op->newline() << "#endif";
+ // copy timer renew calculations from above :-(
+ s.op->newline() << "stp->timer_list.expires = jiffies + ";
+ emit_interval (s.op);
+diff --git a/tapset/linux/scsi.stp b/tapset/linux/scsi.stp
+index 44f686c2a..35779421b 100644
+--- a/tapset/linux/scsi.stp
++++ b/tapset/linux/scsi.stp
+@@ -14,7 +14,7 @@
+ #include <scsi/scsi_cmnd.h>
+ #include <scsi/scsi_device.h>
+ #include <scsi/scsi_host.h>
+-#include <linux/timer.h>
++#include "linux/timer_compatibility.h"
+ #include <linux/blkdev.h>
+ %}