summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Pellegrin2021-07-06 08:15:18 +0100
committerChristian Pellegrin2021-07-06 08:15:18 +0100
commit9108e8dc18c9f22294d67665bf293ab9a8a0ff91 (patch)
treeec56ecbdd783053b8449702a86b048cec35c3f9f
parent6b093b9789774551664c01a0fb69dc0215bcf194 (diff)
downloadaur-9108e8dc18c9f22294d67665bf293ab9a8a0ff91.tar.gz
upgpkg: systemtap 4.5-1
upstream release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 20 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae2282f286f8..ff0273a5ebde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,25 @@
pkgbase = systemtap
pkgdesc = Infrastructure to simplify the gathering of information about the running Linux system
- pkgver = 4.2
+ pkgver = 4.5
pkgrel = 1
url = http://sourceware.org/systemtap/
install = systemtap.install
arch = x86_64
arch = i686
license = GPL
- makedepends = python2-setuptools
+ makedepends = python-setuptools
makedepends = xmlto
depends = elfutils
depends = nss
- depends = python2
+ depends = python
depends = cpio
optdepends = sqlite3: for storing results in a database
- source = systemtap-4.2.tar.gz::https://sourceware.org/systemtap/ftp/releases/systemtap-4.2.tar.gz
- source = systemtap-4.2.tar.gz.asc::https://sourceware.org/systemtap/ftp/releases/systemtap-4.2.tar.gz.asc
+ source = systemtap-4.5.tar.gz::https://sourceware.org/systemtap/ftp/releases/systemtap-4.5.tar.gz
+ source = systemtap-4.5.tar.gz.asc::https://sourceware.org/systemtap/ftp/releases/systemtap-4.5.tar.gz.asc
validpgpkeys = F75E6545B9F8AA15AA932A444DE16D68FDBFFFB8
validpgpkeys = 5D38116FA4D3A7CC77E378D37E83610126DCC2E8
- sha512sums = 50d426e8c3d976fd635f6867fb4202832be455d869178a384159d1b2cd2a25642b07da2bd3184081b13bfb95df48a97f430b06713eaee0d0f67e27f43266cfd6
- sha512sums = ddb3217d9bbe7b9531b3d7ce24d88766e65629bd720228c0f8f96edc82216e13e5f0d0f30c8012cb85bf5ac7401f5a551aa69fc0505a29475ed61c548b4cdcf4
+ validpgpkeys = 159B0DF71150B8A8539A8802D7C256443CC637CA
+ sha512sums = 8136779a9f5cb0fbaae565eab1ab6fa307f1024dfc2c6c3845acfadff0eecc684ba89aa5d442c7b90c2c73edaab41ca07bae2bad8361f80fe8e9928b40466cd3
+ sha512sums = SKIP
pkgname = systemtap
-
diff --git a/PKGBUILD b/PKGBUILD
index 7f29799e5050..18acbe718d10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
-# Maintainer: An Nguyen (stk) <an@linux.com>
+# Maintainer: Christian Pellegrin (chripell) <chripell@fsfe.org>
+# Original Maintainer: An Nguyen (stk) <an@linux.com>
# Original Maintainer: George Angelopoulos <george@usermod.net>
# Original Maintainer: Christian Rebischke <Chris.Rebischke@archlinux.org>
# Original Maintainer: dront78 <dront78@gmail.com>
pkgname=systemtap
-pkgver=4.2
+pkgver=4.5
pkgrel=1
pkgdesc="Infrastructure to simplify the gathering of information about the running Linux system"
url="http://sourceware.org/systemtap/"
arch=('x86_64' 'i686')
license=('GPL')
-depends=('elfutils' 'nss' 'python2' 'cpio')
-makedepends=('python2-setuptools' 'xmlto')
+depends=('elfutils' 'nss' 'python' 'cpio')
+makedepends=('python-setuptools' 'xmlto')
optdepends=('sqlite3: for storing results in a database')
source=("${pkgname}-${pkgver}.tar.gz::https://sourceware.org/systemtap/ftp/releases/${pkgname}-${pkgver}.tar.gz"
"${pkgname}-${pkgver}.tar.gz.asc::https://sourceware.org/systemtap/ftp/releases/${pkgname}-${pkgver}.tar.gz.asc"
)
-sha512sums=('50d426e8c3d976fd635f6867fb4202832be455d869178a384159d1b2cd2a25642b07da2bd3184081b13bfb95df48a97f430b06713eaee0d0f67e27f43266cfd6'
- 'ddb3217d9bbe7b9531b3d7ce24d88766e65629bd720228c0f8f96edc82216e13e5f0d0f30c8012cb85bf5ac7401f5a551aa69fc0505a29475ed61c548b4cdcf4')
+sha512sums=('8136779a9f5cb0fbaae565eab1ab6fa307f1024dfc2c6c3845acfadff0eecc684ba89aa5d442c7b90c2c73edaab41ca07bae2bad8361f80fe8e9928b40466cd3'
+ 'SKIP')
install='systemtap.install'
+# Note, you need to run:
+# gpg --recv-keys --keyserver hkps://keys.openpgp.org/ 0xD7C256443CC637CA
+# unless /etc/pacman.d/gnupg/gpg.conf is updated.
validpgpkeys=('F75E6545B9F8AA15AA932A444DE16D68FDBFFFB8' # "Serhei Makarov (for Red Hat 2018..onwards) <smakarov@redhat.com>"
- '5D38116FA4D3A7CC77E378D37E83610126DCC2E8')
+ '5D38116FA4D3A7CC77E378D37E83610126DCC2E8'
+ '159B0DF71150B8A8539A8802D7C256443CC637CA')
build() {
cd "${pkgname}-${pkgver}"
./configure \